[BUG] Hybrid 2019.01.06.1 aus dem AUR für Linux-Arch
#11
(20.02.2019, 17:00)Selur Wrote: -> hab Dir nen Link per PM geschickt

Danke, Fehler sind weg Smile
(20.02.2019, 17:00)Selur Wrote: Der Screenshot hilft schon mal 0, da die Subjobs nicht zu sehen sind.

Den hatte ich nur anghängt, weil Hybrid da scheinbar die Chapter reinschreibt, wenn es fertig ist. Alles andere steht ja im Log.
Beim Starten des Jobs sieht der auch noch hanz normal aus, Subjobs eingeklappt und nur eine Zeile. Nach dem Durchlauf stehen dann komischerweise die Chapter mittendrin, sowohl bei Linux als auch bei Windows.

cu
Stefan
Reply
#12
Das Problem ist
Quote:--title "S04E01 - In Medias Res"
im Aufruf:
mkvmerge --ui-language en_US -o "/home/stefan/network/movies/Temp/series/The_Last_Ship-S04E01-'In_Medias_Res'.mkv" --title "S04E01 - In Medias Res" --global-tags "/home/stefan/.hybrid/temp/The_Last_Ship-S04E01-'In_Medias_Res'_20_47_49_0110__06.xml" -d 0 --default-track 0:yes --track-name 0:"FullHD 1080p" --default-duration 0:25/1fps --aspect-ratio-factor 0:1/1 --fourcc 0:MP4V --chapter-charset UTF-8 --chapters "/home/stefan/.hybrid/temp/The_Last_Ship-S04E01-'In_Medias_Res'_20_47_49_0110__07.chp" --compression -1:none --forced-track 0:yes --no-audio --no-subtitles "/home/stefan/.hybrid/temp/20_47_49_0110_04.264" --track-name 0:"Dolby Digital 5.1 (384kBit)" --language 0:de --default-track 0:yes --sync 0:12 --forced-track 0:no -a 0 --compression -1:none --no-video --no-subtitles --no-chapters "/home/stefan/.hybrid/temp/iId_9_aid_259_lang_de_DELAY_12ms_20_47_49_0110_01.ac3" --track-name 0:"Dolby Digital 2.0 (384kBit)" --language 0:en --default-track 0:no --sync 0:36 --forced-track 0:no -a 0 --compression -1:none --no-video --no-subtitles --no-chapters "/home/stefan/.hybrid/temp/iId_10_aid_260_lang_en_DELAY_36ms_20_47_49_0110_02.ac3"
2019.02.19 - 21:20:04_linux-64bit_5.5.1_2019.01.06.1 - level 4: output files(2): /home/stefan/network/movies/Temp/series/The_Last_Ship-S04E01-'In_Medias_Res'.mkv
eigentlich schreibt Hybrid alle Tags ins '--global-tags' file.
Da Hybrid im gesamten Source Code '--title' nicht verwendet, vermute ich, dass Du in der 'Mkvmerge command line addition' das hinzufügst, richtig?
(-> Ich schreib nen Workaround, damit alle custom additions beim Inputparsen ignoriert werden)

Cu Selur
Reply
#13
Yep, genau.

Ich hatte vorher mal versucht unter Config/Output/MKV Tags den Title zu setzen, das ist aber nie richtig im mkv angekommen (war vor zwei oder drei Jahren, ich müsste mal testen, ob das jetzt geht...), deshalb die CL-Addition. Hat auch immer problemlos funktioniert.
Dass das dazu führen könnte, dass plötzlich keine Ausgabe mehr geschrieben wird, ist mir nie in den Sinn gekommen Wink

Ich teste gleich anschließend mal die neue Version und melde mich dann wieder...

PS: Ich hab Hybrid in zwei VMs laufen, einmal Archlinux x64, einmal Win10 x64. Bei Linux bekomme ich beim Kodieren ca. 30fps, bei Win10 ca. 13, bei ansonsten gleicher Konfig der VMs und gleichen Einstellungen in Hybrid. Hast du eine Idee woran es da bei Windows hängt?

cu
Stefan
Reply
#14
Normale Tags werden gesetzt über im Tags-Tab. ('Base->Tabs->Tagging' aktivieren damit man es sieht)
Den Titel würde man dann über:
Aktivieren von "Tags->Container->Name" (+ Eingabe des Namens) setzen. (nicht vergessen 'Add to tag list' zu drücken damit der Eintrag in der Tag-Queue erscheint.

Quote: Hat auch immer problemlos funktioniert.
Bis zu dem Punkt wo 'Parallel subjob processing' eingeführt würde. Wink

Quote:Hast du eine Idee woran es da bei Windows hängt?
Ich vermute Du reencodest interlaced content und unter Windows wird dann QTGMC verwendet und da Du unter Linux weder Vapoursynth noch Avisynth installiert hast wird dort Yadif verwendet, was wesentlich schneller (und qualitativ schlechter) ist.

Cu Selur
Reply
#15
Ok, das macht Sinn. Ich lass mal beides für die Episode aus dem Debuglog laufen und schau mir anschließend die Ergebnisse mal im Vergleich an...
Ich vermute aber mal, da das dvb-Quellmaterial sowieso nicht unbedingt BluRay Qualität ist werden die Unterschiede wohl nicht so gravierend sein (zumindest was mich angeht, ich hab nicht gerade Adleraugen Wink ).

cu
Stefan
Reply
#16
Thumbs Up 
Hi Selur,

die Erstellung der Ausgabedateien klappt jetzt wieder. Danke für die schnelle Hilfe und den Tip mit den Tags Smile
Ich hab wohl damals beim rumprobieren einfach vergessen, im ersten Tab 'Add to tag list' zu klicken Wink

cu
Stefan
Reply
#17
Zu früh gefreut Sad
Da scheint was nicht zu stimmen mit dem Aufruf von d2vwitch in der Windows dev-Version die du geschickt hast.
Log ist angehängt...

cu
Stefan


Attached Files
.7z   HybridDebugOutput.7z (Size: 3,45 KB / Downloads: 7)
Reply
#18
Laut DebugOutput, crashed es beim Aufruf von:
"C:\Program Files\Hybrid\64bit\vsfilters\SourceFilter\d2vSource\d2vwitch.exe" --output "C:\Users\stefan\Videos\Hybrid.tmp\20_29_44_0310.d2v" "M:\serie\TVOPB8~D.TS"
Was passiert denn wenn das in einer Windows Command Prompt aufrufst?
(bitte keinen Screenshot, den Inhalt einer Windows Command Prompt kann man kopieren)

Cu Selur
Reply
#19
Die Datei TVOPB8~D.TS existiert dort nicht. Keine Ahnung wo er den Dateinamen herzaubert Huh
Der Aufruf müsste eigentlich heißen:
Quote:"C:\Program Files\Hybrid\64bit\vsfilters\SourceFilter\d2vSource\d2vwitch.exe" --output "C:\Users\stefan\Videos\Hybrid.tmp\20_29_44_0310.d2v" "M:\serie\The Last Ship - S04E01 - In Medias Res.ts"

cu
Stefan
Reply
#20
"M:\serie\TVOPB8~D.TS" ist ein "Windows 8.3 filename" (https://de.wikipedia.org/wiki/8.3).
-> Hast Du den Aufruf mal ausgeführt?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)