[HELP] 264 is too small
#1
I'm using Windows 10 64-bit and Hybrid 2019.02.23.1
It was fine when I encoded a video without filter in Avisynth.
Then I got an error when using it:
18_51_50_9110_03_video crashed: ERROR: D:\Snapshot\18_51_50_9110_03.264 is too small! (byteSize: 0byte)
I read this thread. But since Hybrid already using Avisynth+, I don't know what to do.
Debug log.
Reply
#2
Does the Avisynth Preview work properly?
Is your system overclocked?
What cpu do you use?
Try disabling 'Config->Internals->Avisynth->Prefer FFmpeg as decoder' and enable 'Config->Internals->Avisynth->Prefer avs2yuvas decoder'.

Encoding call:
"C:\PROGRA~1\Hybrid\32bit\ffmpeg.exe" -y -loglevel fatal -threads 4 -i "D:\Snapshot\encodingTempSynthSkript_18_51_50_9110.avs" -an -sn   -vf zscale=rangein=tv:range=tv -pix_fmt yuv420p10le -strict -1 -vsync 0  -f rawvideo - | "C:\PROGRA~1\Hybrid\64bit\x264.exe" --crf 17.00 --profile high10 --ref 16 --keyint 250 --min-keyint 0 --scenecut 40 --bframes 16 --b-bias 0 --b-pyramid normal --direct spatial --b-adapt 0 --cplxblur 20.0 --qcomp 0.7 --qblur 0.5 --mbtree --rc-lookahead 40 --ipratio 1.4 --pbratio 1.3 --chroma-qp-offset 0 --qpmin 0 --qpmax 81 --qpstep 4 --partitions i4x4,i8x8,p8x8,b8x8 --8x8dct --me umh --merange 16 --mvrange -1 --subme 10 --cabac --trellis 2 --psy-rd 1.00:0.00 --weightp 2 --aq-mode 1 --aq-strength 1.0 --nr 0 --deadzone-inter 21 --deadzone-intra 11 --cqm flat --pic-struct --threads auto --sar 1:1 --deblock 0:0 --range tv --colormatrix bt709 --demuxer raw --input-res 1280x720 --input-csp i420 --input-range tv --input-depth 10 --fps 24000/1001 --output-csp i420 --output-depth 10 --output "D:\Snapshot\18_51_50_9110_03.264" -
and the Avisynth script:
LoadCPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\ffms2.dll")
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\flash3kyuu_deband.dll")
SetFilterMTMode("DEFAULT_MT_MODE", MT_MULTI_INSTANCE)
# loading source: D:\Downloads\Tate no Yuusha\[HorribleSubs] Tate no Yuusha no Nariagari - 07 [720p].mkv
#  input color sampling YV12
#  input luminance scale tv
FFVideoSource("D:\DOWNLO~1\TATENO~1\_HORRI~3.MKV",cachefile="D:\Snapshot\18_51_50_9110.ffindex")
# current resolution: 1280x720
# filtering
# debanding
f3kdb(range=27,dither_algo=3,grainY=1,grainC=1,dynamic_grain=true,Y=64,Cb=64,Cr=64)
# adjusting bit depth current 8 to target 10
# convert to 10bit for encoder
ConvertBits(10, dither=1)
PreFetch(4)
return last
seem fine to me.

Cu Selur
Reply
#3
Yes, the Avisynth Preview works normally.
I'm using really old laptop CPU Intel Core i5 2450M @ 2.50GHz and it's not overclocked.
I tried this: Try disabling 'Config->Internals->Avisynth->Prefer FFmpeg as decoder' and enable 'Config->Internals->Avisynth->Prefer avs2yuvas decoder'.
But it crashed.
Debug log.
Reply
#4
What happens if you call:
"C:\PROGRA~1\Hybrid\32bit\avs2yuv.exe"  "D:\Snapshot\HybridDebug\encodingTempSynthSkript_07_02_44_5510.avs" -csp I420 -o -
2019.02.27 - | "C:\PROGRA~1\Hybrid\64bit\x264.exe" --crf 17.00 --profile high10 --ref 16 --keyint 250 --min-keyint 0 --scenecut 40 --bframes 16 --b-bias 0 --b-pyramid normal --direct spatial --b-adapt 0 --cplxblur 20.0 --qcomp 0.7 --qblur 0.5 --mbtree --rc-lookahead 40 --ipratio 1.4 --pbratio 1.3 --chroma-qp-offset 0 --qpmin 0 --qpmax 81 --qpstep 4 --partitions i4x4,i8x8,p8x8,b8x8 --8x8dct --me umh --merange 16 --mvrange -1 --subme 10 --cabac --trellis 2 --psy-rd 0.40:0.00 --weightp 2 --aq-mode 1 --aq-strength 0.6 --nr 0 --deadzone-inter 21 --deadzone-intra 11 --cqm flat --pic-struct --threads auto --sar 1:1 --deblock 1:1 --range tv --colormatrix bt709 --demuxer y4m  --input-range tv --fps 24000/1001 --output-csp i420 --output-depth 10 --output "D:\Snapshot\HYBRID~1\07_02_44_5510_03.264" -
inside a command prompt? (you can copy the content of a command prompt window, so ne need for screenshots)

While running this check the RAM usage on your system.

Cu Selur
Reply
#5
Like this?


C:\Users\ATLUS>"C:\PROGRA~1\Hybrid\32bit\avs2yuv.exe"  "D:\Snapshot\HybridDebug\encodingTempSynthSkript_07_02_44_5510.avs" -csp I420 -o -
error: ConvertBits: dithering is allowed only for scale down
(D:\Snapshot\HybridDebug\encodingTempSynthSkript_07_02_44_5510.avs, line 14)

C:\Users\ATLUS>2019.02.27 - | "C:\PROGRA~1\Hybrid\64bit\x264.exe" --crf 17.00 --profile high10 --ref 16 --keyint 250 --min-keyint 0 --scenecut 40 --bframes 16 --b-bias 0 --b-pyramid normal --direct spatial --b-adapt 0 --cplxblur 20.0 --qcomp 0.7 --qblur 0.5 --mbtree --rc-lookahead 40 --ipratio 1.4 --pbratio 1.3 --chroma-qp-offset 0 --qpmin 0 --qpmax 81 --qpstep 4 --partitions i4x4,i8x8,p8x8,b8x8 --8x8dct --me umh --merange 16 --mvrange -1 --subme 10 --cabac --trellis 2 --psy-rd 0.40:0.00 --weightp 2 --aq-mode 1 --aq-strength 0.6 --nr 0 --deadzone-inter 21 --deadzone-intra 11 --cqm flat --pic-struct --threads auto --sar 1:1 --deblock 1:1 --range tv --colormatrix bt709 --demuxer y4m  --input-range tv --fps 24000/1001 --output-csp i420 --output-depth 10 --output "D:\Snapshot\HYBRID~1\07_02_44_5510_03.264" -


Sorry, I'm not very fond of using cmd, so maybe I did it wrong.
No difference in RAM usage.
Reply
#6
I see the problem will fix after work.
Reply
#7
Got it fixed, but can't send you a link to a dev version since you disabled PMs.

Cu Selur
Reply
#8
Ah, sorry. 
Should be okay right now.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)