Moov Atom
#1
Hello,

I'm trying to encode .mp4 files in hevc for browsers.

Apparently that means, that I have to moove the moov atom in the beginning of the files.

Are there any settings in Hybrid that do that?


Thanks,
Sandra
Please, read the 'Infos needed to fix&reproduce bugs,..'-sticky before you post about a problem.Please, read the 'Infos needed to fix&reproduce bugs,..'-sticky before you post about a problem.
Reply
#2
Quote:Are there any settings in Hybrid that do that?
Yes.
Quote:Interleave/FastStart:
To prepare a file for HTTP download, the following instruction will interleave file data by chunks of X milliseconds in order to enable playback while downloading the file (HTTP FastStart).

When ffmpeg instead of MP4Box is used, the interleave value can not be set manually.

Side note:
Typically a value of 500 is used for X.
source: tool-tip of 'Config->Output->Container Settings->Mp4 Settings->Interleave'.

Cu Selur
Reply
#3
You can also verify it yourself by using AtomicParsley:

AtomicParsley.exe Test.mp4 -T

And it should show on the second line right after the "ftyp" atom:
E:\Test>AtomicParsley.exe Test.mp4 -T
Atom ftyp @ 0 of size: 24, ends @ 24
Atom moov @ 24 of size: 1127899, ends @ 1127923
    Atom mvhd @ 32 of size: 108, ends @ 140
    Atom iods @ 140 of size: 21, ends @ 161
    Atom trak @ 161 of size: 358098, ends @ 358259
        Atom tkhd @ 169 of size: 92, ends @ 261
....
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)