[HELP] ScreenRecorder File enkodieren - Ton asynchron
#1
Hallo,

Hybrid ist neu für mich und auch wenn ich schon MeGui gearbeitet habe werde ich hier von den gebotenen Möglichkeiten förmlich erschlagen :

Ich möchte Videomitschnitte die mit Nvidia Shadowplay (Geforce Experience) aus dem Spiel heraus gemacht habe auf eine definierte Dateigröße runterkomprimieren.
Das Ausgangsmaterial ist mit variabler Bitrate so wie auch mit variabler Framerate erstellt worden.
Die Einstellungen bei der Auzeichnung sind : 1920x1080 bei 60fps
Frame rate mode                 : Variable
Frame rate                          : 60.000 FPS
Minimum frame rate             : 2.966 FPS
Maximum frame rate            : 77.453 FPS


das wird mit Avidemux oder Lossslesscut geschnitten sprich am Anfang und Ende getrimmt. Die geschnnittene Datei hat dann in beiden Fällen 59.940fps.
Frame rate mode                : Variable
Frame rate                         : 59.940 (59940/1000) FPS
Minimum frame rate            : 2.966 FPS
Maximum frame rate           : 77.453 FPS
Original frame rate              : 60.000 FPS

Diese geschnittene Datei lade ich in Hybrid : ich wähle X264 - specific Filesize/Bitrate 495mb - resize auf 1280x720 / Audio custom : aac oder mp3 128kbit (möchte möglichst gutes Bild, daher von 196 auf 128)

Mein enkodiertes Video sieht dann schön aus, nur leider ist der Ton asynchron.

Das Problem ist wohl die variable Framerate, so bin ich auch auf Hybrid gekommen, hier gibt es Möglichkeiten diese auch einzustellen. Filtering -> Speedchange oder Avisynth -> Frame

Aber irgendwie will das alles nicht so hinhauen ; entweder crashed Hybrid oder der Ton ist asynchron.

Auf google finde ich häufig die Lösung das man die Aufnahme mit Handbrake auf eine konstante Framerate bringt, und dann erst Videobearbeiteung zu macht.

Kann mir jemand hier bitte einen Tip geben wie ich Hybrid einstellen muss um die Ton synchron zu bekommen ?

Falls gewünscht kann ich eine Videodatei zum testen hochladen.
Reply
#2
Kann das leider nicht nachstellen (sticky lesen) und deshalb nur allgemein anworten:
  • wenn Hybrid die Quelle als vfr identifiziert wird es die Timecodes extrahieren und versuchen diese auch dem Output hinzufügen.
    Wird die Quelle initial nicht als vfr identifiziert, kann man Hybrid mit "Config->Automation->On Load->Always extract timecodes from input" sagen, dass es die Timecodes auf jeden Fall extrahieren soll, anhand der TimeCodes wird dann entschieden ob der Input vfr ist oder nicht.
  • wenn Du cfr als output haben willst, solltest Du Config->Input->Decoding->CFR output aktivieren

Cu Selur
Reply
#3
Danke für die schnelle Antwort, ich habe einiges Material hochgeladen und eine PM an dich geschickt.
Reply
#4
Die zwei Dateien bei der eine okay ist und die andere nicht erlauben mir nicht keine Rückschlüsse auf den Input ziehen.
Sehe leider keine Möglichkeit das Problem nachzustellen.
Was ich brauche um das Problem mit Deiner Quelle nachzustellen ist die Datei die Du Hybrid fütterst.

Cu Selur
Reply
#5
-> Hab Dir ne PM mit nem Link zu einer dev Version geschickt, die das Problem fixen sollte.

Cu Selur
Reply
#6
Hallo, ich hab deine neue version von hybrid ausprobiert : das wird leider nicht besser, Ton und Video laufen imer noch auseinander bei mkv und mp4 und immer noch der selben Quelldatei. Ich habe Hybrid auch nochmal deinstalliert und neu installiert.

Frage and Dich : hast du es denn bei dir synchron bekommen ? 

Noch was anderes : kann es sein das die Datei Raisy2.mkv nicht mit mkvmerge gemuxt worden ist ? - kann man hybrid das auch mit ffmpeg machen lassen?
Reply
#7
Hatte einen schnellen Reencode gemacht der mir synchron erschien. (Werde ich noch mal machen und Dir nen Link per PM schicken.)
Nein, Hybrid nutzt immer mkvmerge zum Erstellen von MKVs. Würde mich wundern wenn ein Multiplexen mit ffmpeg da irgendwie hilft.

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)