This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[BUG] fail to to the final muxing when parallel subjob processing and timecodes
#1
Hi,

When activating parallel subjob processing and dealing with a source file with timecodes, the timecode file is deleted before the final muxing happens. I presume there is some sort of dependency order that is not correct. The few last lines are:


-> should be there after processing: /tmp/Exodus (1960) 1080p_new_08_39_31_7310_03.264
starting 08_39_31_7310_03_video@08:39:32.940 - /home/marc/Downloads/retrieve/Exodus (1960) 1080p_new.mkv
finished after 00:00:02.458
-> should be there after processing: /home/marc/Downloads/retrieve/Exodus (1960) 1080p_new.mkv
starting 08_39_31_7310_05_muxing@08:39:35.403 - /home/marc/Downloads/retrieve/Exodus (1960) 1080p_new.mkv
delete /tmp/timecodeV2_08_39_31_7310.tc
Error: The timestamp file '/tmp/timecodeV2_08_39_31_7310.tc' could not be opened for reading.
finished after 00:00:00.035
-> 08_39_31_7310_05_muxing crashed: ERROR: /home/marc/Downloads/retrieve/Exodus (1960) 1080p_new.mkv was not created!
Aborting '08_39_31_7310_05_muxing' due to: ERROR: /home/marc/Downloads/retrieve/Exodus (1960) 1080p_new.mkv was not created!

I've got the full debug log if necessary, but this seems self explanatory

Regards
Reply
#2
Please add the debug output so I can see in which Order the queue was processed.
-> forget the debug output, I can reproduce the issue, will look into it
Reply
#3
Think I fixed it, will send you a link to a dev version via PM for you to test in a few minutes.

Cu Selur
Reply
#4
(04.12.2019, 18:05)Selur Wrote: Think I fixed it, will send you a link to a dev version via PM for you to test in a few minutes.

Cu Selur
Hey, I was collecting the debug output ! Smile

Do you still want it ?
Reply
#5
Nope
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)