This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[HELP] MP4Box crashes when muxing UHD4K 10-bit color video
image of crashed mp4box step

What skill level are you?                    Data Engineer by profession, worked with ffmpeg command line for years
What Hybrid version did you use?      Hybrid 2020.12.13.1 running on OSX Big Sur
What did happen?                            MP4BOX crashed while trying to create MP4 from MKV

What did you do to get to the bug?
  1. Found a very small UHD4k 10-bit test video
  2. Left all options at their defaults EXCEPT for the following:
    a. use x265 CODEC
    b. force 10-bit color
    c. don't ignore audio
    d. Matroska input file
    e. average bit rate 1-pass 800k

...I'm pretty sure that it's because I need to set an advanced option or something. I'd really really like to solve this because so far, Hybrid is the ONLY app that I've found that will properly transcode UHD4K 10-bit color video on my MacBook. All the others I've tried dither it back to 8-bit color. Dithered 8-bit color makes the colors all washed out, like a permanent fog.
Debug file is attached.
Thank you.
Please, read the 'Infos needed to fix&reproduce bugs,..'-sticky before you post about a problem.Please, read the 'Infos needed to fix&reproduce bugs,..'-sticky before you post about a problem.
Crash happens due to a missing library (deleted it accidentally).
MP4Box output: dyld: Library not loaded: @executable_path/lib/libx265.179.dylib
  Referenced from: /Applications/
  Reason: image not found
-> I'll look into it and send you a link to fixed version via PM once I'm finished.

Cu Selur

Ps.: As a workaround enabling 'Config->Containers->Mp4 Settings->FFmpeg instead of MP4Box' should work.
Send you a link to a dev version which should fix the issue.
Let me know whether it worked.

Cu Selur

Forum Jump:

Users browsing this thread: 1 Guest(s)