This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[BUG] m2ts was not created
#41
Quote:Yet another reason not to go Catalina
More like hitting Apple developers,.. Big Grin
Reply
#42
Okay, I added a new tsMuxeR version and adjusted Hybrid, it should now work on MacOS 10.14.
It will not work on newer MacOS since:
a. tsMuxeR can't handle symlinks.
b. tsMuxeR only searches /Library/Fonts, which (starting with Catalina) is typically only populated with symlinks.
see: https://github.com/justdan96/tsMuxer/iss...-922433515
-> send you a link via pm for testing.

Cu Selur
Reply
#43
So for 10.14 should we use tsMuxer from Hybrid but not versions from Hithub?
Reply
#44
The tsMuxeR version which came with the dev build I send you last works with 10.14 as you know. Can't say whether the new tsMuxeR version from GitHub will still work with 10.14.

Cu Selur
Reply
#45
Hybrid_dev_2021.09.19 have same problem with "tsMuxeR can't be used." Seems i static libraries fix is missing. PM'ed you details.
Reply
#46
I read your PM, thought I adjusted the tsMuxeR in that package, will compress it again.

Cu Selur
Reply
#47
Updated Hybrid tsMuxer version works well on 10.14, but i didn't test it with subtitles.

If your subtitles fix works in Hybrid, so maybe you can suggest the solution for tsMuxer developers so they keep macOS 10.14 support for tsMuxer GUI?
Here is new separate thread about his problem https://github.com/justdan96/tsMuxer/issues/463

Here is also separate new thread for static libs fix here https://github.com/justdan96/tsMuxer/issues/462
Reply
#48
(19.09.2021, 10:19)Selur Wrote: Okay, I added a new tsMuxeR version and adjusted Hybrid, it should now work on MacOS 10.14.
It will not work on newer MacOS since:
a. tsMuxeR can't handle symlinks.
b. tsMuxeR only searches /Library/Fonts, which (starting with Catalina) is typically only populated with symlinks.
see: https://github.com/justdan96/tsMuxer/iss...-922433515
-> send you a link via pm for testing.

Cu Selur

Hi Selur,

I tried again with your new version but got the same result.
I send the debug.

(19.09.2021, 21:05)shijan Wrote: If your subtitles fix works in Hybrid, so maybe you can suggest the solution for tsMuxer developers so they keep macOS 10.14 support for tsMuxer GUI?

Actually the last version of tsMuxer Gui works well on macOS 10.14, even with subtitles (I tried it).
The sub problem occurs with macOS 10.15 and up, as I understood because I'm on 10.14.


Attached Files
.zip   HybridDebugOutput.txt.zip (Size: 61,77 KB / Downloads: 26)
Reply
#49
(19.09.2021, 22:51)LaurentS Wrote: Actually the last version of tsMuxer Gui works well on macOS 10.14, even with subtitles (I tried it).
The sub problem occurs with macOS 10.15 and up, as I understood because I'm on 10.14.

Release version 2021-09-09-02-03-09 works 10.14, but newer dev. builds from github discussion threads don't works on 10.14 until they figure how to fix fonts reading problem for both old and new macOS versions.
Reply
#50
(19.09.2021, 23:37)shijan Wrote: Release version 2021-09-09-02-03-09 works 10.14, but newer dev. builds from github discussion threads don't works on 10.14 until they figure how to fix fonts reading problem for both old and new macOS versions.

ah ok, I didn't know.
I'm fine with official version Blush
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)