This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

No A/V/ delay taken into account
#1
Hello,
I am using Hybrid version 2021.07.18.1 MacOS version.
It is as if the value in A/V delay is not taken into account. I have to go to MKVToolnix to delay the audio track.
It appears with and without burning subtitles.

A way to overcome this trouble ?

Best regards,

FrédéricPlease, read the 'Infos needed to fix&reproduce bugs,..'-sticky before you post about a problem.
Reply
#2
Quote:Please, read the 'Infos needed to fix&reproduce bugs,..'-sticky before you post about a problem.
Rolleyes
Reply
#3
(20.09.2021, 19:04)Selur Wrote:
Quote:Please, read the 'Infos needed to fix&reproduce bugs,..'-sticky before you post about a problem.
Rolleyes
Sorry, I thought it wouldn't necessarily be useful.

Here you'll find the output.
Best regards,


Attached Files
.zip   Compress.zip (Size: 703,87 KB / Downloads: 13)
Reply
#4
To be clear : I think that the A/V delay is always read within the files, even if you specify a typical delay in the interface.
Maybe the field in the interface is not refreshed

For a mkv file loaded, with a delay 1000ms indicated within the file, but in fact there is no delay, 
if I write 1000 or 0 ms in the A/V delay filed, the output file is always out of sync, shifted.
I did one more times the encoder of one file, with 1000 ms as delay, and with 0 delay. I always got a shifted file; and playing thoses files with smplayer, I always put a delay to the audio track to sync the audio and the video (for both files, 1000 ms delay and 0ms delay).

You will find the output debug file compressed.

BR


Attached Files
.zip   Compress2.zip (Size: 463,42 KB / Downloads: 15)
Reply
#5
Looking at the audio queue
/Users/Famille/Downloads/The.Suicide.Squad.2021.MULTi.TRUEFRENCH.1080p.WEB.H264.WwW.ZoNe-TelecharGement.CaM (1).mkv;0;aac;6;bitrate;192;FDK;low complexity;48000;3.00;fr;950;7966.080;ac3;0;0;toStereo (dpl2);;false;;false;2;false;;;;true;false;;;false;48000;0;ac-3;;false;true;false;3/2/0.1;1/1;;1000;0;;None;54:_:15;10;20;0;1000;;false;;pcm;false;3;;;;;;16;-n;4;GPU;NVIDIA CUDA;;6;false;/Users/Famille/Downloads/The.Suicide.Squad.2021.MULTi.TRUEFRENCH.1080p.WEB.H264.WwW.ZoNe-TelecharGement.CaM (1).mkv;true;false;;;false;2;;;-1;;
the audio queue entry was created with a delay of 950ms.

-> my guess is that you changed the delay in the frontend, but didn't adjust the audio queue entry.

Cu Selur
Reply
#6
So, the next version will fix the problem ? If you prefer, I could do tests after corrections in the code.
BR
Reply
#7
From what I see there is no bug.

Let's explain to you how Hybrid works in regard to audio assuming audio is set to 'Custom'.
a. you load a source and the source is analysed
b. you switch to the Audio-tab
c. you configure the settings for each auio stream you want to handle
d. whenever you configured the settings, you add them to the audio queue
only stuff that is in the audio queue will be done during job creation.

So atm. it seems like you added entries to the audio queue, and later modified the settings in the gui, but did not add the settings to the audio queue.

If you for example load a source file, set audio processing to "passhtrough (all)' Hybrid will create a audio passthrough entry for each audo stream.
If you then switch to custom audio modify settings, but do not add those changed settings to the audio queue nothing relevant to Hybrid happend.

Cu Selur
Reply
#8
I do not understand what the connexion of what you say, and what I did/generally do.

Of course, I change the audio delay, and add it into the queue (I click on the +).
Then, I put the global job (video, audio).

After, I change the delay, remove the previous selection, and add into the queue the new audio prescription (with an other delay for example).

I did in that way with the windows software, and that since 4 years.
I really think that it is a bug, in the maxOS version. Or I must change the way to transcode with the new version of Hybrid.
Tell me what to do, I am in a bind ...
Best regards
Reply
#9
What I do is:
  • Start Hybrid (Base->Video Processing is set to x264, Base->Audio->Processing is set to 'ignore' after the start)
  • Load a source. (which has an audio delay)
  • Set "Base->Audio->Processing" to "Custom"
  • Enable "Audio->Base->Audio Encoding"
  • Set "Audio->Base->Audio Encoding->Encoder->Audio Format" to "opus"
  • Set "Audio->Base->Audio Surce->A/V delay (ms)" to "0"
  • Press "Audio->Base->Add current"
then I look at the audio queue entry:
G:\TestClips&Co\files\MPEG-4 H.264\delayTest_audio_needs ffmpeg extract enabled.ts;6120;mp2;2;passthrough;256;;;48000;;de;0;33.960;mp2;0;1;don't change;;false;;false;4;false;;;;true;false;;;false;48000;unknown;mp2;;false;true;false;;1/1;;;;;None;;;;;;;;;pcm;false;3;;;;;;;;;;;6120;2;false;G:\TestClips&Co\files\MPEG-4 H.264\delayTest_audio_needs ffmpeg extract enabled.ts;true;false;;;false;2;;;-1;
and look at the 12th entry, which in my case is 0.
When I look at your audio queue entry it's '950'.

You must be doing some thing different then me.
Since I can not reproduce it here, you write a detailed step-by-step of what you do and what audio queue entry you get?
(no need to test the encoding, if the delay entry (12th) is wrong, the job will be wrong)

Cu Selur
Reply
#10
Hello, and first, many thanks for replies, and sorry to be so boring

This is exactly what I did.

I did it one more time :
  • I load the mkv video
  • Then, I enable the audio, and set to custom
  • I enable te encoder : I usually use the aac encoder (fdk), which gives me good results, in mp4 container (and recognised by my TV though DLNA protocol)
  • I encode the video too, with a typical bitrates ...
  • I put a name for the output file (click Output File), and then I Click on Add to Queue
  • Then, I start the queue.
The audio is set (in the frontend, see screen captures) to a delay of -50 ms, which is normal.
The result, after the enconding, is a file with a delay of 1000 ms! I see that with smplayer.

2 possible sources of error : either the source file is corrupted ... (and I will try with another file with a 0 delay and with a 1000 ms delay), nor the 0 I put in the frontend is not taken into account, and the program reads what it is written in the source file (1000) even if I specify a 0 delay.

By the way, tell me if I am wrong somewhere, and I will continue to do more tests as I said just before (to see if it occurs with another source file).

But it is very strange : I used hybrid on windows since about 5 (or more) years, without troubles on delays. It is with the macOS version that I have troubles with delays.
(I had troubles on windows with subtitles to burn on the video)

Best regards,


Attached Files Thumbnail(s)
       
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)