This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Absturz mit XviD
#1
Hallo, beim Encoden mit XviD crasht Hybrid bei mir. Ich verwende die neueste Version 2021.07.18.1, die Debug-Datei kann ich gerne zur Verfügung stellen - leider bekomme ich die Fehlermeldung, dass sie zu groß ist und ich sie deswegen nicht mit anhängen kann (Größe 240 KB).
Quellvideo ist eine MP4-Datei, die ich von FullHD zu SD resize, mit fest eingebrannten Untertiteln.
Reply
#2
Ohne DebugOutput ist schwer zu sagen was da schief geht.
Schicke Dir gleich einen Link zu meiner aktuellen dev Version, da ich das Problem eventuell die Tage schon gefixed hatte.
(alte Jobs müssen gelöscht und alte Version deinstalliert werden vor der Installation der dev Version)

Cu Selur

Ps.: wenn man die Datei packt sollte sie kleiner werden und man kann sie dann auch anhängen.
Reply
#3
Anbei die gezippte Debug-Datei.


Attached Files
.zip   HybridDebugOutput.zip (Size: 626,03 KB / Downloads: 5)
Reply
#4
Link hatte ich per PM geschickt.
Reply
#5
Vielen Dank, ich teste es dann mit der neuen Version im Laufe des Tages.
Reply
#6
Alles klar, falls es mit der dev Version auch nicht geht mach nochmal mit der nen DebugOutput.

Cu Selur
Reply
#7
Mit der dev-Version stürzt XviD nun nicht mehr ab. Ein anderes Problem habe ich aber bei der Erstellung der avi-Datei festgestellt: Diese ist defekt. Mit PowerDVD ist sie nicht abspielbar und MPC-HC spielt sie nur mit Artefakten ab. Das Problem liegt am Muxen mit mencoder. Wenn ich in den Optionen nämlich auf Muxen mit ffmpeg umstelle, funktioniert die avi-Datei einwandfrei. Eine Debug-Datei wird wohl keinen Sinn machen, da keine Fehlermeldung angezegt wird.
Reply
#8
Hab hier mal ein paar Clips umgewandelt und bei mir gibt es keine Probleme.

Ist der Avisynth Preview okay?
Wie groß ist die Datei? Soweit mir bekannt erstellt mencoder immer opendml .avi Dateien (wenn man nicht '-noodml' verwendet) , aber vielleicht gibt es da ein Problem.

Cu Selur
Reply
#9
Ja, die AviSynth-Preview sieht ok aus. Die Datei ist je nach Encoder-Einstellungen 550-650MB groß. 
Ich schätze, dass es ein Bug von mencoder ist, wenn die mit ffmpeg gemuxte Datei ok ist.
Reply
#10
Komisch ist halt, dass der Effekt bei mir nicht auftritt.
Wie sieht es aus wenn Du so eine kaputte Datei in Hybrid öffnest audio&video auf passthrough setzt, FFmpeg als Muxer nimmst, ist der Output dann auch okay?
Passiert das bei Dir auch wenn Du eine kleine Datei umwandelst?

Wenn ich wüsste woran es liegt, könnte ich vielleicht nen Workaround schreiben, dass je nach dem FFmpeg verwendet wird als Muxer. (mencoder wird schon seit Jahren nicht mehr weiter entwickelt, da wird sich also nichts tun)
Problem ist halt, dass der Effekt hier nicht auftritt, alle Dateien die ich erstelle habe sind einwandfrei in MPC-HC abspielbar,...

HA! Idee ! Vielleicht liegt es am FOURCC. Vielleicht wird bei Dir für XviD ein hardware decoder verwendet je nach FOURCC.
Check mal:
1. Was MediaiInfo zu den zwei Dateien sagt.
2. Ob die gleichen Decoder im MPC-HC bei Dir verwendet werden.

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)