This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

AVI: Stream 1 (audio) has a non-zero start position
#1
I encoded the file in Hybrid and opened it in virtualdub.
Virtualdub displays a message:

Quote:AVI: Stream 1 (audio) has a non-zero start position of 1152 samples (+24
    ms). VirtualDub does not currently support a non-zero start time and the
    stream will be interpreted as starting from zero.
Source file opens normally in virtualdub.

I encoded the file with Xvid codec in Hybrid.
Target file is not playable.
Mediainfo:

General
...
Duration : 2 min 41 s

Video
...
Duration : 2 min 25 s

Audio
...
Duration : 2 min 41 s

In the source file video and audio durations are the same.


Attached Files
.zip   HybridDebugOutput.zip (Size: 57,59 KB / Downloads: 5)
.zip   HybridDebugOutput-.zip (Size: 76,61 KB / Downloads: 4)
Reply
#2
Quote:AVI: Stream 1 (audio) has a non-zero start position of 1152 samples (+24 ms). VirtualDub does not currently support a non-zero start time and the stream will be interpreted as starting from zero.
So, did you ask the VirtualDub authors when they will fix this?

How I see it:
  • MediaInfo reports:
    Delay                                    : 24 ms
  • You configured Hybrid to fix that delay using DelayCut (Audio->Misc->Fix input with delay cut).
  • Hybrid does as instructed.
  • The tool you choose to handle that stream isn't capable to handle it.
-> you should try disabling 'Audio->Misc->Fix input with delay cut' (which is not enabled by default)

Cu Selur
Reply
#3
(02.05.2022, 05:09)Selur Wrote:
Quote:AVI: Stream 1 (audio) has a non-zero start position of 1152 samples (+24 ms). VirtualDub does not currently support a non-zero start time and the stream will be interpreted as starting from zero.
So, did you ask the VirtualDub authors when they will fix this?

How I see it:
  • MediaInfo reports:
    Delay                                    : 24 ms
  • You configured Hybrid to fix that delay using DelayCut (Audio->Misc->Fix input with delay cut).
  • Hybrid does as instructed.
  • The tool you choose to handle that stream isn't capable to handle it.
-> you should try disabling 'Audio->Misc->Fix input with delay cut' (which is not enabled by default)

Cu Selur

This bug was created by Hybrid. Previous versions of Hybrid did not have this bug. Virtualdub didn't give the above message when opening encoded in the Hybrid files.
'Audio->Misc->Fix input with delay cut' - It has always been disabled.
Quote:The tool you choose to handle that stream isn't capable to handle it.
I didn't understand it.

I have enable 'LibavVideoSource instead of FFmpegSource'.
'LibavVideoSource' isn't capable to handle it?
Reply
#4
I haven't touched any of the code related to muxing for ages, so I doubt it's Hybrid itself, that is causing you issues.

Have you tried as I suggested?

Quote:'LibavVideoSource' isn't capable to handle it?
How can I say, I don't have the file nor a step-by-step how to reproduce the issue.
You didn't provide a sample. You didn't even mention what VirtualDub version you are using.
Since the classic VirtualDub does use vfw interfaces it might also be due to some changes in the codecs on your system.

Quote:Virtualdub didn't give the above message when opening encoded in the Hybrid files.
Are you sure you did use the exact same Xvid settings as before?

Quote:This bug was created by Hybrid. Previous versions of Hybrid did not have this bug.
So this does work with the previous version 2022.03.19.1 ?
If it does, you can try whether switching mencoder and/or ffmeg and/or xvid_encraw binaries changes anything.
You can even try whether removing xvid_encraw helps. (Hybrid will then use mencoder for Xvid encoding. Xvid encraw was added back in 2020.10.10.)


Cu Selur
Reply
#5
Quote:You didn't provide a sample. You didn't even mention what VirtualDub version you are using.

Sample

Quote:what VirtualDub version you are using
Build 35576 (1.10.5, experimental): [October 13, 2014]
Quote:you can try whether switching mencoder and/or ffmeg

Thank you for helpful advice:
'Config' - 'Containers' - 'Avi settings' - I check box "Always use ffmepg for muxing".
After this - no problem.
Reply
#6
Okay, then it's an issue when mencoder is used for muxing.
Hmm,....
How large are your output files?

Cu Selur
Reply
#7
(03.05.2022, 17:48)Selur Wrote: Okay, then it's an issue when mencoder is used for muxing.
Hmm,....
How large are your output files?

Cu Selur

When output as Xvid codec File size : 78.5 MiB (full duration 2 min 41 s)
When output as UTvideo codec File size : 239 MiB (duration 41s cutted with Hybrid)
Reply
#8
Hmm, in both cases the file size doesn't require OpenDML and normal avi container should be okay.
Do you get the message from your old VirtualDub version for both files? (Most folks nowdays use VirtualDub2)
Reply
#9
(03.05.2022, 20:56)Selur Wrote: Hmm, in both cases the file size doesn't require OpenDML and normal avi container should be okay.
Do you get the message from your old VirtualDub version for both files? (Most folks nowdays use VirtualDub2)

When I try open file encoded as Xvid codec - old VirtualDub is freezes.
When I try open file encoded as UTvideo codec - old Virtualdub displays a message:

Quote:AVI: Stream 1 (audio) has a non-zero start position of 1152 samples (+24
ms). VirtualDub does not currently support a non-zero start time and the
stream will be interpreted as starting from zero.
Reply
#10
Have you tried using VirtualDub2?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)