This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[BUG] Hybrid CLI hangs on non-ASCII file name
This is totally unrelated to 8dot3name filename support.

Cu Selur
@potejan: send you a link to a dev version for testing via pm

Btw. why are you calling Hybrid in a batch? (Hybrid can monitor a folder, in case that is why you do it.)

Cu Selur
Reposting here to continue our PM conversation. 

Almost works! Hybrid loads the file successfully, and all parts of the GUI detect it (audio tab, etc.). Only issue is when I start encoding, it crashes immediately.

This time, here are proper debug logs:

I'm not sure what you mean by calling Hybrid in a batch. I have a pretty elaborate pipeline (capture, fix and deinterlace, merge with chapters, final encode), and I try to make everything fully stateless and automated. Using Hybrid's CLI and global profiles, I can achieve just that, with a different global profile per video, if necessary. So far I've had incredible success (after all your CLI fixes Big Grin).
According to the log, Hybrid calls:
"C:\Program Files\Hybrid\64bit\vsfilters\SourceFilter\FFMS2\ffmsindex.exe" -f -t 0
tool(1): C:\Program Files\Hybrid\64bit\vsfilters\SourceFilter\FFMS2\ffmsindex.exe
2022.07.15 - 19:18:17_Windows 11 Version 2009 (64bit)_2022.07.15.1 - level 9:  tool: C:\Program Files\Hybrid\64bit\vsfilters\SourceFilter\FFMS2\ffmsindex.exe
2022.07.15 - 19:18:17_Windows 11 Version 2009 (64bit)_2022.07.15.1 - level 9:  argumentString(1): -f -t 0 "ГГГГГ\2006-01-01-ГГГГГ- 12.12.19.avi" "C:\Users\User\AppData\Local\Temp\2022-07-15@18_52_23_6610.ffindex"
2022.07.15 - 19:18:17_Windows 11 Version 2009 (64bit)_2022.07.15.1 - level 9:  arguments(1):
  ГГГГГ\2006-01-01-ГГГГГ- 12.12.19.avi

"ГГГГГ\2006-01-01-ГГГГГ- 12.12.19.avi" is the issue here.
-> You feed Hybrid with an absolute path, right?

Cu Selur
My apologies, I see what happened. At first I tried absolute path, it worked, then I tried relative, it failed, and after that absolute kept failing too. Turns out, Hybrid had saved the failed job, and every time I was starting a new absolute path job, it was only queuing it after the failing relative job, and restarting the relative job. I cleaned my job queue and now absolute works as expected. Case solved, thanks a lot!!!

Out of curiosity - how did you resolve the problem where QFile::exists() was always false?
I fixed it by making sure that Hybrid only used the argument list from the QApplication and not the argv values.

Forum Jump:

Users browsing this thread: 1 Guest(s)