This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[HELP] AAC not created
#1
I've seen a few people with the same problem on this forum but I never came across a working fix. I've run it to this issue quite a few times. It always say that the aac isn't created whether I'm using faac or ffmpeg. I tried installing iTunes but I still get the same error. I'm using a DVD input so passing through the audio is not an option. I've also tried encoding it to mp3 but it still doesn't work. Please advise me on what to try next. Thanks in advance!


Attached Files
.zip   HybridDebugOutput.zip (Size: 15,23 KB / Downloads: 16)
Reply
#2
From the log:

Hybrid uses:
"C:\Program Files\Hybrid\64bit\mplayer.exe" -v -mc 0 -vc dummy -nocorrect-pts -noconsolecontrols -nocorrect-pts -vc null -vo null -nocache -hardframedrop -aid 160 dvd://1 -dvd-device "G:\Paul McCartney\McCartney Archive Collection DVDs\McCartney\VIDEO_TS" -chapter 6-6  -dumpaudio -dumpfile "C:\Users\User\AppData\Local\Temp\iId_2_aid_160_lang_en_DELAY_-43ms_2022-09-29@21_41_16_4310_01.mov"
to extract the audio from the DVD. (did you intend to only use chapter 6?)

During this call Mplayer reports:
libdvdread: Could not open input:
libdvdread: Can't open G:\Paul McCartney\McCartney Archive Collection DVDs\McCartney\VIDEO_TS for reading
libdvdread: Device G:\Paul McCartney\McCartney Archive Collection DVDs\McCartney\VIDEO_TS inaccessible, CSS authentication not available.
This might be a problem, but it finishes without an error and created:
Quote:C:\Users\User\AppData\Local\Temp\iId_2_aid_160_lang_en_DELAY_-43ms_2022-09-29@21_41_16_4310_01.mov (31.1613 MB)
Since there was no error, Hybrid then tries to convert the audio using:
"C:\Program Files\Hybrid\64bit\ffmpeg.exe" -y -ignore_editlist true -threads 8 -i "C:\Users\User\AppData\Local\Temp\iId_2_aid_160_lang_en_DELAY_-43ms_2022-09-29@21_41_16_4310_01.mov" -c:a aac -strict -2 -b:a 320k -ar 48000 -channel_layout stereo "C:\Users\User\AppData\Local\Temp\iId_2_aid_160_lang_en_DELAY_-43ms_2022-09-29@21_41_16_4310_02.aac"
Which aborts with:
[mov,mp4,m4a,3gp,3g2,mj2 @ 000001c8c52ad080] Format mov,mp4,m4a,3gp,3g2,mj2 detected only with low score of 1, misdetection possible!
[mov,mp4,m4a,3gp,3g2,mj2 @ 000001c8c52ad080] moov atom not found
C:\Users\User\AppData\Local\Temp\iId_2_aid_160_lang_en_DELAY_-43ms_2022-09-29@21_41_16_4310_01.mov: Invalid data found when processing input
Hybrid then detects that the audio conversion wasn't successful and aborts.
-> Is the extracted audio okay?
( "C:\Users\User\AppData\Local\Temp\iId_2_aid_160_lang_en_DELAY_-43ms_2022-09-29@21_41_16_4310_01.mov")
In case it is, do you see any additional errors when calling the audio encoder call in a Windows Command Prompt?

Cu Selur
Reply
#3
Hi, thanks for the reply! The mov files mentioned could not be played in VLC whatsoever. Maybe the files created are .mov and the program was searching for .aac? (I could be very wrong though.)
Reply
#4
No, .aac would be wrong.
The audio on the DVD should be PCM judging by the debug output.
Since the extracted mov is not playable something must be the problem with the audio extraction:
"C:\Program Files\Hybrid\64bit\mplayer.exe" -v -mc 0 -vc dummy -nocorrect-pts -noconsolecontrols -nocorrect-pts -vc null -vo null -nocache -hardframedrop -aid 160 dvd://1 -dvd-device "G:\Paul McCartney\McCartney Archive Collection DVDs\McCartney\VIDEO_TS" -chapter 6-6  -dumpaudio -dumpfile "C:\Users\User\AppData\Local\Temp\iId_2_aid_160_lang_en_DELAY_-43ms_2022-09-29@21_41_16_4310_01.mov"

Try whether disabling "Config->Extraction->Use mplayer for DVD audio extraction" and recreating the jobs helps. (Hybrid will use mencoder instead of mplayer.)
(I suspect this will not help, but it's worth a try.)

As a last resort, you could remux the DVD with mkvtoolnix or MakeMKV to an mkv beforce converting.

Cu Selur
Reply
#5
The files are becoming 0KB after I unchecked "Use mplayer for DVD audio extraction". I guess I'll just use MakeMKV. Thanks for the help!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)