This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

SSA Subtitle format !!
#21
(15.10.2022, 18:52)Selur Wrote: I can not reproduce it.
Please, write a !detailed! step-by-step how I can reproduce your problem.


Cu Selur

Sure, i keep it very short. 

I start hybrid, emediatly check the audio tab to be sure the custom settings i have saved to an profile of mine are right.

After that, i open/load an mkv file .. Hybrid reads the fresh loaded .mkv file checks the file for audio id's and such, and extract some tracks like audio for instance.
So, when hybrid done his thing i go strait back to audio tab to double check settings.. BaM, every setting i have chose is kept EXCEPT for the speed/change portion !!  The checkbox i have enabled before importing the mkv is now once again disabled/unchecked !!?

But again, it happends ONLY the LONELY on total NEW files i open for the FIRST time in hybrid !!

i read you can't reproduce this behavior, but b. are you using the custom build you have sended me through pm?  Also, are you using the same settings iam using ?  Hopefully you can read that all out of the log file i have posted .

It's no big deal anyway, but it would be nice to load an selection of mkv files and let hybrid do his thing and apply all of my custom settings automatically for each and single file you see .
And since one "important" settings is off , i have to do that manually with every file at an time you see !


Cheerios,
TD
Reply
#22
Quote:I start hybrid, emediatly check the audio tab to be sure the custom settings i have saved to an profile of mine are right.
I have no clue what those settings are.
You did not share those settings.

Quote:Sure, i keep it very short.
That is not what I asked for. Confused
Reset Hybrid defaults, write down every step you do in detail.
Share those steps.

Cu Selur
Reply
#23
(15.10.2022, 20:22)Selur Wrote:
Quote:I start hybrid, emediatly check the audio tab to be sure the custom settings i have saved to an profile of mine are right.
I have no clue what those settings are.
You did not share those settings.

I kind of hoped you could read that from the huge hybrid debug file i have posted Blush !!

(15.10.2022, 20:22)Selur Wrote:
Quote:Sure, i keep it very short. 
That is not what I asked for.  Confused
Reset Hybrid defaults, write down every step you do in detail.
Share those steps.

Cu Selur

I did !!

I mean , whats more to say!? 

Now, that hybrid manages to remember my custom settings i only need to load an media file and add it to the queue !!
But once a file is loaded one particular but important setting in the AUDIO→Base tab gets disabled/unchecked doing that ! 


Anyway, i have reset hybrid to defaults settings AFTER i have saved all my settings in a Global profile. 
Guess what... now hybrid play nice and remembers all audio settings..

But here's the big mistery, after i have loaded my old settings again from the profile i have made prior to resetting hybrid to defaults. 

Now it loads any media file just fine keeping all the Audio settings intact, speedchange box checked Huh  NOT unchecked / disabled this time !

Just to clarify, i have load my old profile to try and reproduce the same behavior using my old settings.
And since it now is kind of solved using the same old settings i have used before though. 

It's safe to say, my custom settings is probebly not the root and cause of this, right !?

oh well, its solved now...


Update 1:    It appears i spoke to soOON!  It happend again, BUT.. I have noticed it happends with media files with multiple Audio tracks !!
Forgot to mention that.. my bad..

And yes, reseting hybrid doesn't help .. its confirmed.. It ONLY happends with file that has multiple audio tracks!!




cheerios,
TD
Reply
#24
Quote:I have noticed it happends with media files with multiple Audio tracks !!
Forgot to mention that.. my bad..

And yes, reseting hybrid doesn't help .. its confirmed.. It ONLY happends with file that has multiple audio tracks!!
Okay, with this I can reproduce the issue.
-> Looking into it.

Cu Selur
Reply
#25
Disabling "Audio->Misc->Matroska stretch handling" should disable the behaviour of Hybrid do disable the speed change setting.

Cu Selur
Reply
#26
(15.10.2022, 21:24)Selur Wrote: Disabling "Audio->Misc->Matroska stretch handling" should disable the behaviour of Hybrid do disable the speed change setting.

Cu Selur

Affirmative.. That helped..

My only question is, will the A/V from the output file always play in sync now that i have disabled that !

Remember, iam doing an framerate conversion of both video and audio aswell, even though an Audio track itself doesn't has FPS unlike the video track !


Thanks again, we've sorted out the checkbox annoyance  Big Grin 

cheerios,
TD
Reply
#27
Quote:My only question is, will the A/V from the output file always play in sync now that i have disabled that !
No. If the source has stretched/compressed time codes for the audio stream the output will likely be async unless you took this strech/compression into account. In this case "Audio->Misc->Matroska stretch handling" should be set to 'manual'.
"Matroska stretch handling" is an option which sets speed change, but it can also disable it.

Cu Selur
Reply
#28
(15.10.2022, 23:12)Selur Wrote:
Quote:My only question is, will the A/V from the output file always play in sync now that i have disabled that !
No. If the source has stretched/compressed time codes for the audio stream the output will likely be async unless you took this strech/compression into account. In this case "Audio->Misc->Matroska stretch handling" should be set to 'manual'.
"Matroska stretch handling" is an option which sets speed change, but it can also disable it.

Cu Selur


Set to manual.. meaning Enable it again Shy  ... whereby i have to double check my audio settings every time i open another file .. again !

Is that an bug in hybrid that can be fixed btb ?  I mean disable one thing so that another setting is enabled and sticks as a result of that, can't be the purpose ?  Right Dodgy ?

anyway, thanks for all the support,

cheers,
TD
Reply
#29
Quote:Is that an bug in hybrid that can be fixed btb ? I mean disable one thing so that another setting is enabled and sticks as a result of that, can't be the purpose ? Right Dodgy ?
If Hybrid detects a streched/compressed audio stream it can disable/enable the 'Speed change'.
It can't detect when the user manually enabled the speed change.
Not sure how I will change the general processing to handle this.

Cu Selur
Reply
#30
I'll adjust Hybrid to do nothing in regard to normal speed change if stretch handling is set to 'ignore' or 'pass through' this will remove the issue of 'speed change' getting disabled.

But note, that if your source has streched/compressed time stamps for the audio stream, using speed change will require manual adjustment. This is independent of the 'stretch handling' value.

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)