This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[BUG] Avisynth - Cannot copy script with line breaks
I always save my scripts for my projects so I know what I did later.

In previous versions of Hybrid, this worked fine.

In the latest dev version of Hybrid (2022.10.12.1), in AvisynthScriptView, if I right click and do "Select All", then copy, when I paste it anywhere, there are no line breaks. It all pastes as 1 line.
Yeah, that's related to Qt 6.4 which I switched to.
It seems to use something different from the normal line feed in the script preview.
Normal processing should work fine.
I plan to look into it over the weekend.

Cu Selur
I just had a look at this and from the look of it this only happens if you copy&paste the script into Notepad++.
If I copy&paste the script content into the default Windows Editor or any other text editor, everything looks fine.
=> seems to be that this is not a Hybrid, but a Notepad++ issue caused by some change in Notepad++

Cu Selur
I don't have Notepad++.

I pasted into the default Windows Notepad, and it pasted as 1 line.

I have UltraEdit, so I tried pasting in that and it also pastes as 1 line.

The only workaround I can figure out is to process the job and copy the .avs file out of the user temp folder. Doesn't work with small / quick jobs because it processes too fast to grab the .avs file.

What I see when I paste, is where the line breaks are supposed to be, there is nothing, so the next line starts immediately where the previous line ends.

This is kind of an important feature for me, to be able to copy scripts from the script previewer.

I guess I can try some other text editors?

OK, I tried Windows Word Pad, and it works in there. Save as plain text, and the line breaks are retained. Tongue 

It must be using a line break character that a rich text editor can recognize, but a plain text editor can't.
Okay, so it's not just Notepad++ like I suspected.

Quote:It must be using a line break character that a rich text editor can recognize, but a plain text editor can't.
Yes, that is what I suspect too.
(Haven't found anything in Qt 6.4 changelog that seems to hint into this direction.)

Cu Selur
Got it.
It's a known bug in Qt 6.4, see:
Quote:Copying text from QTextEdit to other applications does not handle line breaks well. This is a regression from Qt 6.3 (QTBUG-107004)
-> so until that is fixed in a new Qt version this is how it is atm.

Cu Selur

Ps.: Should be fixed in 6.4.1, but that is not released in the free Qt version.
Compiled a version using Qt 6.3.2 for Hybrid itself, send you a link via pm.
This should fix the issue.

Cu Selur

Forum Jump:

Users browsing this thread: 1 Guest(s)