This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[INFO] GUI scaling and misc.ini
#1
Hi.
I'd like to know if there is any way to make Hybrid's GUI a bit smaller, since on low resolution monitors (e.g., 1366x768) it doesn't fit on the screen and part of it sticks out, unless you use the option to hide the sidebar. It used to be possible to do this by controlling "fontSize=x" via misc.ini, but it seems to have been removed and the option within the GUI doesn't have the same effect as before.

Another question is about the options that are available to be used in misc.ini, since the thread https://forum.selur.net/thread-10.html seems outdated. Could you please list them?
Thanks in advance.
Reply
#2
Font adjustment is nowadays an option in the GUI. Smile
When you open Hybrid, you can lower the font by using 'View->Font--', the Window size will be adjusted to the font.
So adjusting the font and then saving those settings as defaults (Defaults->Save All; or save the defaults for the GlobalDataModel under Config->Defaults), will cause Hybrid to remember that setting.

Alternatively, you could also manually edit the 'fontSize'-value in the GlobalDataModelDefaults.xml in your Hybrid settings folder.

Cu Selur
Reply
#3
Yes, I tried that, but unfortunately only the font size is changed, there is no impact on the GUI scaling, which remains large... at least on my end. šŸ˜Ÿ
Reply
#4
Okay, that is strange.
Have you pressed 'font size --' multiple times, not each font size change also causes the GUI to shrink.

Default looks like this for me: (2372x1112)
[Image: grafik.png]
after pressingĀ  'font size --' 4 times: (1600x1200)
[Image: grafik.png]

Additionally, disabling the sidebar might help. (View->Toggle Sidebar or disable Config->View->Show tooltip sidebar).
If Hybrids GUI is greater than your display, switching to fullscreen 'View->Toggle Fullscreen' should also resize it to fit into the screen.
Also, when lowering the font, toggling icons to text might also help for a smoother scaling. (Icon/Text)

Cu Selur
Reply
#5
Default (fontsize 9):
[Image: Size9.png]

Changed font three times (fontsize 6):
[Image: Size6.png]
It's not yet adjusted to the screen and is practically unreadable.

In fact, the GUI size is adjusted to the font size and shrinks a bit, but it is almost unnoticeable at the resolution I use on my laptop. SadĀ 
Before, when using "fontSize=12" in the misc.ini, the GUI fitted perfectly on my screen, did the behavior change after the option was removed from there?

The only solution that actually helped was hiding the sidebar, which is what I'm using right now.
Reply
#6
On Windows the way the scaling works in Qt6 is a somewhat different that what it was in Qt5 and with each Qt6.x update the behavior seems to change again.
I think the main issue Qt has is with the dpi scaling Windows additionally does.
Does it work better if you go fullscreen.

You can also test whether it differs if you start Hybrid with:
Hybrid -platform windows:dpiawareness=2
Hybrid -platform windows:dpiawareness=1
Hybrid -platform windows:dpiawareness=0
You can also try how it looks if you use:
set QT_SCALE_FACTOR=XXX && Hybrid
where XXX can be any positive float like 0.75

Cu Selur

Ps.: Normal font scaling worked on my Windows systems. (all Windows 11, but with different Monitor sizes and resolutions, so I'm surprised that the gui isn't scaled by only the font for you.)
Reply
#7
Quote:On Windows the way the scaling works in Qt6 is a somewhat different that what it was in Qt5 and with each Qt6.x update the behavior seems to change again.
I think the main issue Qt has is with the dpi scaling Windows additionally does.
Got it. Sad

Quote:You can also test whether it differs if you start Hybrid with:
Hybrid -platform windows:dpiawareness=2

Hybrid -platform windows:dpiawareness=1

Hybrid -platform windows:dpiawareness=0
This has no effect.

Quote:You can also try how it looks if you use:
set QT_SCALE_FACTOR=XXX && Hybrid
This, on the other hand, makes the window smaller, but the items inside it get totally buggy. Confused
[Image: Scale0-85.png]

Quote:Ps.: Normal font scaling worked on my Windows systems. (all Windows 11, but with different Monitor sizes and resolutions, so I'm surprised that the gui isn't scaled by only the font for you.)
Me too. But I can live without the sidebar, I guess.

Thanks for the support. Smile
Reply
#8
Quote:But I can live without the sidebar, I guess.
You can, enable "Config->View->Design->Show tool tips" instead. (which is what I usually use)

Quote:Thanks for the support.
Thanks for reporting the problem. Smile

Cu Selur
Reply
#9
Instant tooltips in sidebar really helps first days when you learn how to use Hybrid, but later it only became a waste of screen space. So i also usually turn sidebar off.
Instead of sidebar to see tooltips you can simply right mouse click on any UI item. At least this works well on macOS.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)