This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Crashed with exit status 0
#1
When ffmpeg muxing enabled "Crashed with exit status 0"


Attached Files
.zip   HybridDebugOutput.zip (Size: 31,6 KB / Downloads: 6)
Reply
#2
Hybrid calls ffmpeg with:
"C:\Program Files\Hybrid\64bit\ffmpeg.exe" -y  -r 25/1 -fflags +genpts -i "H:\264\!_Aspect\3\PINK O TV-11.h264" -i "H:\264\!_Aspect\3\PINK O TV-11.m4a" -vcodec copy -acodec copy -metadata encoding_tool="Hybrid 2023.01.05.1" -map 0:0 -map 1:0  -bsf:v h264_mp4toannexb -aspect 32:18 -r 25/1 "H:\264\!_Aspect\3\PINK O TV-11.mkv"
which looks okay to me, but ffmpeg complains that:
[matroska @ 000001f38e0fa440] Timestamps are unset in a packet for stream 0. This is deprecated and will stop working in the future. Fix your code to set the timestamps properly
[matroska @ 000001f38e0fa440] Can't write packet with unknown timestamp
The funny thing is that '-r 25/1 -fflags +genpts ' should make sure that ffmpeg generates time codes.
Does it work if you use:
"C:\Program Files\Hybrid\64bit\ffmpeg.exe" -y  -r 25/1 -vsync 0 -enc_time_base -1 -i "H:\264\!_Aspect\3\PINK O TV-11.h264" -i "H:\264\!_Aspect\3\PINK O TV-11.m4a" -vcodec copy -acodec copy -metadata encoding_tool="Hybrid 2023.01.05.1" -map 0:0 -map 1:0  -bsf:v h264_mp4toannexb -aspect 32:18 -r 25/1 "H:\264\!_Aspect\3\PINK O TV-11.mkv"
and is the output sync?

Alternatively: rename your .h264 file to .264, Hybrid then will remux it to mkv and feed that mkv to ffmpeg which should work. (I'll adjust Hybrid to also add the mkvmerge remux when .h264 or .avc is used as extension)


Cu Selur
Reply
#3
Quote:Does it work if you use:
"C:\Program Files\Hybrid\64bit\ffmpeg.exe" -y  -r 25/1 -vsync 0 -enc_time_base -1 -i "H:\264\!_Aspect\3\PINK O TV-11.h264" -i "H:\264\!_Aspect\3\PINK O TV-11.m4a" -vcodec copy -acodec copy -metadata encoding_tool="Hybrid 2023.01.05.1" -map 0:0 -map 1:0  -bsf:v h264_mp4toannexb -aspect 32:18 -r 25/1 "H:\264\!_Aspect\3\PINK O TV-11.mkv"
and is the output sync?

Unrecognized option 'y  -r'.
Error splitting the argument list: Option not found


Quote:Alternatively: rename your .h264 file to .264, Hybrid then will remux it to mkv and feed that mkv to ffmpeg which should work. (I'll adjust Hybrid to also add the mkvmerge remux when .h264 or .avc is used as extension)

In this case it worked
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)