This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[HELP] Trying to ovewrite input scan type from progressive to interlaced
#1
I have a bunch of vhs footage that I captured in avi format with lagarith losseless codec. The videos are marked as progressive in both hybrid and media info but I can clearly see the combing effect. I read that avi doesn't have a flag for interlacing so that's okay, and I'm supposed to mark that it's interlaced when I'm encoding. I'm encoding to mp4 x264 file but when I'm checking the Overwrite input scan type to bottom field first and disabling auto deintarlacing then I get this error:
Aborting: Encoding is set for progressive output, but the input is not progressive.

I tried top field and telecine just in case, but I get the same error.
I'm on Windows 10 Hybrid 2022.11.28.1

I'm not sure If I'm misunderstanding what this option is for, but I want the video to have interlace flag so that my tv can deinterlace it instead of Hybrid, because apparently it's better to let the tv do it.


Attached Files
.7z   HybridDebugOutput.7z (Size: 3,51 KB / Downloads: 7)
Reply
#2
Quote: I read that avi doesn't have a flag for interlacing so that's okay,..
The video format should support the flagging, which lagarith does not.

Quote:. I'm encoding to mp4 x264 file but when I'm checking the Overwrite input scan type to bottom field first and disabling auto deintarlacing then I get this error:
Aborting: Encoding is set for progressive output, but the input is not progressive.

I tried top field and telecine just in case, but I get the same error.
I'm on Windows 10 Hybrid 2022.11.28.1

I'm not sure If I'm misunderstanding what this option is for, but I want the video to have interlace flag so that my tv can deinterlace it instead of Hybrid, because apparently it's better to let the tv do it.
You can count yourself lucky that Hybrid did complain, since what you should do is:
1. Overwrite, the input scan type like you did.
2. Configure the encoder to output interlaced content for x264: 'x264->Frames->Advanced Frame Settings->Interlaced encoding' + 'Force bff'.
Since the encoder is set to interlaced output Hybrid will not deinterlace (unless it's necessary to apply some filter, but then it will reeinterlace and make sure the encoder is fed interlaced content).

With your settings, you would have ruined the output by making the combing part of the image while encoding progressively instead of interlaced. Wink
(your TV wouldn't be able to deinterlace, since what you would have created, wouldn't be interlaced content)

Cu Selur
Reply
#3
Thanks for the quick help it worked.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)