This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

M2V file encoding fails with an error
#1
Hello Selur,




Current version Hybrid 2023.01.22.1



M2V file (extracted from DVD) encoding fails with an error. There were no errors in the previous version




x264 --preset veryfast --bitrate 3500 --profile high --level 5.1 --ref 3 --direct auto --b-adapt 0 --lookahead-threads 3 --sync-lookahead 18 --ratetol 2.00 --qcomp 0.50 --rc-lookahead 40 --qpmax 51 --partitions i4x4,p8x8,b8x8 --no-fast-pskip --subme 5 --aq-mode 0 --vbv-maxrate 3500 --vbv-bufsize 300000 --sar 32:27 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt709 --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE -




.zip   m2v.zip (Size: 22,63 KB / Downloads: 7)



If M2V is muxing in MKVToolNix as MKV and start converting with my settings - all is wel





.zip   mkv.zip (Size: 30,64 KB / Downloads: 5)
Reply
#2
Avisynth script:
ClearAutoloadDirs()
SetFilterMTMode("DEFAULT_MT_MODE", MT_MULTI_INSTANCE)
LoadPlugin("D:\Other\Hybrid\32bit\AVISYN~1\DGDecode.dll")
LoadPlugin("D:\Other\Hybrid\32bit\AVISYN~1\RgTools.dll")
LoadPlugin("D:\Other\Hybrid\32bit\AVISYN~1\masktools2.dll")
LoadPlugin("D:\Other\Hybrid\32bit\AVISYN~1\mvtools2.dll")
LoadPlugin("D:\Other\Hybrid\32bit\AVISYN~1\nnedi3.dll")
LoadPlugin("D:\Other\Hybrid\32bit\AVISYN~1\svpflow1.dll")
LoadPlugin("D:\Other\Hybrid\32bit\AVISYN~1\svpflow2.dll")
Import("D:\Other\Hybrid\32bit\avisynthPlugins\mtmodes.avsi")
Import("D:\Other\Hybrid\32bit\avisynthPlugins\QTGMC.avsi")
Import("D:\Other\Hybrid\32bit\avisynthPlugins\Zs_RF_Shared.avsi")
# loading source: D:\Video\test.m2v
# color sampling YV12@8, matrix: bt709, scantyp: top field first, luminance scale: limited
MPEG2Source(d2v="D:\Other\Temp\2023-01-22@20_37_19_1510.d2v",fieldop=0)
# current resolution: 720x480
# deinterlacing
AssumeTFF()
QTGMC(Preset="Fast", ediThreads=2)
SelectEven()
input = last
super=SVSuper(input, "{scale:{up:2},gpu:1,rc:0}")
vectors=SVAnalyse(super, "{main:{search:{coarse:{distance:0},type:4}},refine:[{thsad:200}]}")
SVSmoothFps(input, super, vectors, "{rate:{num:2,den:1},algo:13,mask:{area:0},scene:{mode:3}}", mt=24)
# filtering
# setting output fps to 59.940fps
AssumeFPS(60000,1001)
PreFetch(6)
#  output: color sampling YV12@8, matrix: bt709, scantyp: progressive, luminance scale: limited
return last
and encoding call:

"D:\Other\Hybrid\32bit\ffmpeg.exe" -y -loglevel fatal -noautorotate -nostdin -threads 8 -i "D:\Other\Temp\encodingTempSynthSkript_2023-01-22@20_37_19_1510_0.avs" -an -sn -vf zscale=rangein=tv:range=tv -pix_fmt yuv420p -vsync 0 -f rawvideo -
| "D:\Other\Hybrid\64bit\x264.exe" --preset veryfast --bitrate 3500 --profile high --level 5.1 --ref 3 --direct auto --b-adapt 0 --sync-lookahead 18 --ratetol 2.00 --qcomp 0.50 --rc-lookahead 40 --qpmax 51 --partitions i4x4,p8x8,b8x8 --no-fast-pskip --subme 5 --aq-mode 0 --vbv-maxrate 3500 --vbv-bufsize 300000 --sar 32:27 --non-deterministic --range tv --colormatrix bt709 --demuxer raw --input-res 720x480 --input-csp i420 --input-range tv --input-depth 8 --fps 60000/1001 --output-depth 8 --output "D:\Other\Temp\2023-01-22@20_37_19_1510_04.264" -
looks fine.
Hybrid stops, since the output file is 0 bytes.

Does the Avisynth Preview work?

My guess atm. is that this is related to Avisynth and SVP.
Reinstalling the graphic card drivers might help. (using Vapoursynth instead of Avisynth probably fixes the issue too)

As a side note: That script seems wrong.
If the source is interlaced (and not telecined like most commercial DVDs) using QTGMC with Bob turned on would be the better approach.
If the source is telecined then using QTGMC is the wrong choice and TIVTC or Decomb should be used for TIVTC, then SVP makes sense.

Cu Selur
Reply
#3
Okay, seems like the switch to Qt 6.4.2 broke Avisynth -> use Vapoursynth instead until I figure out what's causing the issue.
Reply
#4
(22.01.2023, 18:23)Selur Wrote: Does the Avisynth Preview work?

Crashed after warnings

[Image: 331714149_2023-01-23_000503.jpg]

if placed in a container mkv also shows an error, but the preview works and converting.
Reply
#5
Yeah, seems like I overlooked something there and there is some issue with Qt.
-> I'll probably fix the error there and will upload a new version tomorrow. (which will use an older Qt version for the Avisynth related tools)

Cu Selur
Reply
#6
Please, redownload Hybrid_2023.01.22.1_SETUP from https://www.selur.de/downloads
test both preview and encoding and let me know whether it works now.

Cu Selur

Ps.: Also please try whether it works when using Vapoursynth.
Reply
#7
Not working Avisynth after redownload.

Vapoursynth - working
Reply
#8
Strange, works fine here.
(just tested it)
Does the Avisynth Preview work?
=> Share a debug output.

Cu Selur
Reply
#9
Might have found an issue. Seems like 32bit Avisynth uses an of DGDecode version.
(couldn't reproduce the issue since I use Avisynth 64bit)
-> send you a link to a dev version where I updated the source filter in the 32bit folder.

Cu Selur
Reply
#10
In the test version, Avisynth does not work.

Vapoursynth - working.

To MKV Avisynth Preview does not work but encoding is successful.

Selur, is there a difference in processing for MKV and M2V ?


Attached Files
.zip   test_version.zip (Size: 22,65 KB / Downloads: 2)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)