This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[INFO] About qaac
#1
Hello.

I have two questions about a behavior I noticed in hybrid.
1. Why is there a 32bit qaac binary in the 64bit folder?
2. Why does hybrid prefer the 32bit binary over the 64bit one?

From what I've noticed, this usually only occurs when there's no option for a 64bit binary.
I came across this when trying to encode audio from a movie and hybrid returned a crash warning because of trying to use Qtfiles64 with a 32bit binary. Well, this is easily workarounded by changing the binary path in "Tools", but it's a bit annoying to have to do this manually every time you reset the cache in case you update some tool.

Thanks for reading.
Reply
#2
That is a mistake, simply deleting the qaac.exe from the in Hybrid/64bit folder should be fine.
On the next start or Hybrid, Hybrid should detect the qaac64.exe, which also comes with Hybrid, automatically.

Cu Selur
Reply
#3
Quote:On the next start or Hybrid, Hybrid should detect the qaac64.exe, which also comes with Hybrid, automatically.
This doesn't seem to be the case.

If I just delete the "qaac.exe" and don't rename the "qaac64.exe", Hybrid will not find it on its own, even if I clear the tools info cache as you can see below:
[Image: hybrids-qaac.png]
Reply
#4
Ah, sorry, you also need to clear the tool cache. (Config->Tools->Clear all cached tool infos.)

Cu Selur
Reply
#5
Yes, I did that, but it didn't work for me. Does it work for you?
Reply
#6
Yes. After deleting qaaac.exe and clearing the tool cache qaac64.exe was found and used.
Reply
#7
Hello Selur,

  I noted that in Config->Tools. The path for NVEnc is not set. If I try to set it, the setting is not saved.
  It is not relevant because Hybrid is able to use the right version in any case. But I prefer to report this issue in the case it need to be fixed.

Thanks,
Dan
Reply
#8
Yeah noticed that too and it's on my todo. Smile
Reply
#9
Send you two a link to a dev version, via pm.

Cu Selur
Reply
#10
Got the dev version.
Weird, my case with qaac remains the same. If I don't rename the "qaac64.exe" to "qaac.exe", Hybrid doesn't detect it. Clearing the tools cache has no effect either. Well, I just renamed it and everything is working fine, so I'll keep it that way for now.

Thanks for your help, Selur. Smile
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)