This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[HELP] bypass/disable deinterlace
#11
I will look into it this evening, but neither of those has interlaced flags, but I'll look into it what happens if I feed it interlaced content and if I adjust Hybrid to allow saving interlaced into those formats.

Cu Selur
Reply
#12
Okay, I did some small test.
FFvHuff interlaced works.
UTVideo interlaced, does encode, produces output that is flagged as interlaced, but is neither bff nor tff. => not working.

Cu Selur
Reply
#13
First I wish to thank you, Selur, for taking my question and running with it.
Using the recent 12.20.1. scan stated BFF, that cannot be correct, I suspect lack of flag on the AVI.
So, I take my captured HuffYUV file and in the HuffYUV window I have chosen 4:2:2 and interlacing ticked to TFF, for export.
In the filter window Avisynth the auto deinterlace is ticked to QTGMC and the overwright is unticked.
A few added filters for testing.
The file is created but in MediaInfo it states "scan type progressive" "Original scan type interlaced".
Display aspect ratio                    : 3:2
Frame rate                              : 29.970 (30000/1001) FPS
Standard                                : NTSC
Color space                              : YUV
Chroma subsampling                      : 4:2:2
Bit depth                                : 8 bits
Scan type                                : Progressive
Original scan type                      : Interlaced
Good grief it will NOT accept my TXT debug file, says it's too big at 449kb. If I post it as text you'll all kill me! Maybe I will DM/PM Selur to avoid death, or is that worse???
I am confused, not an entirely foreign condition for me. Would you need a short before and after sample? I do not think it is a bug, but I want to be sure and learn along the way.
Thank you again.
Barry
Reply
#14
If you want to attach a debug output, zip. (like the sticky states)

Quote:MediaInfo it states "scan type progressive" "Original scan type interlaced".
That basically says:
a. the container says its progressive
b. the video stream itself says its interlaced.

If you want suggestions to process a file, I need a sample of it.
And some info what you want to create.
Like I tested FFvHuff allows creating interlaced output, UTVideo not.

Cu Selur
Reply
#15
In regards to the zip, I certainly tried that but it never showed up.

https://drive.google.com/drive/folders/1...sp=sharing
EDIT: I had to run but I will truncate those 2 files to a more manageable size later today.
Reply
#16
New samples with notes are uploaded.
I may be beating a dead horse, it seems OK, just the progressive labeling threw me off. 
Honestly now that I THINK I know how to use the new function I like it and hope it is useful to other people. Donation made.
Reply
#17
Got the files.
Will look at it after the Christmas days and report back then.

atm. there are a few issues.
a. Hybrid should not deinterlace since the output is flagged to be interlaced (due to a typo)
b. Hybrid should again setting the interlaced flags if the it muxes an .avi file. (overlooked that since I didn't mux the additional audio in my tests)
----
had a quick go at it:
  • extracting audio:
    ffmpeg -y -threads 8 -i "C:\Users\Selur\Desktop\HuffInterlaced.avi" -map 0:1 -vn -sn -ac 2 -ar 96000 -acodec pcm_s16le -f wav -map_metadata -1 -metadata encoding_tool="Hybrid 2023.12.23.1" "J:\tmp\iId_1_aid_1_2023-12-23@07_12_29_4610_01.wav"
  • reencoding video:
    ffmpeg -y -noautorotate -nostdin -threads 8 -i "C:\Users\Selur\Desktop\HuffInterlaced.avi" -map 0:0 -an -sn -vf zscale=rangein=tv:range=tv,setfield=tff -pix_fmt yuv444p -vsync 0 -top 1 -vcodec ffvhuff -coder 0 -context 0 -non_deterministic true -flags +ildct+ilme -top 1 -metadata encoding_tool="Hybrid 2023.12.23.1" "J:\tmp\HuffInterlaced_new_1_2023-12-23@07_12_29_4610_02.avi"
    Video (stream&container) is properly flagged as interlaced.
  • muxing audio&video:
    ffmpeg -y  -r 30000/1001 -fflags +genpts -i "J:\tmp\HuffInterlaced_new_1_2023-12-23@07_12_29_4610_02.avi" -top 1 -flags +ildct+ilme -i "J:\tmp\iId_1_aid_1_2023-12-23@07_12_29_4610_01.wav" -metadata encoding_tool="Hybrid 2023.12.23.1" -c:0 copy -c:1 copy -map 0:0  -map 1:0  -aspect 720:480 -r 30000/1001 -f avi "G:\Output\HuffInterlaced_new.avi"
    Video container is flagged as progressive, video stream is flagged as interlaced.
So I fixed the typo, but I'm unsure why FFmpeg still flags the output container as progressive after the muxing call.

Cu Selur

Ps.: created a post over at videohelp (https://forum.videohelp.com/threads/4127...essive-why), maybe someone sees the problem. Will look at it further after the Christmas days. (send you a link to the version I used above)
Reply
#18
Quote:FFMPEG AVI muxer writes number of fields based on par->field_order value. But this field is never set when we copy ffvhuff video, so the muxer just uses the default (progressive) here.
source: https://forum.videohelp.com/threads/4127...ost2717252
Seems like I will have to file a bug report (after the holidays) with the FFmpeg team and hope for the best.

Cu Selur
Reply
#19
ARGH,... I thought re-encoding the stream would work as a workaround, but then you would need to know the encoding settings or the original stream, which is possible if Hybrid already reencoded the stream, but with video passthrough you would change the encoding. Sad
This is just: ugly.

Cu Selur
Reply
#20
I created an entry in the FFmpeg Bug tracker: https://trac.ffmpeg.org/ticket/10761

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)