This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

NVEnc Preview
Why, did you do that?!?
NVEncC is not meant to create raw YUV output, it's meant to output compressed stuff.
The issue isn't NVEnc, it's somewhere in the piping and opening the piped content with ffmpeg and Python in Vapoursynth.
Better ask _AI_ whether he has an idea why this Vapoursynth(file->nvenc->ffmpeg) does not work.

Cu Selur
I understand your view, but in windows is already a miracle if a pipe is working as expected, and the use of an additional pipe will introduce an additional point of failure. The possibility to get the uncompressed filtered video from NVEnc is the most robust way to build a preview. Fortunately Rigaya understood the issue and provided a positive answer to my request. Let's see...
Ideally you would need an option which gives you the output for frame X, but that gets tricky when deinterlacing or other stuff that changes the frame count is involved.
=> fingers crossed that Rigaya can come up with something that can be integrated into guis. Smile

Cu Selur
I posted also a message to __AI__ asking clarification on the script published because I was unable to get it working properly.
This the link of the post:
 I hope that __AI__ will answer.
I was able to test the changes in 7.32, see:

Unfortunately by removing the intermediate file and using the pipe to provide the input to "ffplay" is not working the output is bad.

Till now I was unable to get a Vapoursynth script able to work using the pipe (and no answer from _AI_) Sad
I just tried, it with:
F:\Hybrid\64bit\NVEncC.exe --avhw --input "C:\Users\Selur\Desktop\TestSubs-1.mp4" -c raw --output-csp yuv420 --output-depth 8 --output-format y4m --output - | F:\Hybrid\64bit\ffplay.exe -f yuv4mpegpipe -i -
and it worked without any issues.
Same with:
F:\Hybrid\64bit\NVEncC.exe --avhw --input "C:\Users\Selur\Desktop\TestSubs-1.mp4" -c raw --output-csp yuv420 --output-depth 8 --output-format raw --output - | F:\Hybrid\64bit\ffplay.exe -f rawvideo -pixel_format yuv420p -video_size 720x300 -i -
F:\Hybrid\64bit\NVEncC.exe --avhw --input "C:\Users\Selur\Desktop\TestSubs-1.mp4" -c raw --output-res 720x304 --output-csp yuv420 --output-depth 8 --output-format raw --output - | F:\Hybrid\64bit\ffplay.exe -f rawvideo -pixel_format yuv420p -video_size 720x304 -i -

Cu Selur

Ps.: can't get Vapoursynth working with your stream, works fine with mine that already is mod16.
Answer from __AI__: Quick tested it with another 1920x1080 mp4, 4:2:0 video I have here and it worked, so ffmpeg's rawvideo loaded it ok, but your mp4 file did not work. I suspect that height mod might be a problem, it is 4 for 300, maybe mod 8 is needed for ffmpeg. Would resizing it to 304 help for example? Source video, not in vapoursynth.

I tried:

E:\VideoTest\TestSubs\NVEncC.exe --avhw --input "E:\VideoTest\TestSubs\TestSubs-1.mp4" -c raw --vpp-resize spline36 --output-res 720x304 --output-csp yuv420 --output-depth 8 --output-format raw --output - | E:\VideoTest\TestSubs\ffplay.exe -f rawvideo -pixel_format yuv420p -video_size 720x304 -i -

but the output image "is green"  maybe the problem is in ffplay version used.
I'm using:

ffplay version Copyright © 2003-2023 the FFmpeg developers
  built with gcc 12.2.0 (Rev10, Built by MSYS2 project)
  configuration: --enable-gpl --enable-version3 --enable-static --disable-w32threads --disable-autodetect --enable-fontconfig --enable-iconv --enable-gnutls --enable-libxml2 --enable-gmp --enable-bzlib --enable-lzma --enable-zlib --enable-libsrt --enable-libssh --enable-libzmq --enable-avisynth --enable-sdl2 --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxvid --enable-libaom --enable-libopenjpeg --enable-libvpx --enable-mediafoundation --enable-libass --enable-libfreetype --enable-libfribidi --enable-libvidstab --enable-libvmaf --enable-libzimg --enable-amf --enable-cuda-llvm --enable-cuvid --enable-ffnvcodec --enable-nvdec --enable-nvenc --enable-d3d11va --enable-dxva2 --enable-libvpl --enable-libgme --enable-libopenmpt --enable-libopencore-amrwb --enable-libmp3lame --enable-libtheora --enable-libvo-amrwbenc --enable-libgsm --enable-libopencore-amrnb --enable-libopus --enable-libspeex --enable-libvorbis --enable-librubberband

could you provide your version ?

Uploaded the ffplay version I used to my GoogleDrive.

Cu Selur
I found the problem regarding the "ffplay". It was due to the fact that i was running the scripts in Powershell, by running them in the command dos (cmd.exe) all the version of ffpay are woking. Even without resize mod 8.
Yeah, but that doesn't fix it for Vapoursynth.

Forum Jump:

Users browsing this thread: 1 Guest(s)