This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Help needed with Linux builds,...
#1
Hi, sadly the Linux dependency builds are broken atm.
(see: https://github.com/Selur/hybrid-vapoursynth-addon)
If someone gets neo-vague-denoise (vsvaguedenoise is gone) and vslsmashsource to compile, please let me know.
Sadly, building the tools also is broken for sox, ffmpeg (https://github.com/Selur/HybridDeploy/bl...d-tools.sh)


Cu Selur
--- mainly offline 20.-26 of May ---
Reply
#2
Question. Is FFmbc needed or used by anything? From what I can tell is an old outdated fork of ffmpeg. I have possible fixes from regular ffmpeg, but not that.

Also error/biuld logs would be handy. I got most of it working on my end already. 

https://github.com/bcoudurier/FFmbc
Reply
#3
ffmbc is optionally used as mov muxer, but not having it is no problem.

Cu Selur
--- mainly offline 20.-26 of May ---
Reply
#4
okay so I've been testing everything on an Ubuntu 20.04 VM. Ffmpeg  and Sox both compile fine. I tried on an Ubuntu 18.04 install, but ffmpeg didn't compile there though. I'm using the latest version of your build script.

So At minimum I would use Ubuntu 20.04 for now on. I would recommend using  Ubuntu 22.04 in the future though, 20.04 is getting kind of dated.

funny enough though your ffmpeg script works with no issue on my Arch Linux machine, despite some other issues new version of binutils is causing.

I'm looking into the new plugin though.
Reply
#5
I did run the scripts in Ubuntu 22.04. Tongue
-> maybe it was something that the ffmpeg folks fixed. Will try again on Wednesday or Thursday. (busy with job&family related stuff atm. so not much time to look into it)

Cu Selur
--- mainly offline 20.-26 of May ---
Reply
#6
I didn't actually test on 22.04 I had assumed you were still running 18.04 or had tried 20.04.

I'll test it myself tonight.
Reply
#7
I can confirm building the tools works again. Big Grin
I also checked the code. Hybrid doesn't use ffmbc anymore. Totally forgot I removed it completely. Tongue
but vslsmashsource fails
and neo-vague-denoise (https://github.com/HomeOfVapourSynthEvol...ueDenoiser doesn't exist anymore) fails
(will remove waifu2x-w2xc)

Cu Selur
--- mainly offline 20.-26 of May ---
Reply
#8
this make possible to publish a new (updated) public build?
Reply
#9
Nope, atm. L-SMASH does not build which blocks a new release
--- mainly offline 20.-26 of May ---
Reply
#10
I know it's a bit late for the latest release But I got Lsmash compiling for me again. I'm honestly not sure what the issue was. I strongly suspect it's an issue with your header script. It's not the first time it's caused issue for me.

I rewrote it by hand and it just started working. I never actually had an issue with it compiling for me normally, only with your script. So I gave up debugging it and redid it and it just worked.

ghdl HomeOfAviSynthPlusEvolution/L-SMASH-Works
ghdl l-smash/l-smash

./configure --prefix="$vsprefix" --extra-cflags="$CFLAGS" || cat config.log
make -j$JOBS lib
cp liblsmash.a ..


cd ..


cd VapourSynth

mv meson.build meson.build.ORIGINAL
sed < meson.build.ORIGINAL > meson.build \
-e "/vapoursynth_dep *=/i\
liblsmash_dep = declare_dependency(link_args : ['-L../../build', '-llsmash'],\\
                                   include_directories : ['../../build'])\n" \
-e "s/dependency('liblsmash')/liblsmash_dep/g"

meson build

ninja -C build

cd build

cp libvslsmashsource.so $VSPREFIX/vsplugins/libvslsmashsource.so

also neo deniose compile fine for me too now. all i did was remove the retry_git_clone line and did a normal git clone.

git clone https://github.com/HomeOfAviSynthPlusEvolution/neo_Vague_Denoiser
cd neo_Vague_Denoiser
cmake .
make
strip_copy libneo-vague-denoiser.so
cd ..
rm -rf neo_Vague_Denoiser
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)