This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[HELP] colourspace
#1
I'm so sorry Selur I need help again this time its  with colourspace issues in hybrid.

When I use Huffyuv render in moviestudio and export to Hybrid for de-interlacing and h264 compressio,  it wrongly identifies it as BGR0 when I have captured it YUV2 in virtualdub and exported it YUY2 PAL in moviestudio.

When I do the same above in lagrith it shows YUY 4:2:2 lossless and 8bit like it should.

Why is it not showing the correct colourspace in Huff? I wanted to use huff because it was correctly identifying field order in hybrid media info panel making it easier for me to select correct field order when asking hybrid to deinterlace, now if using lagrith I have to overwrite input scan do a 2 min test render with lower and upper field but I can't tell the difference during playback on PC monitor, they are lossless VHS captures.

Thanks for the great software
Reply
#2
This does not sound like a problem in Hybrid, but more like a problem with your capturing setting.
BGR0 sounds like you captured to RGB not YUV 4:2:2.
If you share a debug output of Hybrid analyzing the source, I can see what Hybrid detects using mediaingo, mplayer and ffmpeg.

Cu Selur
--- mainly offline 20.-26 of May ---
Reply
#3
I re-encoded a file in moviestudio today using lagrith lossless codec and after de-interacing in hybrid I get jagged edges on fast movement or when the camera quickly pans to another place.
I exported in every option progressive, upper field first lower field first I even changed field order in hybrid I tried -1 match source, 0 bottom field, 1 top filed nothing was solving this issue so I did my own research I did not want to disturb you it's very embarrassing asking for help all the time
the search said this happens when a wrong resize option is used, what resize option should I use?

 I remember using one option and all I got was a tiny box and a green screen so I want back to the old option  I was using. The original size is 729x576 I'm resizing it to 1920x1080 to make it look good on a bigger screen.

Thanks for this great software.
I'm so sorry I should know how to solve this issue
Reply
#4
don’t worry – everything works in x265 – in automatic mode

but for x264 you have to change it a little manually

Big Grin  https://drive.google.com/file/d/198ohyUF...sp=sharing
Reply
#5
Quote:I re-encoded a file in moviestudio today using lagrith lossless codec and after de-interacing in hybrid I get jagged edges on fast movement or when the camera quickly pans to another place.
From the sound of that, I would say you did not deinterlaced in fact.
If the input detected as interlaced, I suspect it's flagged as progressive.
In which case you need to overwrite the input scan type to 'tff' or 'bff' (depending on the source) otherwise the deinterlacer will not be used.

You are right, this could also happen if you resized during the capture or in movie studio without taking the interlaced nature of the source into account and messed up the file you feed to Hybrid.
If that is the case, you could try to:
a. resize before deinterlacing (amount of resizing and the resizer to choose depends on the source), to try to counteract the done resizing and then deinterlace. (this usually will a. blur the source and b. leave ghosting)
b. resize until the resize is gone and then use filtering to remove residual combing (same as above)

=> if you can share a short same (a few seconds with horizontal movement are enough) I can look at it later.

Quote:don’t worry – everything works in x265 – in automatic mode

but for x264 you have to change it a little manually
Can you share a debug output of the whole process (loading of the source and you adjusting the settings before creating the jobs) so I can see what actually happens.

Cu Selur
--- mainly offline 20.-26 of May ---
Reply
#6
I don’t want to repeat my post about “profile422” - it’s simple:

1. launch "Hybrid"
2. upload any video
3. select “profile422” as in the screenshot and you will see that the forced CSP has not changed
Reply
#7
Quote:1. launch "Hybrid"
2. upload any video
3. select “profile422” as in the screenshot and you will see that the forced CSP has not changed
Why should it?
Profile 4:2:2 allows 4:2:0 and 4:2:2 so no need to switch the color space.
In x265 it works as you want, since I wrote an auto adjust to the highest possible color space of the profile option, I did not for x264.
But this has nothing to do with this thread at all.

I'm getting more and more tired of you posting in threads without having understood what the issue is.
Assuming you do this not to spite me and others, but due to you using some translation software that and not really understanding what is happening:
Please do not post stuff like 'works with ...' if you don't really understand what's happening.
This is your last warning before getting banned.

Cu Selur
--- mainly offline 20.-26 of May ---
Reply
#8
OMG

буду вручную менять ибо автоматический режим не работает. удачи! забаньте меня
Reply
#9
I will think about adding 'auto' option to x264 in the future, but this should have been in its own feature requires thread, not in the thread about a not related problem.

Cu Selur
--- mainly offline 20.-26 of May ---
Reply
#10
I did overwrite input scan I tried every option upper field first, lower field first, when I encoded progressive so issue but content interlaced
Lagrith is always flagged as progressive.
I capture at 720x576 export to moviestudio clean up colour correct re-encode lagrith lossless 720x576
Then import into hybird overwrite scan I normally choose TFF then I go to the resize option 2- bicubic
Target resolution 1920x1080

 
I left the AR 720x576 original  during capture but when encoding in movie studio I went for PAL DV template because the standard 720x576 leaves black bars on the sides when using lossless codecs encoding in moviestudio.

I have tried all the resize options in hybrid no effect
I tried changing field order -1, 0, 1 no change .
I use the forum on my smart phone
How do I send debug file
I can only find log files
(18.11.2023, 08:27)Selur Wrote:
Quote:I re-encoded a file in moviestudio today using lagrith lossless codec and after de-interacing in hybrid I get jagged edges on fast movement or when the camera quickly pans to another place.
From the sound of that, I would say you did not deinterlaced in fact.
If the input detected as interlaced, I suspect it's flagged as progressive.
In which case you need to overwrite the input scan type to 'tff' or 'bff' (depending on the source) otherwise the deinterlacer will not be used.

You are right, this could also happen if you resized during the capture or in movie studio without taking the interlaced nature of the source into account and messed up the file you feed to Hybrid.
If that is the case, you could try to:
a. resize before deinterlacing (amount of resizing and the resizer to choose depends on the source), to try to counteract the done resizing and then deinterlace. (this usually will a. blur the source and b. leave ghosting)
b. resize until the resize is gone and then use filtering to remove residual combing (same as above)

=> if you can share a short same (a few seconds with horizontal movement are enough) I can look at it later.

Quote:don’t worry – everything works in x265 – in automatic mode

but for x264 you have to change it a little manually
Can you share a debug output of the whole process (loading of the source and you adjusting the settings before creating the jobs) so I can see what actually happens.

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)