This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

VOB to MKV Syncing Issue
#1
Hello,

I am running into an issue where my the audio and video are constantly out of sync when I encode from a .VOB to a .MKV within Hybrid. Sometimes the video plays too fast. Other times the audio outpaces the video. In this example, the video is faster than the audio. I'm not exactly sure what I am doing wrong, to be honest. I am also using dev version 2023.11.05. Please see the attached debug file.

Edit: I tried 2 more attempts with different variables. The first was to change to input FR and check "Always extract timecodes from input; uncheck 'only some'". The following attempt I changed audio to Auto Add All. Debug file includes all three attempted outputs.


Attached Files
.7z   HybridDebugOutput20240115b-VOB_sync_issue.7z (Size: 61,44 KB / Downloads: 14)
Reply
#2
Quote: "Always extract timecodes from input; uncheck 'only some'".
vobs should be from DVDs which are not vfr, but cfr, so that option only can cause problems.
Quote: I am also using dev version 2023.11.05.
Update to latest version (and post another debug output), otherwise looking at the debug output makes no sense for me.

Cu Selur
Reply
#3
How do I get the latest dev version? I originally got it to get the Torch Addon. Is that in the public version now?
Reply
#4
Support for the addons is independent of the version for quite a while. (download for the addons is linked on the download page)
Dev version is recommended to get the latest fixes, but is not necessary.
=> send you a link to the latest dev

Cu Selur
Reply
#5
Oh nice! Sounds good! I'll report back with results.
Reply
#6
Okay. Same results. The closest I got was with the third/final attempt. Speed seemed to look more normal after I changed the input fps to 23.976 instead of 29.97. And the sound just seemed to be a few seconds ahead. At least that's what is appeared to be. I have attached the log.


Attached Files
.7z   HybridDebugOutput20240116-VOB_sync_issue.7z (Size: 136,21 KB / Downloads: 16)
Reply
#7
Input should be detected as 29.97fps soft telecined, which either gets handled by DGDecNV or by applying normal IVTC, but should output 23.976 fps.
According to the analysis the audio should be delayed by 280ms.
Strange thing is, that the vob gets reported as 3.4GB, which is not normal. vobs should not be larger than 1GB on DVDs.
Checking the first log, MPlayer does remort some issues extracing the audio.

a. try whether enabling "Filtering->Vapoursynth->Misc->Source->Use DGDecNV when available" helps.
b. try whether enabling "Filtering->Vapoursynth->Misc->Script->Always use Vapoursynth" helps.
c. try whether remuxing the source file with mkvtoolnix to mkv before processing the file with Hybrid helps.

Cu Selur
Reply
#8
(17.01.2024, 06:42)Selur Wrote: Input should be detected as 29.97fps soft telecined, which either gets handled by DGDecNV or by applying normal IVTC, but should output 23.976 fps.
According to the analysis the audio should be delayed by 280ms.
Strange thing is, that the vob gets reported as 3.4GB, which is not normal. vobs should not be larger than 1GB on DVDs.
Checking the first log, MPlayer does remort some issues extracing the audio.

a. try whether enabling "Filtering->Vapoursynth->Misc->Source->Use DGDecNV when available" helps.
b. try whether enabling "Filtering->Vapoursynth->Misc->Script->Always use Vapoursynth" helps.
c. try whether remuxing the source file with mkvtoolnix to mkv before processing the file with Hybrid helps.

Cu Selur

Option A did the trick! Thank you, Selur!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)