This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Avisynth preview error
#11
Quote:Make sure to disable cropView when wanting to see the effect of the filters.
Ok. Some filters working, "Smooth tweak" asks
Quote:Avisynth preview error: -> I don't know what 'brightness' means. (K:\temp\tempPreviewAvisynthFile18_49_07_346.avs, line 14)


Attached Files
.zip   HybridDebugOutput.zip (Size: 36,83 KB / Downloads: 9)
Reply
#12
Found the problem, the scaling of the values for SmoothAdjust had a bug.
That I fixed, but now when I call:
ClearAutoloadDirs()
SetFilterMTMode("DEFAULT_MT_MODE", MT_MULTI_INSTANCE)
LoadPlugin("F:\Hybrid\64bit\Avisynth\avisynthPlugins\LSMASHSource.dll")
LoadPlugin("F:\Hybrid\64bit\Avisynth\avisynthPlugins\dither.dll")
LoadPlugin("F:\Hybrid\64bit\Avisynth\avisynthPlugins\SmoothAdjust.dll")
Import("F:\Hybrid\64bit\Avisynth\avisynthPlugins\mtmodes.avsi")
# loading source: C:\Users\Selur\Desktop\Tonight (with Emma Hewitt) (M).mov
# color sampling YUY2@10, matrix: bt709, scantyp: progressive, luminance scale: limited
LWLibavVideoSource("C:\Users\Selur\Desktop\Tonight (with Emma Hewitt) (M).mov",cache=false,format="YUV422P16", prefer_hw=0,repeat=true)
# current resolution: 1920x815
# cropping
Crop(0,1,0,0)# 1920x814
SmoothTweak16(brightness=25600)
# adjust color to RGB32 (color matrix: Rec709)
ConvertToRGB32(matrix="Rec709")
# setting output fps to 25.000fps
AssumeFPS(25,1)
PreFetch(16)
#  output: color sampling RGB32@16, matrix: bt709, scantyp: progressive, luminance scale: limited
return last
I get:
SmoothAdjust: Width and height must be MOD2! (J:\tmp\tempPreviewAvisynthFile21_32_41_409.avs, line 13)
and I have no clue why.

Cu Selur
Reply
#13
Okay, found it.
ConvertToStacked is needed.
Reply
#14
Send you a link to a dev version which should fix all the SmoothAdjust using calls.
Reply
#15
Thank you, now working!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)