This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

'array too big.' error
#1
Hello,

I am getting an 'array too big' error dialog when loading bluray content on multiple discs that have worked in past versions (last was 2024.03.10.1). This is with a default config (no custom profile loaded).

pic and debug log attached.


Attached Files Thumbnail(s)
   

.txt   HybridDebugOutput.txt (Size: 13,64 KB / Downloads: 9)
Reply
#2
Okay, first time seeing this.
From the looks of it the Blu-ray seems to be authored in a way that libbluray can't handle the output.

Hybrid calls:
"C:\Program Files\Hybrid\64bit\ffmpeg.exe" -i "bluray:G:\rips\1080p\THE_STAND"
a. Do you see more infos when you call this in a Windows Command Prompt?
b. Does is work in Hybrid if you disable "Config->Input->Pre-select .mpls with ffmpeg" ?
c. How many files are there in the "G:\rips\1080p\THE_STAND\PLAYLIST"-folder? Assuming there are not too many, can you load them one at a time in Hybrid?

Cu Selur

Ps.: as a workaround you could first remux the blu-ray with mkvtoolnix or makemkv.
Reply
#3
a. I get:
C:\Users\Sub-Zero>"C:\Program Files\Hybrid\64bit\ffmpeg.exe" -i "bluray:G:\rips\1080p\THE_STAND
ffmpeg version N-114213-g098b78df9d-gf5441e441f+1 Copyright (c) 2000-2024 the FFmpeg developers
  built with gcc 13.2.0 (Rev5, Built by MSYS2 project)
  configuration:  --pkg-config=pkgconf --cc='ccache gcc' --cxx='ccache g++' --ld='ccache g++' --extra-cxxflags=-fpermissive --extra-cflags=-Wno-int-conversion --disable-autodetect --enable-amf --enable-bzlib --enable-cuda --enable-cuvid --enable-d3d11va --enable-dxva2 --enable-iconv --enable-lzma --enable-nvenc --enable-zlib --enable-sdl2 --enable-ffnvcodec --enable-nvdec --enable-cuda-llvm --disable-doc --enable-gmp --enable-libmp3lame --enable-libopus --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libx265 --enable-libdav1d --enable-libaom --disable-debug --enable-fontconfig --enable-libass --enable-libbluray --enable-libfreetype --enable-libmfx --enable-libmysofa --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-amrwbenc --enable-libwebp --enable-libxml2 --enable-libzimg --enable-libshine --enable-gpl --enable-avisynth --enable-libxvid --enable-libopenmpt --enable-version3 --enable-librav1e --enable-libsrt --enable-libgsm --enable-libvmaf --enable-libsvtav1 --enable-gnutls --extra-cflags=-DLIBTWOLAME_STATIC --extra-libs=-lstdc++ --extra-cflags=-DLIBXML_STATIC --extra-libs=-liconv --disable-w32threads
  libavutil      59.  1.100 / 59.  1.100
  libavcodec     61.  1.101 / 61.  1.101
  libavformat    61.  0.100 / 61.  0.100
  libavdevice    61.  0.100 / 61.  0.100
  libavfilter    10.  0.100 / 10.  0.100
  libswscale      8.  0.100 /  8.  0.100
  libswresample   5.  0.100 /  5.  0.100
  libpostproc    58.  0.100 / 58.  0.100
Array too big.
../src/libbluray/bdj/bdj.c:614: libbluray-j2se-1.3.4.jar not found.
../src/libbluray/bdj/bdj.c:801: BD-J check: Failed to load libbluray.jar
../src/libbluray/bdj/bdj.c:614: libbluray-j2se-1.3.4.jar not found.
../src/libbluray/bdj/bdj.c:801: BD-J check: Failed to load libbluray.jar

C:\Users\Sub-Zero>

b. disabling that does get me past the error, but then the video encoding immediately crashes. Also, using the crop analysis tool results in a 'crop crashed!' error dialog. Sometimes hybrid crashes after that, sometimes not.

c. the stand has 17 files in PLAYLIST. T2 has 57. I do have to disable the ignore playlist limits in input for the feature playlists to show up in T2.

yes, I know, but some of these blurays have multiple titles that need the playlist files analyzed in order to play back all the clips in the right order (eg Terminator 2 theatrical/directors edition)


Attached Files
.7z   HybridDebugOutput.7z (Size: 39,72 KB / Downloads: 6)
Reply
#4
Seems like there is a general problem with current ffmpeg and Blu-rays.
I'll look into it, but sseing that this doesn't really seem to be Hybrids fault, I'm not sure whether I can fix it.

Cu Selur
Reply
#5
Ok, I understand. Thanks for looking into it.
Reply
#6
What do you get when calling
"C:\Program Files\Hybrid\64bit\ffmpeg.exe" -i "bluray:G:\rips\1080p\THE_STAND\"
?
(doesn't seem like the ffmpeg command line has changed, https://ffmpeg.org/ffmpeg-all.html#bluray)

Cu Selur
Reply
#7
with the trailing backslash, I get:
C:\Users\Sub-Zero>"C:\Program Files\Hybrid\64bit\ffmpeg.exe" -i "bluray:G:\rips\1080p\THE_STAND\"
ffmpeg version N-114213-g098b78df9d-gf5441e441f+1 Copyright (c) 2000-2024 the FFmpeg developers
  built with gcc 13.2.0 (Rev5, Built by MSYS2 project)
  configuration:  --pkg-config=pkgconf --cc='ccache gcc' --cxx='ccache g++' --ld='ccache g++' --extra-cxxflags=-fpermissive --extra-cflags=-Wno-int-conversion --disable-autodetect --enable-amf --enable-bzlib --enable-cuda --enable-cuvid --enable-d3d11va --enable-dxva2 --enable-iconv --enable-lzma --enable-nvenc --enable-zlib --enable-sdl2 --enable-ffnvcodec --enable-nvdec --enable-cuda-llvm --disable-doc --enable-gmp --enable-libmp3lame --enable-libopus --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libx265 --enable-libdav1d --enable-libaom --disable-debug --enable-fontconfig --enable-libass --enable-libbluray --enable-libfreetype --enable-libmfx --enable-libmysofa --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-amrwbenc --enable-libwebp --enable-libxml2 --enable-libzimg --enable-libshine --enable-gpl --enable-avisynth --enable-libxvid --enable-libopenmpt --enable-version3 --enable-librav1e --enable-libsrt --enable-libgsm --enable-libvmaf --enable-libsvtav1 --enable-gnutls --extra-cflags=-DLIBTWOLAME_STATIC --extra-libs=-lstdc++ --extra-cflags=-DLIBXML_STATIC --extra-libs=-liconv --disable-w32threads
  libavutil      59.  1.100 / 59.  1.100
  libavcodec     61.  1.101 / 61.  1.101
  libavformat    61.  0.100 / 61.  0.100
  libavdevice    61.  0.100 / 61.  0.100
  libavfilter    10.  0.100 / 10.  0.100
  libswscale      8.  0.100 /  8.  0.100
  libswresample   5.  0.100 /  5.  0.100
  libpostproc    58.  0.100 / 58.  0.100
../src/libbluray/disc/disc.c:333: failed opening UDF image G:\rips\1080p\THE_STAND"
Array too big.
../src/libbluray/disc/disc.c:437: error opening file BDMV\index.bdmv
../src/libbluray/disc/disc.c:437: error opening file BDMV\BACKUP\index.bdmv

C:\Users\Sub-Zero>

The bottom lines after 'array too big.' now reference the bdmv files rather than the java jar files.
Reply
#8
I created a thread over at doom9s maybe someone has an idea what the problem is.
(couldn't find anything over at https://trac.ffmpeg.org/)
The missing libbluray jar files are no problem, they should only be needed when handling menus.


Cu Selur
Reply
#9
# ffmpeg -i bluray:THE_STAND/
ffmpeg version 4.4.4 Copyright (c) 2000-2023 the FFmpeg developers
  built with gcc 12 (Gentoo 12.3.1_p20240209 p2)
  configuration: --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64 --docdir=/usr/share/doc/ffmpeg-4.4.4-r9/html --mandir=/usr/share/man --enable-shared --cc=x86_64-pc-linux-gnu-gcc --cxx=x86_64-pc-linux-gnu-g++ --ar=x86_64-pc-linux-gnu-ar --nm=x86_64-pc-linux-gnu-nm --strip=x86_64-pc-linux-gnu-strip --ranlib=x86_64-pc-linux-gnu-ranlib --pkg-config=x86_64-pc-linux-gnu-pkg-config --optflags='-O2 -march=alderlake -mtune=alderlake -pipe -fomit-frame-pointer -fno-stack-protector' --disable-static --enable-avfilter --enable-avresample --disable-stripping --disable-optimizations --disable-libcelt --enable-nonfree --disable-indev=oss --disable-indev=jack --disable-indev=sndio --disable-outdev=oss --disable-outdev=sndio --enable-version3 --enable-nonfree --enable-bzlib --enable-runtime-cpudetect --disable-debug --disable-gcrypt --enable-gnutls --enable-gmp --enable-gpl --disable-hardcoded-tables --enable-iconv --disable-libxml2 --enable-lzma --enable-network --disable-opencl --enable-openssl --enable-postproc --disable-libsmbclient --enable-ffplay --enable-sdl2 --enable-vaapi --enable-vdpau --disable-vulkan --enable-xlib --enable-libxcb --enable-libxcb-shm --enable-libxcb-xfixes --enable-zlib --enable-libcdio --enable-libiec61883 --enable-libdc1394 --disable-libcaca --disable-openal --enable-opengl --enable-libv4l2 --disable-libpulse --disable-libdrm --disable-libjack --disable-libopencore-amrwb --disable-libopencore-amrnb --disable-libcodec2 --enable-libdav1d --enable-libfdk-aac --enable-libopenjpeg --enable-libbluray --disable-libgme --disable-libgsm --disable-libaribb24 --disable-mmal --disable-libmodplug --enable-libopus --disable-libmfx --disable-libilbc --enable-librtmp --disable-libssh --enable-libspeex --disable-libsrt --disable-librsvg --disable-ffnvcodec --enable-libvorbis --enable-libvpx --enable-libzvbi --disable-appkit --disable-libbs2b --disable-chromaprint --disable-cuda-llvm --disable-libflite --disable-frei0r --disable-libfribidi --disable-fontconfig --disable-libglslang --disable-ladspa --enable-libass --disable-libtesseract --disable-lv2 --enable-libfreetype --disable-libvidstab --disable-libvmaf --enable-librubberband --disable-libzmq --enable-libzimg --enable-libsoxr --enable-pthreads --disable-amf --disable-libvo-amrwbenc --disable-libkvazaar --disable-libaom --enable-libmp3lame --disable-libopenh264 --disable-librav1e --enable-libsnappy --disable-libsvtav1 --enable-libtheora --enable-libtwolame --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxvid --disable-gnutls --disable-armv5te --disable-armv6 --disable-armv6t2 --disable-neon --disable-vfp --disable-vfpv3 --disable-armv8 --disable-mipsdsp --disable-mipsdspr2 --disable-mipsfpu --disable-altivec --disable-vsx --disable-power8 --disable-amd3dnow --disable-amd3dnowext --disable-fma4 --disable-xop --enable-pic --cpu=alderlake --disable-doc --disable-htmlpages --enable-manpages
  libavutil      56. 70.100 / 56. 70.100
  libavcodec    58.134.100 / 58.134.100
  libavformat    58. 76.100 / 58. 76.100
  libavdevice    58. 13.100 / 58. 13.100
  libavfilter    7.110.100 /  7.110.100
  libavresample  4.  0.  0 /  4.  0.  0
  libswscale      5.  9.100 /  5.  9.100
  libswresample  3.  9.100 /  3.  9.100
  libpostproc    55.  9.100 / 55.  9.100
bdj.c:798: BD-J check: Failed to load JVM library
bdj.c:798: BD-J check: Failed to load JVM library
[bluray @ 0x559b3e0a7600] 6 usable playlists:
[bluray @ 0x559b3e0a7600] playlist 00204.mpls (1:32:30)
[bluray @ 0x559b3e0a7600] playlist 00200.mpls (5:59:02)
[bluray @ 0x559b3e0a7600] playlist 00201.mpls (1:28:38)
[bluray @ 0x559b3e0a7600] playlist 00301.mpls (0:05:29)
[bluray @ 0x559b3e0a7600] playlist 00203.mpls (1:29:03)
[bluray @ 0x559b3e0a7600] playlist 00202.mpls (1:28:52)
[bluray @ 0x559b3e0a7600] selected 00200.mpls
[mpegts @ 0x559b3e0a6bc0] start time for stream 5 is not set in estimate_timings_from_pts
bluray.c:299: 00018.m2ts: no timestamp for SPN 0 (got 0). clip 188889375-428166538.
[mpegts @ 0x559b3e0a6bc0] Could not find codec parameters for stream 5 (Subtitle: hdmv_pgs_subtitle (pgssub) ([144][0][0][0] / 0x0090)): unspecified size
Consider increasing the value for the 'analyzeduration' (0) and 'probesize' (5000000) options
Input #0, mpegts, from 'bluray:THE_STAND/':
  Duration: 25:30:47.14, start: 4197.541667, bitrate: 4213 kb/s
  Program 1
  Stream #0:0[0x1011]: Video: h264 (High) (HDMV / 0x564D4448), yuv420p(progressive), 1920x1080 [SAR 1:1 DAR 16:9], 23.98 fps, 23.98 tbr, 90k tbn, 47.95 tbc
  Stream #0:1[0x1100]: Audio: ac3 (AC-3 / 0x332D4341), 48000 Hz, stereo, fltp, 192 kb/s
  Stream #0:2[0x1101]: Audio: ac3 (AC-3 / 0x332D4341), 48000 Hz, stereo, fltp, 192 kb/s
  Stream #0:3[0x1102]: Audio: ac3 (AC-3 / 0x332D4341), 48000 Hz, stereo, fltp, 192 kb/s
  Stream #0:4[0x1103]: Audio: ac3 (AC-3 / 0x332D4341), 48000 Hz, stereo, fltp, 192 kb/s
  Stream #0:5[0x1200]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
  Stream #0:6[0x1201]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090), 1920x1080
  Stream #0:7[0x1202]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090), 1920x1080
  Stream #0:8[0x1203]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090), 1920x1080
  Stream #0:9[0x1204]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090), 1920x1080
  Stream #0:10[0x1205]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090), 1920x1080
  Stream #0:11[0x1206]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090), 1920x1080
At least one output file must be specified

using the same source data from gentoo linux running ffmpeg 4.4.4..
Reply
#10
Propably works fine with 5.x branch too.
I expect the issue to be only in latest FFmpeg 6.x.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)