This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

dlib 19.24.99 with CUDA
#11
Please try to reinstall the provided wheel.
You can try to rename or delete the file _dlib_pybind11.py.
Then try to do an "import dlib" in python to see the problem is solved.

Dan
Reply
#12
Quote:Please try to reinstall the provided wheel.
python -m pip install dlib-19.24.99-cp312-cp312-win_amd64.whl --force
Processing f:\hybrid\64bit\vapoursynth\dlib-19.24.99-cp312-cp312-win_amd64.whl
Installing collected packages: dlib
  Attempting uninstall: dlib
    Found existing installation: dlib 19.24.99
    Uninstalling dlib-19.24.99:
      Successfully uninstalled dlib-19.24.99
Successfully installed dlib-19.24.99

Quote:You can try to rename or delete the file _dlib_pybind11.py.
F:\Hybrid\64bit\Vapoursynth\Lib\site-packages>ren _dlib_pybind11.py _dlib_pybind11.bak
Quote:Then try to do an "import dlib" in python to see the problem is solved.
F:\Hybrid\64bit\Vapoursynth>python
Python 3.12.3 (tags/v3.12.3:f6650f9, Apr  9 2024, 14:05:25) [MSC v.1938 64 bit (AMD64)] on win32
>>> import dlib
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "F:\Hybrid\64bit\Vapoursynth\Lib\site-packages\dlib\__init__.py", line 20, in <module>
    from _dlib_pybind11 import *
ImportError: DLL load failed while importing _dlib_pybind11: Das angegebene Modul wurde nicht gefunden.
=> not fixed

Cu Selur
Reply
#13
Hello Selur,

  try this version of dlib for python 3.12, built using CUDA 12.1 and cuDNN 8.9.7

Dan

P.S.
Remove any version before install the the attached wheel.
I changed the version number, to have more room to release other builds.
After the install clear the cache: dlib\__pycache__\__init__.cpython-312.pyc


Attached Files
.zip   dlib-19.24.93-cp312-cp312-win_amd64.whl.zip (Size: 2,84 MB / Downloads: 17)
Reply
#14
That version seems to work with codeformer. Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)