This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[HELP] Hybrid ignores my selections...?
Hello!  Hybrid seems to be ignoring all of the settings and selections I choose...  Huh

I'm running Windows 10 Home.  I digitized a VHS at 29.97 FPS.  I'm trying to deinterlace the footage with Hybrid using QTGMC, and Bob it to 59.94 FPS.

- I put my video in Hybrid and selected "passthrough" for audio.
- I went to the x264 tab and changed bitrate to 14000.
- Under the Filtering tab > (De)interlace/telecine sub-tab, I have "QTGMC (Vapoursynth) selected under "Auto deinterlace handling."
- I changed the preset to "very slow."
- I checked "Bob."
- I checked "compare view" and clicked the preview button... and both the "original" and "filtered" fields appear exactly the same.

I must be missing something... I feel like it's right under my nose... any help is MUCH appreciated!  I've spent the past few weeks carefully upgrading my hardware and software for capturing and mastering my VHS rips, and I feel like I'm SO close to having it all figured out... thank you so much in advance!
Sounds like your source is detected as progressive and not interlaced.
(If you had read the [INFO] Infos needed to fix&reproduce bugs,..-sticky and provided proper details, I could have said for sure. Please read the sticky and provide proper details in the future.)

Assuming your source is interlaced, not properly flagged and thus detected as progressive, you should Hybrid know that it is interlaced by overwriting the scan type (Filtering->(De-)Interlace/Telecine->Deinterlace/Telecine Settings->Overwrite input scan type to') to the correct scan type (probably 'top field first') and check your choice through the Vapoursynth Preview.

The 'Auto deinterlace handling' tool-tip:
Quote:Deinterlace handling:
Sets what method will be used to deal with non-progressive content, assuming the output isn't marked as interlaced in the encoder.
Hybrid does only deinterlace if:
a. the source is non-progressive
b. the output is not interlaced
- If your source is flagged as interlaced, but in reality is progressive: overwrite the scan type.
- If your source is flagged progressive, but in reality interlaced: overwrite the scan type.
- If your source is progressive and properly flagged, do not worry Hybrid will not try to deinterlace the source.
=> so if your source is not detected as interlaced Hybrid will not try to deinterlace.

Cu Selur
Thanks so much for the response!

Sorry for my poor job reading the "[INFO] Infos needed to fix&reproduce bugs,.."-sticky... I always told myself that I would never be one of "those" guys who would join a forum and make a post without reading the rules... but my wife and I had our second kid a few weeks ago, and I haven't been thinking clearly due to lack of sleep, haha.

I tried your suggestion, checking the box to "Overwrite input scan type to:" > "top field first."  I also tried "bottom field first."  In every case, the "Filtered" half of the preview window still looks identical to the "Original" half - combing effects and all.

Attached below is the zipped Debug file, as well as a screenshot of the Preview window.

Thanks again for any advice!

Attached Files Thumbnail(s)

.7z   HybridDebugOutput.7z (Size: 28,21 KB / Downloads: 10)
E r r o r   o n   f r a m e   4 1 7 4 3   r e q u e s t :
R e s i z e   e r r o r :   R e s i z e   e r r o r   3 0 7 4 :   u n r e c o g n i z e d   t r a n s f e r   c h a r a c t e r i s t i c s   ( 5 / 0 / 0   = >   0 / 0 / 0 ) .   M a y   n e e d   t o   s p e c i f y   a d d i t i o n a l   c o l o r s p a c e   p a r a m e t e r s .
2024.06.15 - 22:09:41_Windows 10 Version 22H2 (64bit)_2024.05.09.1 - level 9: Got unhandled IPC message:  E r r o r   o n   f r a m e   4 6 3 1 6   r e q u e s t :
Seems like there is a problem with processing the source.
Would need a small sample to reproduce and fix the issue.

Cu Selur
Okay, sounds good.  Would you like me to just edit out a few seconds of the video file and post it here?
Yes, please, do that. (or post a link here or send it to me via pm)
But before that, update to the latest version. 2024.06.16 to be sure, I didn't fix the problem in the past.
(deinstall the old version before installing the new one)

Cu Selur
That file is flagged as 'progressive'.
Scan type                                : Progressive
Looking at the file as if it was interlaced and separating the fields one can see that the fields already have combing on it.
Looks like someone messed up and saved interlaced/telecined content progressivelywithout deinterlacing / applying ivtc.
So applying deinterlacing will not remove the combing since the source is not interlaced.
=> this is not a bug in Hybrid, but you're feeding it broken content.
Whoever created this content, in the form you have it, likely didn't know what they were doing.
If you downloaded this from something like YouTube, downloading it at the native resolution of the content, would have probably been better.

What you can try is:
  • enable 'Filtering->Vapoursynth->Misc->Script->Lower. res. before deinterlace' and Sset it to 720x480
  • enable 'Filtering->(De-)Interlace/Telecine->Deinterlace/Telecine Settings->Overwrite input scan type to' and set it to 'top field first'
that way you can get rid of the combing artifacts, but you will still have ghosting (luma&chroma).
Starting with that, you can try to get rid of some of the ghostings by reducing the frame rate with sRestore and apply some string degrain&denoising.
(for example: script:, result:

Cu Selur
It's me - I'm the one who created that content and didn't know what I was doing, haha.  I appreciate your honesty!

Although... I thought I knew what I was doing.  Perhaps you might be kind enough to give me some advice so I can figure out what I did wrong?

Some quick background:  I've been doing my best to read up and study on how all of this works over the past few years.  I got myself a decent VCR - a JVS HR-7900U with built-in TBC and SVHS output - and for awhile I had been digitizing important family videos (and other cherished tapes) via the Elgato Video Capture cable and hardware.

In recent months, I started to realize that the Elgato cable and hardware... sucks.  I started noticing that it crops the video frame, and besides that, I just didn't like the video quality.  So I decided to start over (fortunately I made sure to keep all the original tapes).

After reading all sorts of reviews and watching all sorts of videos, I recently picked up the GV-USB2 cable, and learned how to use OBS software to capture video.  I immediately saw a NOTICEABLE difference in overall quality with these new hardware and software changes to my setup.  And with OBS, I'm able to deinterlace with Yadif 2x and export at 60fps, and honestly I think it looks really good... but then I started reading about other forms of deinterlacing, like QTGMC... which is what lead me to the Hybrid software.  And then, of course, I saw all the other features that Hybrid offers, and I got really excited to learn about it.

So, back to the tape in question (from which came the clip I sent you).  My understanding was that in order to deinterlace via Hybrid (instead of deinterlacing from the start using OBS's built-in filters), I needed to re-digitize my tapes with deinterlacing turned OFF in OBS.  So, that's what I did to capture this video - acquiring what I thought was a properly-captured, non-deinterlaced video.  And then I proceeded to load it into Hybrid, which led me here.

After your response today about the way my video was digitized, I wonder if perhaps the problem may be in my settings on the GV-USB2's driver software... it appears that there's no way to disable deinterlacing?  Perhaps I'm looking at it wrong.

Attached below is a screenshot of my current settings for my GV-USB2 cable.  I know that this forum isn't for getting help with that particular cable, and I'm not going to insist that you do give me advice with this if you aren't interested in doing so... but I'm just curious if you might have any suggestions.  If not, I understand - I can go elsewhere to try and get help to properly digitize these tapes before returning here for help with Hybrid.

In any case, thank you for the help!

Attached Files Thumbnail(s)
In general, I would not recommend to deinterlace while capturing.
Normally, one would capture:
a. in a lossless (not uncompressed) format (yes, that will create huge files)
b. without deinterlacing, denoising, resizing, etc.
Deinterlacing and filtering in general normally should be done after the capturing, since proper filtering usually can't be done in real time.
The folks over at and can usually help with advice on how to best capture stuff. Smile

Cu Selur

Forum Jump:

Users browsing this thread: 1 Guest(s)