Selur's Little Message Board

Full Version: AviSynth64 does not work for encode / jobs (but viewer works)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Tried in the latest development build I have, 2021.06.08.1. Tried on both Windows 7 and Windows 10 systems. Same problem and errors.

The AviSynth64 viewer works.

But, encodes crash immediately:

Creating job for current source
-> Creating jobs for source: (1)
-> Generating calls for: E:\USER\fin\joga\test64.mp4
  adding x264 calls for source: 1
  createJobs for E:\USER\fin\joga\test64.mp4
  creating attachment extraction subjobs
  creating video subjobs
  creating muxing subjobs
  optimizing the subJobs
-> finished creating subjobs for current source
  added new job with id 2021-07-09@21_40_53_4610
starting 2021-07-09@21_40_53_4610_02_video@21:40:53.471 - E:\USER\fin\joga\test64.mp4
2021-07-09@21_40_53_4610_02_video finished after 00:00:00.063
-> 2021-07-09@21_40_53_4610_02_video crashed: ERROR: C:\Users\ADMINI~1\AppData\Local\Temp\2021-07-09@21_40_53_4610_02.264 is too small! (byteSize: 0byte)
Aborting '2021-07-09@21_40_53_4610_02_video' due to: ERROR: C:\Users\ADMINI~1\AppData\Local\Temp\2021-07-09@21_40_53_4610_02.264 is too small! (byteSize: 0byte)

The above error happens regardless if filters are used. I removed all filters and still got the crash.


# loading source: E:\USER\fin\joga\Proteus2\%06d.png
# color sampling RGB24@8, matrix: bt709, scantyp: progressive, luminance scale: limited
ImageReader(file="E:\USER\fin\joga\Proteus2\%06d.png", start=0, end=4837, fps=25, use_DeviL=true, pixel_type="RGB")
# current resolution: 2624x1920
# filtering
# adjust color to YV12 (color matrix: Rec709)
# setting output fps to 25.000fps
#  output: color sampling YV12@8, matrix: bt709, scantyp: progressive, luminance scale: limited
return last

Debug file (ran the previewer then the job / crash): [attachment=1439]
Will look at it.
Also as a reminder read the start of the normal log:
Quote:This log is only intended for user information. It should not be part of a bug/problem report!!
Problem is that Hybrid adds:
# convert to 10bit for encoder
ConvertBits(10, full=true)
to the encoding script, which is wrong and aborts with:
Error: Script error: ConvertBits does not have a named argument "full"
-> will fix

Cu Selur