Selur's Little Message Board

Full Version: VS - QTGMC 29.97i --> 29.97p = Stutter? // Includes video example
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
CONTEXT: Using Hybrid to deinterlace and clean up some interlaced archival. QTGMC to deint a 29.97i clip to 29.97p and dropping into a 23.98fps timeline. 
Windows 10 and MacOS - Hybrid - Vapoursynth - QTGMC - "Fast" - Even - No Bob - PadMod 16 - ProRes 422 HQ - .MOV

PROBLEM: The export now has a stutter every two frames. The same source media exported out of Avid is smooth with no stutter/cadence. 

EXAMPLE: I made a video which visualizes my problem and the technical details:

MY THEORY: I'm sure this is a setting that I'm missing or that I bumped because I use Hybrid quite a bit and haven't had this issue previously. 


First thing I would recommend is to:
a. use QTGMC with Bob and check the Vapoursynth preview and see whether the content has duplicate frames.
b. if you aim for 23.976 you might want to add sRestore to directly drop the frame rate to 23.976 (this also should get rid of potential duplicates), otherwise your NLE will might do some totally static dropping for frames to get to 23.976. If you really aim for 29.97p in the extract also try using QTGMC with Bob combined with sRestore.
c. also, to be sure this isn't some ProRes incompatibility, check whether when you export to another format that stuttering is also there.

On my way to bed, but if you can share a short sample of the source (you could send me a link via PM) I could try to reproduce the issue. Too groggy atm. for other good ideas.

Cu Selur
Thanks for the quick reply and the wise recommendations. I'll try your recommendation first and if I'm still having issues I'll upload a sample file and bug you again ;-)

Following up on this. Your suggestion worked perfectly. Lined up in my timeline with frame accuracy on top of my mix as hoped.  Big Grin  

The only issue that remains:

***Source files which are .MOV work great!  

*** Source files which are .MP4 do not. The .MP4 files crash and will not even play in the preview window. This is the case for 2997i and 25i . All the filters and settings are the same. The only thing which differs is the container of the source. I tried an Avisynth workflow and same issue. I'm assuming it's a decode setting  Huh

Might be an issue with the source filter, try disabling "Filtering->Vapoursynth->Misc->Source->Prefer LSMASHSource over LWLibAVSource for mp4/mov".
If that does not help, try also disabling "Filtering->Vapoursynth->Misc->Source->Prefer over LWLibAVSource over FFMpegSource2",
If both of these don't help, I'll need a debug output to know what's happening.

Cu Selur
Got it. I'll try that and if it doesn't work I'll resurface with more info. 

Thanks again for the help. I've just sent a little donation as a thank you. 

Thanks for the donation.
Fingers crossed that the problem is solved with that. Smile

Cu Selur
(16.09.2022, 18:29)Z3R0 Wrote: [ -> ]Got it. I'll try that and if it doesn't work I'll resurface with more info. 

Thanks again for the help. I've just sent a little donation as a thank you. 


if it doesn't work.

play the video on the player with the necessary filters and make a screen recording with sound .....
Defeats the hybrid purpose
(19.09.2022, 13:32)n4n Wrote: [ -> ]Defeats the hybrid purpose

give this file to Selyur. if good and kind, it will help.
Pages: 1 2