This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[BUG] I suppose Older items in queue lead to crash
Hello again.


Recently I encountered two bugs and I am not sure if they are related. Using Hybrid 2018.06.23.1

1. First, at some files I got error at loading the file "Unknown attachment type" :
When I click OK the file is loaded, but I am not sure the conversion work well later. I don’t have too many infos about this problem but I can share the source files if is needed. I tried to reproduce the problem later but I couldn’t.

2. I am not very sure, but I think is something wrong with the saved queue when loading it from file. I got a strange crash after the conversion is finished at step 08_muxing (creating mkv file with mkvmerge). The odd thing is, if I clear queue and load the file again and start transcoding, second time it works. I am thinking this problem have something to do with the fact that I loaded the files that crashed from a file queue previously saved (with the same Hybrid version 2018.06.23.1).

For this second bug I managed to save a debug file LVL9 in which I executed the following steps:
- Started Hybrid with the old queue and enabled debug LVL9
- Loaded the file    (that crashed previously). I loaded this file over the old queue and then manually dragged it on top to be transcoded first.
- When I started transcoding, the first file that I just loaded was completed successfully, and the others files that were already on queue crashed one fater another at step 08_muxing (creating mkv file with mkvmerge).
- After two crashes, I stoped the transcoding, exit Hybrid and saved the debug file “HybridDebugOutput for BUG2.txt”.

Please take a look when you have some free time, maybe is really a problem with Hybrid that can be solved. Smile

Hmm, it looks like I have problems attaching a RAR file. I try again here.

No. It looks like i cannot attach files here.  I uploaded it on wetransfer:
"Unknown attachment type" happens when during the job creationg when an unknown file should be muxed as attachment to your input file.
Hybrid only recognizes:
  • *.tff
  • *.otf
  • *.ttc
  • *.jpg
  • *.png
  • *.nfo
as valid attachments.
Seeing that your attachment seems to be a 'tags.xml' file, I suspect that this is some how related to what you are doing in what order,...
-> Ignoring 'Error'-messages is always a bad idea.
Since you can't reproduce the issue I won't try to.

Regarding bug2: I'll adjust Hybrid to clear the current queue, whenever an a queue file is loaded. When I wrote this option I never intended it to be used on an non-empty queue.

LOL. It wasn't my intention to yell, just to make the sentence easier to see. Hehe.  Thank you for the quick reply.

Forum Jump:

Users browsing this thread: 1 Guest(s)