This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Absolute Path to avsinfo not set

i tried avisynth extention for hybrid and failed loading the first script. there is the error messages:

AVSAnalyser: Absolute path for 'avsInfo' not set!

AVSAnalyser created an empty call!

Didn't find a 'Length' info node! -> stream will be ignored

under config/tools there isn't a path to avsinfo. but when i click on "tool versions" in the right upper corner there is

avsInfo: no version info

so it looks like avsinfo isn't installed. but how can i install it (its a windows tools??) and how can i set the path?

i'm on ubuntu 18.04 and i've installed hybrid and the hybrid tools using the ppa from djcj.

This is the avisynth script i try to open, its very easy;

v = LWLibavVideoSource("video.mp4", threads=1)
a = LWLibavAudioSource("audio.mp4")
Quote:its a windows tools??
Yes, like anything related to Avisynth, it's Windows based and used through wine. (which is why I would only use Vapoursynth on Linux machines unless Avisynth is really needed,...)

Did you install 'hybrid-avisynth-extension' and 'hybrid-tools' ? (see:

Cu Selur

ii  hybrid                      1:0.12.8~bionic    amd64              Multi platform Qt based encoding frontend
ii  hybrid-avisynth-extension   180310~bionic      amd64              Hybrid Avisynth extension
ii  hybrid-tools                1:0.12.8~bionic    amd64              All tools required by Hybrid
Hmm,.. seems like there's a problem with the avisynth extension,...
will release a new version in a few hours and write a message to djcj to update the dependency,..
Should avsinfo stored in ~/.hybrid-bin or on an other folder?
.hybrid-bin folder is probably okay (djcj can probably say for sure)
with a bit of luck problem will be solved with the next update and djcj adjusting the Linux installer routines,..

Cu Selur
djcj updated the dependencies, hopefully that fixes the issue.

Cu Selur

Forum Jump:

Users browsing this thread: 1 Guest(s)