This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Esxi running macos For selur
Ok, sleep well.
I will test a little bit old vs new tsMuxer...
I always do clean start for every new dev. version, so it can't be old tools cache problem.

Ok, i see a problem source now - tsMuxer GUI version from https://github.com/justdan96/tsMuxer/releases just don't works on my system.
I got pop-up error message when i load file:
dyld: Library not loaded: /usr/local/opt/freetype/lib/libfreetype.6.dylib
  Referenced from: /private/var/folders/ss/y_mbrf6j0_7cnxvljw_2_wv40000gn/T/AppTranslocation/5545471F-86BB-4CF3-A332-19888F0000D5/d/tsMuxerGUI.app/Contents/MacOS/tsmuxer
  Reason: image not found

I scrolled back and randomly checked few versions up to 2019-12-16--01-10-10.mac-nightly-2019-12-16--01-10-10 and they all same pop-up window there. Feels some global mistake in release from start.
Same problem with tsMuxeR 2021-09-09 Nightly from https://www.videohelp.com/software/tsMux...erdownload

No problem with tsMuxeR 2.6.12 from https://www.videohelp.com/software/tsMux...erdownload

I noticed developers about this problem here: https://github.com/justdan96/tsMuxer/issues/458
Reply
I think I could adjust tsMuxeR to use the libfreetype that is in Hybrids lib folder,...

So I just spend an two hours trying to install Xcode Command Line tools for XCode to have oTool available to check the dependencies of tsMuxeR. (oTool -L "Path to tsMuxeR")
By simply trying to call oTool MacOS prompts you if you want to install the command line tools, but after installing them, closing and reopening all Terminal Windows and restarting MacOS, next time you want to call oTool, the prompt comes again,...
Went to developer.apple.com where I downloaded the Command Line tools dmg and then installed the tool with the included installer,..
-> same result
/usr/bin/oTool
oTool: error: Failed to locate 'oTool'.
xcode-select: Failed to locate 'oTool', requesting installation of command line developer tools.

What the f...?
I checked, XCode -> Preferences -> Locations and there the command line version is shown,..

running "xcode-select --install"
it get
Quote:xcode-select: error: command line tools are already installed, use "Software Update" to install updates
so then why does it want to install them again and again?!?

Theses things are why developers are 'nerved out' by writing code for MacOS, it's always the small things that once worked and after another update something is broken and you don't get decent information on how to fix it,...

Software Updates now show a new update for BigSur 11.6 may be that helps,..


Cu Selur
Reply
Nope, updating MacOS didn't change a thing. Rolleyes
-> I'll try to get this working,..
Reply
Okay, I figured that out.
if you call 'oTool' it will reinstall it, it you use 'otool' it works,.. Angry

okay using:
install_name_tool -change /usr/local/opt/freetype/lib/libfreetype.6.dylib @executable_path/lib/libfreetype.6.dylib tsMuxeR
sadly did not work, it gives me:
dyld: Library not loaded: @executable_path/lib/libfreetype.6.dylib
  Referenced from: /Users/selur/workspace/Hybrid/Hybrid.app/Contents/MacOS/./tsMuxeR
  Reason: Incompatible library version: tsMuxeR requires version 25.0.0 or later, but libfreetype.6.dylib provides version 24.0.0
zsh: abort      ./tsMuxeR
when callling tsMuxer. So a newer libfreetype is needed :/
Reply
Seems justdan96 fixed tsMuxer problem in other way https://github.com/justdan96/tsMuxer/iss...-920830284

Quote:The tsMuxer binaries created through osxcross are statically linked now, so it won't look for those libraries at all. Check the binary created here: https://github.com/justdan96/tsMuxer/act...1215042189
Reply
Nice, then I won't have to do the patching of tsMuxer in the future. Smile

Cu Selur
Reply
It looks really funny how they release all those non-functional versions for macOS during almost 2 years and no one can't point to that mistake. Probably tsMuxer just not too popular tool on macOS Smile
Reply
Yup, most MacOS video editing users don't use open source or free software,..
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)