This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[HELP] after encoding ass into mp4, but there is no subtitle at all
using your dev version tested, still the same problem, mp4 with chapters very lag, fps drops half.
no clue why this happens to you.
Have you tried another source, to be sure it's not just this source that's somehow causing the issue?
yeah, you can send me any sources with chapters to test, especially you said you have no problem with chapters there.

i using another source to encode, but this time it seems at the point of chapters got crash, can't encode complete. i creat output debug file for you.

  added new job with id 2021-07-11@22_22_13_1510
starting 2021-07-11@22_22_13_1510_01_audio@22:22:13.180 - D:\X\del-x\clip\drop-ronaldo.mp4
2021-07-11@22_22_13_1510_01_audio finished after 00:00:10.702
starting 2021-07-11@22_22_13_1510_02_audio@22:22:23.885 - D:\X\del-x\clip\drop-ronaldo.mp4
2021-07-11@22_22_13_1510_02_audio finished after 00:04:40.292
delete C:\Users\x\AppData\Local\Temp\iId_2_aid_0_lang_en_DELAY_3ms_2021-07-11@22_22_13_1510_01.dts
starting 2021-07-11@22_22_13_1510_04_attach@22:27:04.415 - D:\X\del-x\clip\drop-ronaldo.mp4
2021-07-11@22_22_13_1510_04_attach finished after 00:00:00.057
starting 2021-07-11@22_22_13_1510_07_video@22:27:04.478 - D:\X\del-x\clip\drop-ronaldo.mp4
2021-07-11@22_22_13_1510_07_video finished after 00:00:19.102
-> 2021-07-11@22_22_13_1510_07_video crashed: ERROR: C:\Users\x\AppData\Local\Temp\drop-ronaldo_2021-07-11@22_22_13_1510_07.stats was not created!
Aborting '2021-07-11@22_22_13_1510_07_video' due to: ERROR: C:\Users\x\AppData\Local\Temp\drop-ronaldo_2021-07-11@22_22_13_1510_07.stats was not created!
That crashed at the start of the encoding (not when the chapters are added).
It's a bug in the Vapoursynth script.

I see the problem:
clip = subs = core.sub.ImageFile(clip=clip, file=".....sup", blend=False)
should be:
subs = core.sub.ImageFile(clip=clip, file=".....sup", blend=False)
-> will look into it

Cu Selur
Send you a link to a dev version which should fix the .sup embedding problem in the dev version.

Cu Selur
encode completed. using another footage still has same problem, the encoded MP4 with chapters got FPS-drop half, very lag.
What does 'mediainfo -f "PATH TO FILE"' say about the output that lags for you?

Cu Selur
i using mediainfo to open, and select text mode, not find path you said.

you mean debug output? This option is not turned on.

i can't encode MP4 with chapters, only can encode MP4 without chapters, please help.
Assuming the path to the lagging .mp4 is "z:\Test.mp4" I wanted you to call 'mediainfo -f "z:\Test.mp4"'.
If you use the mediainfo gui text mode output is probably the same.
where to run 'mediainfo -f "z:\Test.mp4", tell me please.

Mediainfo has no place to type to run that. mediainfo only supports select mode to view.

Forum Jump:

Users browsing this thread: 1 Guest(s)