This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

ToneMap settings greyed out, encoding with ToneMap enabled fails
#1
Using latest Hybrid from the AUR

ToneMap settings are greyed out, if I encode with ToneMap enabled anyway, it fails. Source is a UHD BD remux.


Attached Files
.7z   HybridDebugOutput.7z (Size: 12,04 KB / Downloads: 7)
Reply
#2
ffmpeg aborts with:
Unable to find a suitable output format for 'zscale=tin=smpte2084:min=bt2020nc:pin=bt2020:rin=tv:t=smpte2084:m=bt2020nc:p=bt2020:r=tv,zscale=t=linear:npl=100,format=gbrpf32le,zscale=p=bt709,tonemap=tonemap=clip:desat=2.000:peak=0.000,zscale=t=bt709:m=bt709:r=tv'
which indeed does look wrong.
will look at it after work and report back
Reply
#3
Yup, the 'tonemap=tonemap="-part was a typo, should only be "tonemap=",
Send you a link to a dev version via pm which should fix the problem.
(can't reproduce the grayed out part here,..)

Cu Selur
Reply
#4
(11.10.2021, 14:49)Selur Wrote: Yup, the 'tonemap=tonemap="-part was a typo, should only be "tonemap=",
Send you a link to a dev version via pm which should fix the problem.
(can't reproduce the grayed out part here,..)

Cu Selur

The development build you sent also has the FFmpeg ToneMap settings greyed out.
But, tonemapping works now Smile
Reply
#5
Can't reproduce the grayed out part here, so can't fix anything about that.
[Image: looks-fine-here.png]
How do you configure it, if it's grayed out?

Cu Selur
Reply
#6
(14.10.2021, 07:50)Selur Wrote: Can't reproduce the grayed out part here, so can't fix anything about that.
[Image: looks-fine-here.png]
How do you configure it, if it's grayed out?

Cu Selur

I don't, but since the checkbox is not greyed out I can still enable it.

Btw, are the Avisynth and Vapoursynth tabs Windows-only? I don't have them...

this is how it looks for me:
   
Reply
#7
Avisynth is Windows only. (gave up on supporting it through wine on Linux&MacOS, too much hassle)
Vapoursynth works fine on Linux and MacOS.
I wrote scripts for Ubuntu to build and install Vapoursynth and the plugins Hybrid uses (see: https://github.com/Selur/hybrid-vapoursynth-addon).
The scripts Hybrid uses are available under: https://github.com/Selur/VapoursynthScriptsInHybrid/
Otherwise the user is required to:
a. build/install Vapoursynth
b. build/install the Vapoursynth filters Hybrid uses
c. let Hybrid know it should look for Vapoursynth (misc.ini + vapoursynth=true see: https://forum.selur.net/thread-10.html)

I checked the source code, there is no code in Hybrid which would disable the "useToneMap"-button.
My guess is that this is some incompatiblity between Qt and the theme you use. Try whether changing the style of Hybrid (Config->View->Style) does change whether the button is greyed out or not.

Cu Selur
Reply
#8
(14.10.2021, 15:32)Selur Wrote: Avisynth is Windows only. (gave up on supporting it through wine on Linux&MacOS, too much hassle)
Vapoursynth works fine on Linux and MacOS.
I wrote scripts for Ubuntu to build and install Vapoursynth and the plugins Hybrid uses (see: https://github.com/Selur/hybrid-vapoursynth-addon).
The scripts Hybrid uses are available under: https://github.com/Selur/VapoursynthScriptsInHybrid/
Otherwise the user is required to:
a. build/install Vapoursynth
b. build/install the Vapoursynth filters Hybrid uses
c. let Hybrid know it should look for Vapoursynth (misc.ini + vapoursynth=true see: https://forum.selur.net/thread-10.html)

I checked the source code, there is no code in Hybrid which would disable the "useToneMap"-button.
My guess is that this is some incompatiblity between Qt and the theme you use. Try whether changing the style of Hybrid (Config->View->Style) does change whether the button is greyed out or not.

Cu Selur

I have Vapoursynth installed, have some Vapoursynth plugins that Hybrid can use installed, and created a (confirmed to be working) misc.ini file with entry vapoursynth=true. However, the Vapoursynth tab is still not there. Do I need to do something with the Hybrid Vapoursynth scripts (https://github.com/Selur/VapoursynthScriptsInHybrid)? I have no idea what to do with them.

The ToneMap button is indeed never greyed out, only the settings are, as can be seen on the screenshot. Changing the style does not change this behavior. When disabling ToneMap I get an error message: "FilteringModel get->found no field useToneMap".
Reply
#9
Ahhh,.. there is the problem. Smile
The "useToneMap" field accidentally was sorted to the Vapoursynth section and since Vapoursynth isn't available it doesn't work. (-> will fix)

What is your output if you call Hybrid in a terminal on startup.
There should be some info about Vapoursynth.

About the scripts: either put them in "~/opt/vapoursynth/vsscripts" or "/usr/share/vsscripts" and Hybrid will find them.

About the plugins&co: Where is Vapoursynth installed on your system?
Also your probably need to install vsViewer (https://github.com/Selur/vsViewer/).
You can also add:
vsPluginsPath="PATH TO YOUR Vapoursynth plugins folder"
vsScriptPath="PATH TO YOUR Vapoursynth scripts folder"
to the misc.ini.

Cu Selur
Reply
#10
(16.10.2021, 13:28)Selur Wrote: Ahhh,.. there is the problem.  Smile
The "useToneMap" field accidentally was sorted to the Vapoursynth section and since Vapoursynth isn't available it doesn't work. (-> will fix)

What is your output if you call Hybrid in a terminal on startup.
There should be some info about Vapoursynth.

About the scripts: either put them in "~/opt/vapoursynth/vsscripts" or "/usr/share/vsscripts" and Hybrid will find them.

About the plugins&co: Where is Vapoursynth installed on your system?
Also your probably need to install vsViewer (https://github.com/Selur/vsViewer/).
You can also add:
vsPluginsPath="PATH TO YOUR Vapoursynth plugins folder"
vsScriptPath="PATH TO YOUR Vapoursynth scripts folder"
to the misc.ini.

Cu Selur

I put the scripts in /usr/share/vsscripts.

Probably the relevant part of the terminal output:

Loading values from: /home/damian101/.hybrid/misc.ini
Folder (/usr/bin/64bit/vsfilters) exists: false
  './64bit/vsfilters' doesn't exist
Folder (/usr/bin/vsfilters) exists: false
  './vsfilters' doesn't exist
Folder (/home/damian101/.hybrid/vsfilters) exists: false
  '/home/damian101/.hybrid/vsfilters' doesn't exist
Folder (/home/damian101/opt/vapoursynth/plugins) exists: false
  '/home/damian101/opt/vapoursynth/plugins' doesn't exist
Folder (/home/damian101/opt/vapoursynth/lib/vapoursynth/) exists: false
  '/home/damian101/opt/vapoursynth/lib/vapoursynth/' doesn't exist
Folder (/home/damian101/.hybrid/vsscripts) exists: false
'/home/damian101/.hybrid/vsscripts' doesn't exist,..
Folder (/usr/bin/vsscripts) exists: false
'./vsscripts' doesn't exist,..
Folder (/usr/share/vsscripts) exists: true
  enabling Vapoursynth support
  using vsScriptPath: /usr/share/vsscripts
GUI initialization starting 17:07:44.831
connecting model handler,..
Folder (/usr/bin/64bit/Avisynth/avisynthPlugins) exists: false
Folder (/usr/bin/32bit/avisynthPlugins) exists: false

But still no Vapoursynth tab.
I have Vapoursynth installed from the Arch community repository (https://archlinux.org/packages/community...poursynth/). There are some Vapoursynth-related binaries in /usr/bin, like vspipe.
I have no idea where my Vapoursynth plugins folder is, there is no folder named "vsfilters" or "vsscripts" anywhere on my system.
I also don't know how to build vsViewer, although I could maybe find out.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)