This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[BUG] Issue with Video Resize.
Version.: Linux 64bit 2021.07.18.1
What I'm trying to do: I'm trying to Resize a Video file from 720X480 with a PAR of 10 by 11 to 640X480 with a PAR of 1 by 1. 
What I expect to Happen: I expect it to work.
What happens: Instead I get a cropped video the size of the output, but it only includes the upper Left Quarter. Plus the Colors are badly misaligned.

I've tried a number of combinations to see if it was anything else, but everything else doesn't matter. Even is i just change the PAR value it still does it. Resize by itself will do it too. I normally Crop off black bars when i Encode and then resize it to what I want, but this build broke it. it worked before. I updated to the newest VSscripts and made sure my plugins were updated as well.

Atteched the debug output and the .VPY

image showing what it does
[Image: oCbyeYc.png]

The raw file with the same scene
[Image: jgk2gT9.png]
Does this happen is you do not resize?
If it does only occure when resizing: Have you tried another resizing method?

Assuming those screenshots were taken with vsViewer it looks like a decoding issue.
No clue whether the issue is due to some bug in the source filter or a problem with the source.
First things I would recommand are:
  • check whether overwriting the "Filtering->(De-)Interlace/Telecine->Deinterlace/Telecine Settings->Overwrite inptu scan type" to 'progressive' fixes the color issue. This disables the deinterlacing (yes you will probably see combing artifacts), but if it fixes the color issue it shows that it's not the source filter, but one of the filters used during the ivtc. As a general side note: if the source is interlaced, like indicated by the source headers, one should not use a ivtc method, if the source on the other hand is wrongly flagged one should 'Overwrite inptu scan type' to telecine.
  • if your hardware supports it try using another value for "Filtering->Vapoursynth->Misc->Source->Libav hardware decoding mode"
  • try using another source filter by disabling "Filtering->Vapoursynth->Preer LWLibAVSource over FFmpegSource2"
  • try whether remuxing the source with MKVToolnix to mkv before using it in Hybrid helps
  • check the source with a tool ment to fix m2ts streams
Also does this happen with all sources or just this one?

Cu Selur
No it does not. It works fine as long as I don't resize.

And the first picture was taken from a finished Encode. VS View crashes from me whenever I try to use it. I'm using VS R54 in case it matters.

The second image was from the Blu Ray. I tried MakeMKV, but it didn't make any difference. I also tried other DVDs and blu rays. Same thing.

Before this I was using version Hybrid_20201229. it was a Dev build you made for me last time I had an issue. It only started happening when I updated to the newest public build. 
It might be a Linux bug, because I had a friend On Windows use the same setting on the same version and it worked fine for him.
Okay, try whether adding 'clip = core.std.SetFieldBased(clip, 0)' in a custom addition before the resizing changes anything.
My guess atm. is that there's a problem with the libfmtconv version on your system.
Will look at it some more after work today, so in 12 hrs or so.

Cu Selur
aye it was libftmconv. Recompiled it and swapped it out and it worked. not sure what happened there to be honest.

VSvewier is still broke all the hell though, but at least i can encode again.
No clue either, why it would stop working, but happy that worked. Smile

Cu Selur

Forum Jump:

Users browsing this thread: 1 Guest(s)