This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[HELP] NVEnC encode bitrate limitiert?
#1
Hallo, habe zufaellig entdeckt das im profile NVEnC fuer Nvidia kodierung, die Bitrate auf 10000kb oder weniger limitiert ist. Warum wurde das geaendert?
Es gibt jedoch sachen die ich mit mehr Bitrate kodieren moechte, ab welcher version wurde das eingefuehrt damit ich die vorherige nutzen kann?  Gruss
Reply
#2
Habe nix geändert.
Fehlt dir da eventuell ne 0?
Kann hier "100000" angeben und das erscheint auch im Aufruf:
NVEnc --y4m -i - --fps 25.000 --codec h265 --profile main --level auto --tier high --sar 1:1 --lookahead 16 --output-depth 8 --vbrhq 100000 --max-bitrate 100000 --gop-len 0 --ref 3 --bframes 0 --no-b-adapt --mv-precision Q-pel --preset default --colorrange limited --colormatrix bt470bg --cuda-schedule sync --keyfile GENERATED_KEY_FILE --output OUTPUTFILE

Habe aber nen Bug entdeckt, dass die Levelbeschränkung falschherum ist. Smile

Cu Selur
Reply
#3
ok, verstehe, aber im fenster sehe ich nur 10000 ich sehe die andere null nicht mehr, naja, nicht schlimm, aber ich habe deshalb alle letzten kodierungen mit 10000 gemacht bis ich das gemerkt habe. Ok, dann speichere ich dann nochmal meine presets mit der richtigen bitrate ab. Vielen Dank  Smile

Nee geht nicht, habe es gerade nochmal probiert und es erscheint 10000 kann nicht mehr eingeben, nur weniger  Sad   Nvidia GTX 970

Ist version  2021.12.05.1
Reply
#4
1. alte Version -> keine Ahnung -> aktualisiere mal
2. was stellst Du genau ein?
   

Cu Selur
Reply
#5
das bild ist eine andere version, bei mir sieht das nicht so aus. Kann ich DIE version runterladen?  Gruss
Reply
#6
Die Version kannst Du nicht einfach herunterladen.
Das ist meine aktuelle dev Version. Smile
Die normale aktuelle Version gibt es bei: https://www.selur.de/downloads

Da Du aber bis dato keinerlei Details zu dem was Du eingestellt hast gegeben hast, kann ich nicht sagen, ob der MixUp mit der MaxBitrate für Level der mir eben aufgefallen ist bei Dir zum Problem führt.

Cu Selur

Ps.: Hab den Thread mal ins deutsch Unterforum geschoben wo er hingehört.
Reply
#7
ja, details. Ich hatte ein profil  mit 12500kb erstellt bei NVEnC schon lange her und das ging wunderbar.  Ich habe ja nichts veraendert ausser mal die treiber der grafikkarte. Und dann irgendwann habe ich auf diese version geuppt, die profiles wurden uebernommen und sonst habe ich nichts gemacht.
In dieser version sehe ich ploetzlich das kaestchen mit den max bitrate zum einstellen, das war vorher nicht, ich glaube mich zu erinnern das es ein default gab mit 40000kb, aber ich weiss nicht mehr genau.
Und ich wollte das limit aufheben indem ich mehr al 10000kb bei MAX bitrate, geht aber NICHT bei meiner version. 

Ich weiss nicht was ich noch sagen soll, es geht NICHT, max auf mehr wie 10000kb einzustellen, nur weniger, was wenig sinn hat , da es ja um eine MAX Einstellung geht, oder?

Ich kann das alles nochmal erklaeren aber dann besser copy/paste. Habe doch schon ganz klar gesagt was ich mache und was NICHT geht.

Es ist jas toll das es in der DEV version funktioniert, aber mir hilft das nicht weiter, hier geht es nicht. 

Weiss nicht was ich noch dazu sagen koennte....  Gruss   Huh
Reply
#8
Quote:ja, details. Ich hatte ein profil mit 12500kb erstellt bei NVEnC schon lange her und das ging wunderbar.
Okay,.. und ich darf jetzt raten was da in dem Profil genau eingestellt ist?

Da ich keine Zeit&Nerven habe:
1. In der Regel hilft es den Sticky zu lesen. Da steht auch wie man genau Details sammelt und was man angeben sollte.
2. Vor einem update sollte man das Changelogs der Versionen die man übersprungen hat lesen. (https://www.selur.de/changelog)
3. Wenn Du alte Profile&Co hast, sollten diese in neuen Versionen neu gespeichert werden, damit sie aktualisiert werden. Ansonsten kann es irgendwann zu Problemen kommen da alte Einstellungen teilweise ignoriert werden.

Hab Dir mal einen Link per pm geschickt, zu meiner aktuellen dev Version, in der ich den Level<>Bitraten MixUp vermutlich behoben habe.


Cu Selur
Reply
#9
Sad 
Hallo, habe die DEV version probiert und jetzt ist es noch schlimmer, vorher max bitrate 10000, jetzt kodiert er bei NVEnc nur mit max 128kb, katastrophe,  
Weiss nicht was ich falsch mache, aktuellster Nvidia treiber installiert. Gruss


Attached Files
.7z   IMG_20220217_125957_1.7z (Size: 1,2 MB / Downloads: 39)
.7z   IMG_20220217_125957.7z (Size: 2,38 MB / Downloads: 38)
.7z   IMG_20220217_130754.7z (Size: 6,09 MB / Downloads: 39)
Reply
#10
Debug output enthölrt keiner brauchbaren Informationen.
Weder Analyse der Quelle noch Hob erstellung oder Abarbeitung.
-> lies mal den Sticky wie man den richtig erstellt, vermute der richtig DebugOutput liegt woanders.
Die Fotos haben auch keine brauchbaren Infos.

Im Report steht der Aufru den Du verwendes:
"C:\Program Files\Hybrid\64bit\NVEncC.exe" --avhw  -i "G:\24h pre code\Romeo must die\BDMV\STREAM\00054.m2ts" --fps 29.970 --codec h265 --profile main --level auto --tier high --sar 10:11 --lookahead 32 --vbrhq 12500 --max-bitrate 128 --aq --aq-strength 10 --gop-len 0 --ref 5 --multiref-l0 5 --multiref-l1 5 --bframes 0 --no-b-adapt --mv-precision Q-pel --preset quality --colorrange limited --colormatrix bt470bg --vpp-deinterlace adaptive --interlace auto --vpp-resize auto --output-res 720x480 --vpp-gauss disabled --cuda-schedule sync --output "G:\Edicion Output TEMP\00054_2022-02-17@13_25_58_6810_08.265"
das ist schon mal etwas.
Vermute Du lädst da irgendeine Konfiguration die noch ne Macke hat.
-> Stell mal das Level von 'auto' auf '5.1'
Scheint das bei H.265 bei level auto die MaxBitrate Beschränkung falsch gesetzt wird.


Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)