This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[BUG] Encoder Crash (Helper1, exitCode: -1073741819)
Ah yes, different sub filters may help. MPC-HC has always handled my subs properly, both when using it's built-in support and when using MadVR.

I assume you know to use the version maintained by clsid and not the dead one on the official website (I've been having to direct friends to this because most people don't seem to know this "hurr durr MPV and VLC are so much better, MPC-HC is dead don't ya know hurr durr").
Problem is I would need Vapoursynth subtitle filters not DirectShow filters.
[Image: MPCHC.png]

xy-VSFilter: doesn't work since it has no option through which one could tell the filter where to find the fonts.
[Image: xy-VSFilter.png] doesn't accept a font path either.

AssRenderer ( does!
It still looks totally different than MPC-HC, but it does not seem to crash,..
-> working on it
Does the Vapoursynth Preview (and encoding) for you if you use Vapoursynth an enable 'Filtering->Vapoursynth->Misc->Script->Prever VsFilterMod' ?

Cu Selur
Preview appears to work, encode in progress.
But the fact that it didn't crash instantly is already saying something, usually VSynth just dies at the beginning if it's gonna die.
No, the crash directly at the start was since I forgot to load a dll. Smile
Ah, fair.

Well, it looks like encoding now works in VapourSynth, but with the same caveat as AviSynth in that some subtitles lose the styling.


[Image: eYSUzLM.png]

[Image: nFyjZMR.png]

Looks to me like it just defaults to Arial or whatever else when it can't use the right font.

If I had to guess, does AviSynth use VsFilterMod and that's why I now get the same result?
This is preferred behavior over outright crashing of course, I'd rather have a result with the wrong font faces than no result at all...
... but I'd like to get the actual fonts to work if possible. It happens with far more fonts than just this one.

Is all styling not working? Or is it because of some font naming issue?
AssRender seems to work. Smile
[Image: Ass-Render.png]
-> sending you a pm with a link for testing in a few minutes.

Cu Selur
Appears to work flawlessly!

I suppose the ASS renderer should be default for processing ASS subtitles.
I swear I've also had similar issues with SRT in the past as well so... I'll let you know if I run into anything new in the future.

Thanks so much for helping me to fix this long-had issue. I'm gonna guess that it hadn't been reported in the past because not a lot of people do hardsubs.

Ya know, I've long noticed that you're a developer who has responded in a timely and helpful fashion to pretty much everyone that posts here and have kept that up for years. I want you to know that devs like you who really care about their projects are a blessing and super appreciated. People like you are why we can have nice things. Sent a little something over your donation thing, it ain't much but I hope it gets you a meal or something [Image: jvfBNpA.gif]

I'll be in-touch for any future issues, now that I finally made an account here I may as well try to contribute by submitting issues.

Forum Jump:

Users browsing this thread: 1 Guest(s)