This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[HELP] Keep input PAR
#1
There's already an option to "keep output PAR", but would it be possible to get the same with input PAR? I am working with a bunch of raw captures which are so raw that they don't even have a PAR hint. I set the input PAR to 8:9, but whenever I load a new source, the PAR gets reset to 1:1...

Version: Hybrid 2022.5.31.1
OS: Windows 11

Thanks!
Reply
#2
Will look at it after work today.

Cu Selur
--- mainly offline 20.-26 of May ---
Reply
#3
Link I send you to the dev version also has a 'keep input PAR' option, but I didn't have time to test it, so let me know whether it works or not.

Cu Selur
--- mainly offline 20.-26 of May ---
Reply
#4
Unfortunately it does not seem to work. Two issues I spotted:
- I put "8:9" as input PAR, ticked "Keep input PAR", and I saved as global profile. I then restart Hybrid and load the same profile. Input PAR has been reset to "1:1".
- I put "8:9" as input PAR, ticked "Keep input PAR", and I loaded my raw video with incorrect PAR. Input PAR has been reset to "1:1".

Thanks
Reply
#5
okay, will try to look at it later. Smile
--- mainly offline 20.-26 of May ---
Reply
#6
Okay, keep input PAR is tricky, since all input parameters are on an ignorelist so that they don't get saved or get loaded,... Wink
--- mainly offline 20.-26 of May ---
Reply
#7
Thought about it. Sorry, but I won't implement a keep input PAR option for the time be.
--- mainly offline 20.-26 of May ---
Reply
#8
No problem. I can work around this by changing the PAR during pre-processing.

EDIT: Out of curiosity, why is the input PAR on an ignorelist? Doesn't it get updated every time a source is added, unless "Keep input PAR" is checked?
Reply
#9
Every model parameter in Hybrid that starts with 'input..' is on the ignoreList so it doesn't end up in the model. Smile
Mainly to avoid issues when models are loaded.
I also added an 'overwrite input PAR' option to Hybrid will send you a link in a few minutes for testing. Smile

Cu Selur
--- mainly offline 20.-26 of May ---
Reply
#10
The new build works perfectly for my use case. You're simply the best, thanks so much!!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)