This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Warning: file size below 1MB
#1
Hello Selur,

   When I'm using the "x265" encoder, with a small file, it is shown the following warning

[Image: x265-File-1mb.jpg]

   how I can configure Hybrid so that this warning is not displayed ?

Thanks,
Dan

P.S.
Attached debug file


Attached Files
.zip   HybridDebugOutput.zip (Size: 25,78 KB / Downloads: 11)
Reply
#2
When not using bit rate based encoding, this message will not appear.
Otherwise, this message will appear, since Hybrid is not designed to create files with bit rate based encoding that are < 1MB.

Cu Selur
Reply
#3
(07.01.2024, 11:26)Selur Wrote: When not using bit rate based encoding, this message will not appear.
Otherwise, this message will appear, since Hybrid is not designed to create files with bit rate based encoding that are < 1MB.

Cu Selur

Why Hybrid is not designed to create files with bit rate based encoding that are < 1MB  ?

This is only a warning and the file will be properly encoded, so why this warning ?

In the warning message is displayed: "-> changing Filesize to 1MB", where this change is applied ? can I do it by myself ?
Reply
#4
Quote:Some example of good encoders not using bit rate encoding ?
It's not about the encoder, but the encoder mode the encoder uses.

Quote:Why Hybrid is not designed to create files with bit rate based encoding that are < 1MB ?
File size prediction, encoder bit rate accuracy simply gets messy and inaccurate due to rounding.

Quote:This is only a warning and the file will be properly encoded, so why this warning ?
File size prediction is messy.

Quote:In the warning message is displayed: "-> changing Filesize to 1MB", where this change is applied ? can I do it by myself ?
No, Hybrid will work as if 1MB was set, but the file size prediction will be wrong.

=> Simply do not use Hybrid with bit rate encoding if you want to encode files where the output will be below 1 MB.

Cu Selur
Reply
#5
(07.01.2024, 11:43)Selur Wrote: => Simply do not use Hybrid with bit rate encoding if you want to encode files where the output will be below 1 MB.

I'm using "x265" with encoding mode: "constant rate factor (1-pass)" and the warning is shown
when I use "x264" with encoding mode: "constant rate factor (1-pass)" the warning is not shown.

I will switch to "x264", but I still not see the need to display a dialog box on the GUI, a simple message entry in the application log should be enough.
Reply
#6
Quote:.., but I still not see the need to display a dialog box on the GUI, a simple message entry in the application log should be enough.
I agree to disagree.

Quote:I'm using "x265" with encoding mode: "constant rate factor (1-pass)" and the warning is shown
I can not reproduce this.
To me, it only happens if a bit rate based encoding mode is used.
I tried to reproduce this by:
  • Resetting Hybrid to its defaults.
  • Setting 'Base->Processing->Video' to 'x265'
  • Loading a source file with 2 frames.
=> No pop-up occurred.

I can only reproduce this with x265 if I switch to a bit rate based encoding mode and change the bit rate.
I can look into it further if you can provide a step-by-step which does allow me to reproduce the problem.

Cu Selur
Reply
#7
btw., totally forgot about it, using
  • "x265->Misc->Random stuff->No too small warning"
  • "x265->Misc->No too small warning"
you can disable this warning for x264/x265.

Cu Selur
Reply
#8
I also missed this option.

Thanks,
Dan
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)