This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Crash
#1
helluh,


I figured out that Hybrid crashes at encode phase, because of a setting in x264 pane. 
 
When i choose and select  "force input to be handled as constant frame rate & Input time codes = from input  that combo causes hybrid to crash.
Now, by just uncheck the box "input time codes" and leave forced input enabled, hybrid encodes from a to z just fine.



Pay attention to this ↓ specific section in the debug, a very LOOOONG list of numbers / → timecodes ? !
2024.04.01 - 15:15:04_Windows 11 Version 23H2 (64bit)_2024.03.26.1 - level 9:  videoCalls:
  CUSTOM ### 1:1 ### 23.976 ### Source_1 ### 0 ### 1920 ### 1080 ### 87156/23.976 ### D:\temp\mymovie.mkv ### mkv ### false ### false ### 2717.5 ### # timecode format v2
0
42.00000000
83.00000000
125.00000000
167.00000000
209.00000000
250.00000000
292.00000000
334.00000000
375.00000000
417.00000000
459.00000000
501.00000000


debug in the attachement.


Ta,


Attached Files
.zip   HybridDebugOutput.zip (Size: 2,17 MB / Downloads: 4)
Reply
#2
Quote:LOOOONG list of numbers / → timecodes ? !
Yes, those are the time codes extracted from your source. One for each frame in the source.

Quote: When i choose and select "force input to be handled as constant frame rate & Input time codes = from input that combo causes hybrid to crash.
"x264->Misc->Input time codes->From input" tells x264 to use the time codes for the output
"Force input to be handled as constant frame rate" tell x264 to assume the input is cfr.
(hopefully you know why you want to combine those two)

The encoding crashes with the error:
x264 [error]: --fps + --tcfile-in is incompatible.
=> I adjusted Hybrid to not add '--fps ..." when 'tcfile-in' is used.

Cu Selur
Reply
#3
(01.04.2024, 16:13)Selur Wrote:
Quote:When i choose and select  "force input to be handled as constant frame rate & Input time codes = from input  that combo causes hybrid to crash.
"x264->Misc->Input time codes->From input" tells x264 to use the time codes for the output
"Force input to be handled as constant frame rate" tell x264 to assume the input is cfr.
(hopefully you know why you want to combine those two)


Is it not desirable to move over as much of info as possible from the input file ?

Especialy regarding the framerates...  I mean, i enable "force input" to absolutely be sure all video content is encoded to an constant framerate.  Is that not the right thing to do?
HW players do have noticeable visuall problems/hickups when playing VFR content for sure .. atleast that's my experience.

Hence why i choose to enable that ↑ .


ta,
Reply
#4
Assuming your source is really VFR and not just has broken time codes.
If you want to convert VFR to CFR, you best should:
1. use Avisynth or Vapoursynth and enabled CFR output
2. make sure to overwrite the output frame rate to a frame rate which still keeps enough of a frame rate that the output will still be decentyly fluid.
=> do whatever gives you decent results, there is no 'proper way' that will always work 'wonderful'.

Cu Selur
Reply
#5
(01.04.2024, 16:40)Selur Wrote: Assuming your source is really VFR and not just has broken time codes.
If you want to convert VFR to CFR, you best should:
1. use Avisynth or Vapoursynth and enabled CFR output
2. make sure to overwrite the output frame rate to a frame rate which still keeps enough of a frame rate that the output will still be decentyly fluid.
=> do whatever gives you decent results, there is no 'proper way' that will always work 'wonderful'.

Cu Selur

Ofcourse one have to take that into consideration ↑ too, i know.. 


ta,

... update regarding latest hybrid build you sent me..

After installing it , i start up hybrid and DC throws the following error (again)..  Again, because with the previous install of hybrid i got the same error ..

[Image: Schermafbeelding-2024-04-01-170614.png]


I guess it most probebly is not reffering to "Apple → Quick Time" LoLz,  but rather something that handles all plugins .. right?

Anyway,  hybrid loads up despite of that message but i get the same crash as soon i enable "input time codes" in x264 pane.


Ta,
Reply
#6
Copying Qt6Widgets.dll Qt6Gui.dll Qt6Core.dll from Hybrid/64bit/Vapoursynth to Hybrid/64bit should fix the delaycut problem.

Quote: i get the same crash as soon i enable "input time codes" in x264 pane.
same crash = same error message inside the debug output?

Cu Selur
Reply
#7
Send you a new link via pm.

Cu Selur
Reply
#8
(01.04.2024, 17:39)Selur Wrote: Copying Qt6Widgets.dll Qt6Gui.dll Qt6Core.dll from Hybrid/64bit/Vapoursynth to Hybrid/64bit should fix the delaycut problem.

Quote: i get the same crash as soon i enable "input time codes" in x264 pane.
same crash = same error message inside the debug output?

Cu Selur

Wouldn't i have told you if it wos even slightly different my royal majesty king "selur"?
I saw pretty much the same notes in the last debug.

You keep telling me , no info = no can do .. That's because .. 

A. there's no new info to provide you with and/or bee, me repeating myself will most probebly not help you either, right?  
(01.04.2024, 18:25)Selur Wrote: Send you a new link via pm.

Cu Selur


So you did..  Big Grin
Reply
#9
okay,... did the new version fix the problem for you?
Reply
#10
(01.04.2024, 19:52)Selur Wrote: okay,... did the new version fix the problem for you?

Ohh... thats the info you looking for Tongue
  
That lil nuisance is past tense / history for now.. 
Also, upon installation i didn't received the "DelayCut / QT platform" error anymore.  

What was that all about anyway, if you care to share Shy ?  Overlooked that bit of info in your previous post.  So if i understand correct, Delaycut plugins and/or some vital *.dll's  where located in the wrong path/folder for some reason ?

I ask because , EXACTLY THAT ↑ would explain why i wos / or still am (have to check it) unable to select and encode from chapter to chapter in hybrid !! Are you aware of that , i still am unable to create a test sample using chapter timings through hybrid ?!? 

TA TA
Cu Toilet (° ^°)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)