This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Several Errors prevented job
#1
I was using version 2024.03.18.1
I loaded an uncompressed RGB clip created by Vitualdub2 , and tried saving it as FFV1 using an MKV wrapper while trying to avoid any other changes to the file other than returning to YUV 422 colour space.
The file is about 6GB, so hard to attach.

There were two errors reported, one of which is attached, regarding a mismatch of frame rates. The second error did not appear when I tried to reproduce the run. It indicated that my requested output was de-interlaced, while my input file was progressive. The input file is not progressive. 

I am not using the latest version since my AVAST ONE virus scanner flags a file QAAC.exe as suspicious enough to block and forward to their in house specialists. Installation completes, the error comes up when I try running Hybrid.Please, read the 'Infos needed to fix&reproduce bugs,..'-sticky before you post about a problem.

[attachment=2363]
   
Reply
#2
read the sticky, share a debug output and details on what you are doing.

Quote:The input file is not progressive.
Hybrid reads the flags from your source file using MediaInfo, if your source isn't progressive but lags, the proper flags you need to overwrite the scan type accordingly.
Reply
#3
Very Interesting!
I was trying to avoid changing the video file, so I selected "none" for de-interlacing. That turns off the option for Overwriting the field order. After your reply, I reset de-interlacing to QTGMC, set the override to BFF, and turned de-interlacing back to none. The job now runs with no problems, and produces the expected output. 

I do note that the Video info box towards the upper right in the BASE window still indicates Progressive.  When I drop the file onto either Mediainfo or EXIFTool there is no information regarding progressive, or interlacing. Is there some way to get more info on the flags in the file, or is Hybrid assuming Progressive if no info is available?

I will try attaching the Debug, file again. It did not work last time.
[attachment=2365]

I tried posting the debug.zip file, and a shorter version of the video file (51 MB AVI) and got an error message:

"The type of file that you attached is not allowed, Please remove the attachment, or choose a different file."


Attached Files
.zip   HybridDebugOutput.zip (Size: 32,79 KB / Downloads: 4)
Reply
#4
Quote:and a shorter version of the video file (51 MB AVI) and got an error message:

"The type of file that you attached is not allowed, Please remove the attachment, or choose a different file."
upload your file somewhere else (not to youtube or somewhere, where it gets reencoded) and post a link to it

About the error: this happens if either:
a. Hybrid is configured in a nonsenical way
b. there is a bug

Quote:I was trying to avoid changing the video file, so I selected "none" for de-interlacing. That turns off the option for Overwriting the field order. After your reply, I reset de-interlacing to QTGMC, set the override to BFF, and turned de-interlacing back to none. The job now runs with no problems, and produces the expected output.
1. Never set Deinterlacing to 'none' unless you know what that really does in Hybrid.
2. Hybrid will not deinterlaced if:
a. the source is progressive
b. the output is interlaced
Quote: is Hybrid assuming Progressive if no info is available?
That is the only thing that makes sense.

Quote:I was trying to avoid changing the video ..
Then set video to passthrough and don't reencode.

Assuming your source is interlaced and you want do deinterlace it let Hybrid know whether it is tff or bff by overwriting the scan type.
If you do want to keep the content interlaced, select an encoder that supports interlaced output and configure it accordingly. Anything else will just cause Hybrid to break parts of the content..

Sadly the debug output didn't help, since it did not include the Vapoursynth script used. (that's a bug that will change in the next release)
Please create another debug output, but also trigger the Vapoursynth Preview, this way I can see the used script in the debug output.
(or open the Vapoursynth script view and paste the script here - inside 'code'-tags - so that I can see the used script)

I'm going to bed know, but I will look at the further details from you tomorrow after work.

Cu Selur

Ps.: using uncompreses RAW RGB usually a bad idea unless your source was RGB to begin with.
Reply
#5
Following up on your post:

I set FFV1 to interlaced BFF, and left the setting of "Override input scan type" to it's Progressive default, and Auto deinterlace handling to QTGMC.

I ran three jobs:
1 A short AVI file, uncompressed YUV 422 interlaced. It ran with the desired FFV1 interlaced output.
2 The original RGB uncompressed file. It also produced the desired output, so the colour space change was not a problem.
3 With auto deinterlace set to NONE.  I got both errors. Guess I broke Hybrid.

Quote:2. Hybrid will not deinterlace if:
a. the source is progressive
b. the output is interlaced

Thank you for the clarification. I had not understood that the FFV1 output setting of Interlaced BFF would override the de-interlace setting. 
For me, at least, it was ambiguous since the settings appear to be contradictory. If I set "auto deinterlace handling" to QTGMC, and "overwrite" to BFF, the Interlace button on the De-interlace/Telecine tab is greyed out, implying that the output will not be interlaced even though I have set FFV1 to interlaced on the encoder tab. 

I now understand the priority. Thanks.

PS: the RGB uncompresssed was an unchanged default from virtualdub2 when I was creating a test file..
I am planning on using Resolve for my editing, and it will not accept AVI files from virtualdub2, so I was trying to re-wrap.
FFV1 appears to be my codec of choice, as both Hybrid, and Resolve will both read and write the format, so I can exchange files without damage.

We can call this one "Solved"
Thanks again.
Peter
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)