This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Dolby Vision to SDR converting problem
When encoding DoVi to SDR using Vapoursynth, I ran into the following problem: in some cases, the algorithm highlights some scenes in the video too much (in preview mode, numerous flickering frames are visible in the direction of increasing brightness a ~1 second before this scene). No matter what settings I adjusted, I couldn't turn off this flickering and floating brightness and force/fix it on some specific scale.
My settings in attach.

Attached Files Thumbnail(s)
I have 0 real world experience with DOV -> SDR, iirc the 'smooth period' setting is what you should try to adjust to get rid of this flickering.

Cu Selur
This is the first thing I tried. None of the settings change the behavior and the encoding algorithm DoVi to SDR.
To make it clear, here is a small video with an example. There are scenes with Patrick Swayze in front of a bright window, the brightness is automatically turned up. Why - is not very clear, it is absolutely unnecessary. I need to turn it off:

P.S. HDR to SDR conversion works perfectly at the same time.
Okay, I would have increased the 'smooth period' not lowered it to 0.
With 0 I would expect such flickering to occur.
As an 'ugly workaround' one could try whether adding Frame->Stabilize->ReduceFlicker or SmallDeflicker helps.

Cu Selur
I just did it all. Smooth Period (1000, 10000), all kinds of settings with ReduceFlicker and SmallDeflicker - no changes, at all, the algorithm continues to turn up the brightness on already bright scenes.
if you are interested, here is this piece of 4K video with DoVi:
I checked, Hybrid does use the latest vs-placebo release.
Might be a bug in libplacebo or vs-placebo, sadly there is nothing I can do.
If you can share a small sample of your source with me, I can look at it more after work today.

Cu Selur
I changed the message above by adding a link to part of the this video DoVi.
I downloaded the file and will look at it after work and report back.
I can reproduce the problem, but no clue why this happens with vs-placebo.
To me, this looks like a bug in vs-placebo, since otherwise I would have expected for it to happen in MPC-HC too
=> your best bet is to report this to the vs-placebo developers, maybe they can fix it.

Cu Selur

Ps.: Maybe something can be done with
PPs.: there is an updated vs-placebo fork:, but from my first test updating the dll doesn't help.
Can you tell me, studying vs-placebo github link, I found several commands that are not presented in Hybrid's Tonemap (Placebo) settings section, these are:

metadata: Data source to use when tone-mapping. Setting this to a specific value allows overriding the default metadata preference logic. Defaults to 0 (automatic selection).
0 Automatic selection
1 None (disabled)
2 HDR10 (static)
3 HDR10+ (MaxRGB)
4 Luminance (CIE Y)
visualize_lut: Display a (PQ-PQ) graph of the active tone-mapping LUT. See mpv docs.
show_clipping: Highlight hard-clipped pixels during tone-mapping.
contrast_recovery: HDR contrast recovery strength. If set to a value above 0.0, the source image will be divided into high-frequency and low-frequency components, and a portion of the high-frequency image is added back onto the tone-mapped output. May cause excessive ringing artifacts for some HDR sources, but can improve the subjective sharpness and detail left over in the image after tone-mapping. Defaults to 0.0.

Can the default settings of these commands (one of them) give the autobrightness effect that we were talking about?

Forum Jump:

Users browsing this thread: 1 Guest(s)