This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

MKV Cutter Question
Argh, put the wrong dll into the package, will fix after work.

Cu Selur
Did a few tests, packed the files I used and uploaded a new version.
So the file should be fine. (tested on Win10 64bit)

Cu Selur
Thanks, just tested on 3 videos and I still get  -

avs [error]: Plugin G:\mkvCutterWithAudio3\ffms2.dll is not an AviSynth 2.6 or 2.5 plugin.
(V:\Movies_mkv\Copied to BU drive\temp\o-001.avs, line 1)
x264 [error]: could not open input file `V:\Movies_mkv\Copied to BU drive\temp\o-001.avs'

ExitCode: -1, ExitStatus: 0
 x264 encoding finished,..
Resetting since x264 crashed,..

I'm on Win7, is it possible the ffms2.dll is different for Win7 vs Win10?

When it hangs here, I cannot read the avs file because it is deleted already. Is there a way to prevent that or would that not help determine the problem?

Wait- just noticed that the ffms2.dll is identical in size and content to the previous one, please check.
Ah, it isn't the ffms2 version it's that there was still a LoadPlugin instead of a LoadCPlugin call.
-> reuploaded MkvCutter_r20190122_untested

Cu Selur
I'm still getting the same error. I don't know why.
1. Aktiviere mal 'keep intermediate' und poste mal das komplette Log.
2. Was für eine CPU hast Du?

Wenn 'keep intermediate' an ist sieht man die Avisynth Skripte (.avs) welche verwendet werden, in diesen sollte immer LoadCPlugin verwendet werden, da die ffms2 version die ich verwende von ist und ein C Plugin ist. Du kannst ja mal die ffms2.dll durch die FFMS2 C-plugin r1315+119 Version ersetzen (Wichtig: 32bit Version muss verwendet werden.) und sehen ob das etwas ändert.

Cu Selur
OK, I'm using i7-3770k cpu.
I tried FFMS2 C-plugin r1315 119 version but no difference.
How do I activate "keep intermediate". I remember seeing it somewhere but can't find it now.
It's where you set the output and the temp folder.
Have you tried another file, just to be sure that this isn't a problem with the source?
Also since the preview works, the ffms2.dll should be fine. :/

Cu Selur
OK, making progress -

In temp\moviename-001.avs, this is the plugin load in the script which hangs I think -


Should the above be LoadCPlugin?

In the main folder this is the plugin load for moviename.avs -


Which seems to be ok I think.
Yes, it should be -> made a version which uses LoadPlugin to avoid the general confusion.

Cu Selur

Forum Jump:

Users browsing this thread: 1 Guest(s)