This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

MKV Cutter Question
Just starting to use mkvcutter. Works real nice. Am I missing something, but can it play a video at normal speed with audio? Today I found how to scroll thru the video by putting the cursor on the timeline and holding down or doing the same thing on the next frame button. The only feature that needs to be added is to be able to stop the video at the exact frame to cut. Doing that without audio is very hard in some cases. If you could add play/pause feature using the spacebar I think it would be nearly perfect. I would make a donation too! Thoughts?
Probably not going to happen. Real time playback isn't planned any time soon since it would require writing a player which plays avisynth scripts.
I might add viewing the wav front of the first audio track in the preview sometime in the future.

Cu Selur
--- mainly offline 20.-26 of May ---
Uploaded an untested version to my google drive which does a downMix to Mono and shows the wavefront of that Mono clip over the video.

Cu Selur
--- mainly offline 20.-26 of May ---
Thanks for this. I can't seem to get this one to start properly. A lot of the files also have smaller sizes than the June 25, 2017. I'm on Windows but the June 25 version starts fine. Error says no QT platform plugin could be initialized. Available platform plugins:windows. Any tips?
Try whether the problem is solved by putting the attached qwindows.dll into the platforms-folder.

Cu Selur
--- mainly offline 20.-26 of May ---
(21.01.2019, 06:15)Selur Wrote: Try whether the problem is solved by putting the attached qwindows.dll into the platforms-folder.

Cu Selur

Yes, that allows it to start and it loaded the video then hung at this point -

initializing the avisynth script environment,..
Loading avisynth.dll
loaded CreateScriptEnvironment definition from dll,..
-> Avisynth error: Not An Avisynth 2 C Plugin: ffms2.dll
(FFMS2.avsi, line 3)
will try to look at it later today after work
--- mainly offline 20.-26 of May ---
Update - I overwrote that ffms2.avsi with another version I had. I thought it was from the r20170625 but no it's not unless I got an older version which was updated to the current version. It has a size of 3948 bytes and starts at the top of the file with this -

# FFmpegSource 2.22 helper functions

Everything seems to work and I do see the waveform now, although I can't drag and drop files to load them in this new version but I could in my other working version.

Update - I'm getting the program to fully run to the end but no file is created on hard drive. Trying another now.
OK, tried 2 more movies and I do get an output from both. I tried the movie that failed again, and again no file created. Here is some of the log -

MKVmerge call: "G:\mkvCutterWithAudio\mkvmerge.exe" @"V:\temp\a-001_reencode_mkvOptions.txt"
MkvMerge finished
deleted V:\temp\a-001_reencode_mkvOptions.txt
mkvMerge finished,..
deleting split list elements,...
ffms2.avsi can be deleted, since it isn't used.
Uploaded a new untested version which should come with a working ffms2.dll and where drag&drop works again. (forgot that some changes were made in Qt 5.12).

No clue about your movie, since the section of the log you posted doesn't hold any useful info.

Cu Selur
--- mainly offline 20.-26 of May ---
ok, thanks, I'll give it a try.

Update - just tried that clip that would not work yesterday and now I get a hang at this point -

avs [error]: Plugin G:\mkvCutterWithAudio2\ffms2.dll is not an AviSynth 2.6 or 2.5 plugin.
(V:\Movies_mkv\Copied to BU drive\temp\a-001.avs, line 1)
x264 [error]: could not open input file `V:\Movies_mkv\Copied to BU drive\temp\a-001.avs'

ExitCode: -1, ExitStatus: 0
x264 encoding finished,..
Resetting since x264 crashed,..

will try others.

Update - Ok, tried a few others and same error as above.

Forum Jump:

Users browsing this thread: 1 Guest(s)