This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[GUIDE] VapourSynth + QTGMC Deinterlace + Hybrid UI FAQ for macOS
Quote:The funny thing is that Waifu2x-w2xc is rather legacy and very slow, but it don't need Vulkan SDK. l33tmeatwad recommend to use faster Waifu2x NCNN Vulkan instead.
Hybrid does support both. (can't test since the vm has no hardware acceleration)

Since the VM does not support snapshots (without breaking the vm), it would be nice if someone could test the installer and check which of the:
* csrutil disable
* sudo spctl --master-disable
* Disable Gatekeeper turning back on automatically after 30 days by typing in Terminal:
sudo defaults write /Library/Preferences/com.apple.security GKAutoRearm -bool NO
* Enabe Gatekeeper by typing in Terminal:
sudo defaults write /Library/Preferences/com.apple.security GKAutoRearm -bool YES
* sudo defaults write com.apple.LaunchServices LSQuarantine -bool NO
are really needed.

Are they only needed during installation or are they needed for Hybrid to work?
Depending on that i would adjust the README.rtf:
Quote:This Package includes:

• ‘Hybrid and Plugins’
 Which includes:
◦ the Hybrid .app-package from https://www.selur.de/
◦ a bunch of VapourSynth filters
◦ ‘D2V Witch 4’ from https://github.com/dubhater/D2VWitch which indexes various video streams and writes D2V files. These will be used in Hybrid with the VapourSynth plugin d2vsource.
• ‘VapourSynth R52’ installer which is needed to use VapourSynth inside Hybrid
• XQuartz 2.7.11 from https://www.xquartz.org/ which is required by Hybrid to read image sequences through the VapourSynth ImageReader.
• VulkanSDK 1.2.148.1 from https://vulkan.lunarg.com/sdk/home which is required by to run Vulkan based VapourSynth filters in Hybrid, i.e. Waifu2x nvk and SRMD

Typical install order would be:
1. Open "VapourSynth+Plugins+Scripts+Hybrid-2020.10.10.dmg"
2. Install "VapourSynth-R52.pkg"
3. Install "Hybrid 2020.09.15 and Plugins.pkg"
4. Install "XQuartz.pkg" (optional)
5. Install Vulkan (optional):
    Open "vulkansdk-macos-1.2.148.1.dmg"
    Open Terminal & browse with the following command:
    cd /Volumes/vulkansdk-macos-1.2.148.1
    Run the following command to install:
    sudo ./install_vulkan.py

For questions and problems you can get support over at https://forum.selur.net .

Cu Selur
Ps.: Sadly QCreator and it's tools do not work on m1 Macs atm. see https://bugreports.qt.io/browse/QTBUG-85279 and https://www.qt.io/blog/qt6-development-h...nd-targets, so using a new m1 Mac isn't even an option atm.
Reply
Instead of using:
sudo defaults write com.apple.LaunchServices LSQuarantine -bool NO
to disable quarantine for downloads in general one could:
xattr -d com.apple.quarantine /path/to/file
to just remove the quarantine for specific files or with
xattr -d com.apple.quarantine /Library/Frameworks/VapourSynth.framework/lib/vapoursynth/*
one cloud disable the quarantine for all the vapoursynth plugins.
with
xattr -r -d com.apple.quarantine /Applications/Hybrid.app/
one cloud disable the quarantine for all the files in the Hybrid.app and with
xattr -r -d com.apple.quarantine /Applications/D2VWitch.app/
the same could be done for D2VWitch.

Cu Selur
Reply
Seems you put legacy Xquartz and legacy vulkansdk versions to the installer
Reply
yup, thought they might still be needed,..
Reply
I mean you put old versions to the new package. Why? Smile
Current XQuartz is 2.8.0 and VulkanSDK is 1.2.170.0
Reply
It also probably make sense to update FranceBB LUTs https://github.com/FranceBB/LinearTransformation
By the way, inside Hybrid there are still few legacy duplicates of those LUTs with slightly different names.
Reply
Hybrid_2021.04.05.1 Released and now available as standalone app or as installer package with VapourSynth and Plugins directly from developer's website http://www.selur.de/downloads

Same time i still continue to support and update my "extended" package as unofficial backup.
Reply


Forum Jump:


Users browsing this thread: g0ren, 1 Guest(s)