Selur's Little Message Board

Full Version: Notification
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
in the Avisynth mode, text notification in WinOS does not work when you hide "hints / help"

in Vapoursynth mode, text notification in WinOS works when you hide "hints / help"


information about FPS and video codec reads incorrectly from the AVI container.

loading 360P 23.97fps progressive 214mb.avi

Media info in Hybrid shows 360P 29.97fps telecine(soft)

the strangest thing is that the same file in Topaz Video AI shows 360p and 59.97fps.....

Only in StaxRip shows and processes correctly

StaxRip automatically changed the input/source to FFVideoSource
Regarding: 'text notification' no clue what is missing, so no clue what you are looking for or what to do.
Regarding: 'information about FPS and video codec reads incorrectly from the AVI container.' No sample, no debug outputs. -> no details, so no clue what is seemingly wrong

Cu Selur
and how will the logs help if the information when loading with an error?
MediaInfo reports the file as:
Scan order                               : 2:3 Pulldown
so it's soft telecined.
There are two ways to handle soft telecine:
1. use a source filter which supports soft telecine (only dgdecnv can do this atm.)
2. handle it like it was normal telecine.
Not knowing what source filter will be used on analysis, Hybrid properly reports the file as 29.976 with (soft) telecine.
So the content will be handled either as soft telecine or normal telecine depending on the decoder.

The real problem is: your file is mislabed.
It's not an .avi, but a mpeg-2 program stream file, which should probably use .mpg as extension.
Hybrid assumes it is an .avi file.

=> fix your input extension, then depending on the source filter Hybrid will either apply ivtc or soft ivtc and the decoding should be fine.
Hybrid will not try to educate users that it's a stupid thing to rename file extensions.

Cu Selur
this video file was converted to 4k60fps and forgotten...

(Letzte Bitte) please help with this file
Quote:this video file was converted to 4k60fps and forgotten...
Confused. The file to linked to is 854x476 @ 29.97fps not 4k@60,... + it was encoded with a way too low bitrate at some point of its processing history and from looking at it, it probably once was interlaced (or telecined) and didn't get properly handled.
=> is it the wrong file ?

LOL, that clip is a nice example why one should be wary when using stuff like CodeFormer (
Here's a small image sequence:
[Image: grafik.png]
[Image: grafik.png]
[Image: grafik.png]
[Image: grafik.png]
[Image: grafik.png]
[Image: grafik.png]
[Image: grafik.png]
[Image: grafik.png]
[Image: grafik.png]
[Image: grafik.png]

atm. that source is not even proper SD content,...

Cu Selur
Huh Huh Huh perhaps due to rain and wind, the "equipment", the cameras filmed with errors, and the "cameramen" and the "director" could not cope.

I tried to fix the FPS, it did not work
On what sample?
What did you do to try to fix the fps?
What fps are you trying to achieve?

Cu Selur
on this video track. Big Grin FPS to make it smooth without freezes and jumps

I tried only automatic - interpolation and IVTC and deinterlacing
Which of the files:
  • FPS damaged 130806 source.mp4
  • FPS bugged 23.976fps.mpg (renamed from .avi since it was wrong)
are you having problems with?

Looking at 'FPS bugged 23.976fps.mpg'
using DGDecNV or DGDecode:
# ColorMatrix: adjusting color matrix from 470bg to 709
# adjusting luma range to 'limited' due to post clipping
clip = core.resize.Bicubic(clip=clip, matrix_in_s="470bg", matrix_s="709", range_in=0, range=0)
clip = core.std.CropRel(clip=clip, left=0, right=0, top=54, bottom=58)# cropping to 720x368
# Denoising using QTGMC
clip = havsfunc.QTGMC(Input=clip, Preset="Fast", InputType=3, TR2=1, TFF=False, SourceMatch=0, Lossless=0, opencl=True)
# contrast sharpening using CAS
clip = core.cas.CAS(clip=clip, sharpness=0.650)
clip = core.misc.SCDetect(clip=clip,threshold=0.150)
# adjusting color space from YUV420P8 to RGBS for vsRIFE
clip = core.resize.Bicubic(clip=clip, format=vs.RGBS, matrix_in_s="709", range_s="limited")
# adjusting frame count&rate with RIFE, target fps: 60fps
clip = core.rife.RIFE(clip, model=22, fps_num=60, fps_den=1, sc=True) # new fps: 60
# resizing using NNEDI3CL
# current: 720x368 target: 1280x552 -> pow: 2
clip = edi_rpow2.nnedi3cl_rpow2(clip=clip, rfactor=2) # 1440x736
# adjusting resizing
clip = core.fmtc.resample(clip=clip, w=1280, h=552, kernel="spline64", interlaced=False, interlacedd=False)
clip = core.std.AddBorders(clip=clip, left=0, right=0, top=4, bottom=4) # add borders to archive mod 16 (vsSangNom) - 1280x560
# adjusting color space from RGBS to YUV444PS for vsSangNom
clip = core.resize.Bicubic(clip=clip, format=vs.YUV444PS, matrix_s="709", range_s="limited")
# applying AA using SangNom
clip = core.sangnom.SangNom(clip=clip, aa=[48,0])
clip = core.std.CropRel(clip=clip, left=0, right=0, top=4, bottom=4) # removing borders (vsSangNom) -  1280x552)
seems to work fine here (as a start, creation 720p@60fps).
There are quite a few jumps I would call intentional, that I would say are meant to be this way.

Cu Selur
Pages: 1 2