This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[HELP] No Preview / Hybrid not responding
What is your output format?
Input - ProRes 422HQ SD PAL 25fps / Output ProRes 422HQ 1080i 25fps
Quote:Output ProRes 422HQ 1080i 25fps
Normally enabling "ProRes->Interlacing" should do the trick.
Might be a bug if Hybrid still deinterlaces.
-> looking into it.

Cu Selur
I already tried that setting, may be a bug?


Add file (ProRes 422HQ SD PAL Interlaced)
-> ProRes 422HQ
-> Deinterlacing - Off
Crop/Resize-> Convert to square pixels
Crop/Resize -> Height 1080
Filtering -> DeGrain -> MLDegrain
Filtering -> Sharpen -> CAS
Filtering -> Frame -> Resize -> NNEDI3
Quote:I already tried that setting, may be a bug?
Yes, it's a bug.
Fixed it locally, will send you a new dev version for testing.

Folling your step-by-step, I did the following:
  1. started Hybrid.
  2. opened the file you send (Base->File open).
  3. set 'Base->Processing->Video' to 'ProRes'.
  4. set 'ProRes->Profile' to 'ProRes 422HQ'.
  5. enabled 'ProRes->Interlacing'.
  6. (I did not touch the Deinterlacing, since it now shouldn't be applied.)
  7. I enabled 'Crop/Resize->Base->Pixel Aspect Ration (PAR)->Convert output to PAR'.
  8. I set 'Crop/Resize->Base->Picture Resize->Auto adjust' to 'width'.
  9. I set 'Crop/Resize->Base->Picture Resize->Target resolution' to '1080' (no Output resolution shows (1476x1080).
  10. I enabled 'Filtering->Vapoursynth->DeGrain->MLDegrain'.
  11. I enabled 'Filtering->Vapoursynth->Sharpen->CAS'.
  12. I enabled 'Filtering->Vapoursynth->Frame->Resize->Resizer'.
  13. I set 'Filtering->Vapoursynth->Frame->Resize->Resizer' to 'NNEDI3'
I pressed the 'Vapoursynth Preview' button and Hybrid froze. Smile (this is a bug, not sure where atm.)
-> looking into it.

Just to make sure: This is what you did, right?

Cu Selur
Yes, that looks OK.
Okay, I know what causes the problem.
Since NNEDI3 does not work on interlaced content, Hybrid needs to either deinterlace and then reinterlace or split the interlaced frames into their field and apply the filter on both fields. (This can be controlled through 'Filtering->Vapoursynth->Script->Filter interlace handling'.)
And there is the bug, in which Hybrid does not properly set all the variables and thus when splitting into fields the cropHeight&Width are 0 which when causes an infinite loop during the pow-calcculation for NNEDI3.
-> looking into it.

Cu Selur
What could I use instead of NNEDI3?
Issue isn't NNEDI3, which actually does support interlaced content, but the combination of filtering with filters that do support interlacing and those that do not. (like CAS)
Resizers that will fail, are:
  • NNEDI3
  • Anime4k
  • BasicVSR
  • RealSR
  • SRMD
which are some of the best.
Setting 'Filtering->Vapoursynth->Script->Filter interlace handling' to something else than 'separate fields' should work until I figure out how to fix it for 'separate fields' too.

Cu Selur

Forum Jump:

Users browsing this thread: 1 Guest(s)