This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[HELP] No Preview / Hybrid not responding
Debug file attached.
Debug output shows no errors.
Seeing the input I suspect the problem is that afaik there is no source filter for Vapoursynth which supports .mxf files.

Cu Selur
Nope that's not it. Tested a few mxf files I had here and they worked fine.
-> Would need a sample and details what you did exactly to reproduce the issue.

Cu Selur
The first time I processed the file with QTGMC de-interlacing and it worked fine. 

Can you identify the filter that is not compatible with .MXF files?

Converting to ProRes 422HQ before processing via Hybrid.
That is why I need a sample and specific steps what you do, since I can't reproduce the issue here.

Here are a few thing that seem strange:
  • The the first 3370947 lines in the debug output contains the processing of another file.
  • Looking at the debug output I also see huge delays for audio&video
    "Delay : 9 h 57 min 7 s 360 ms"
  • I see tons of errors that Hybrid can't find temporary created Vapoursynth scripts:
    no clue why that would happen unless some anti virus tool or similar is interfering.
    Later in the script it seems to work.
-> no clue what you did there, but the current debug output is useless. (unless I would spend hours reading it, which is not happening)

Cu Selur
It looks like it's the HQDering filter with interlaced/upscaled video. As soon as I select it, Hybrid stops responding.
I started Hybrid, oepend an interlaced source, enabled HQDering, opened the Vapoursynth Preview.
# Imports
import vapoursynth as vs
import os
import ctypes
# Loading Support Files
Dllref = ctypes.windll.LoadLibrary("i:/Hybrid/64bit/vsfilters/Support/libfftw3f-3.dll")
import sys
# getting Vapoursynth core
core = vs.core
# Import scripts folder
scriptPath = 'i:/Hybrid/64bit/vsscripts'
sys.path.insert(0, os.path.abspath(scriptPath))
# Loading Plugins
# Import scripts
import mvsfunc
import havsfunc
# source: 'G:\TestClips&Co\files\ProRes\'
# current color space: YUV422P10, bit depth: 10, resolution: 720x576, fps: 25, color matrix: 170m, yuv luminance scale: limited, scanorder: top field first
# Loading G:\TestClips&Co\files\ProRes\ using LibavSMASHSource
clip = core.lsmas.LibavSMASHSource(source="G:/TestClips&Co/files/ProRes/")
# Setting color matrix to 170m.
clip = core.std.SetFrameProps(clip, _Matrix=6)
clip = clip if not core.text.FrameProps(clip,'_Transfer') else core.std.SetFrameProps(clip, _Transfer=6)
clip = clip if not core.text.FrameProps(clip,'_Primaries') else core.std.SetFrameProps(clip, _Primaries=5)
# Setting color range to TV (limited) range.
clip = core.std.SetFrameProp(clip=clip, prop="_ColorRange", intval=1)
# making sure frame rate is set to 25
clip = core.std.AssumeFPS(clip=clip, fpsnum=25, fpsden=1)
# setting field order to what QTGMC should assume (top field first)
clip = core.std.SetFrameProp(clip=clip, prop="_FieldBased", intval=2)
# Deinterlacing using QTGMC
clip = havsfunc.QTGMC(Input=clip, Preset="Fast", TFF=True) # new fps: 25
# make sure content is preceived as frame based
clip = core.std.SetFieldBased(clip, 0)
clip = clip[::2]
# deringing using HQDeringmod
clip = havsfunc.HQDeringmod(clip, nrmode=2, darkthr=3.0)
# adjusting output color from: YUV422P10 to YUV420P10 for x265Model
clip = core.resize.Bicubic(clip=clip, format=vs.YUV420P10, range_s="limited")
# set output frame rate to 25.000fps
clip = core.std.AssumeFPS(clip=clip, fpsnum=25, fpsden=1)
# Output
-> no issues
=> can't reproduce it, so I can't fix it.

Going to bed now, since there are no details which allow me to reproduce the issue.

Cu Selur
I'm also upscaling to 1080i, with no deinterlacing. I'll send a sample clip tomorrow.
Also write a step-by-step of what you do and I can try to reproduce it tomorrow.
Click orders are important.

Cu Selur
I'm trying to upscale to 1080i, so I have disabled de-interlacing. When I start the job, it aborts and says encoding is set for progressive out, but the input is not progressive. Where do I set the encoder for interlaced in and out?

Forum Jump:

Users browsing this thread: 1 Guest(s)