This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[HELP] 25i to 29.97i with interpolation
I have notice on some scenes with panning shots that the video seems to stutter - is there a way to avoid this and make the movements smooth?
Reply
Depends on why it's not smooth,..
If it's because of duplicate frames 'FillDrops' or 'FillDuplicateFrames' might help, otherwise interpolating to a higher frame rate might help.

Cu Selur
Reply
Is it possible to perform theĀ 25i to 29.97i with interpolation set to Avisynth? I ask because the Spotless controls have superior removal options in Avisynth, it can be set to target white spots only etc.

I tried to set it up last week, but I could not get it to run.
Reply
Should work the same way it does as in Avisynth.
Bob deinterlace to 50p, interpolate to 59.94 set output to interlaced.

Quote:Spotless controls have superior removal options in Avisynth, it can be set to target white spots only etc.
Avisynth SpotLess:
SpotLess(clip c,int "RadT",int "ThSAD",int "ThSAD2",int "pel",bool "chroma", int "BlkSz",Int "Olap",bool "tm",Bool "glob",Float "bBlur")
Vapoursynth SpotLess:
def SpotLess(clip: vs.VideoNode, radT: int = 1, thsad: int = 10000,  thsad2: int = None, pel: int = None, chroma: bool = True, ablksize: int = None, aoverlap: int = None, asearch: int = None, ssharp: int = None, pglobal: bool = True, rec: bool = False, rblksize: int = None, roverlap: int = None,          rsearch: int = None, truemotion: bool = True, rfilter: int = None, blur: bool = False,  ref: vs.VideoNode = None)
Are you sure you are mean SpotLess? I suspect you mean DeSpot, which in Vapoursynth is really limited.

Cu Selur
Reply
I can't get the same scripts to run in AviSynth, lots of errors. Will post some reports here shortly.
Reply
try to TWICE encoding processing

1. deinterlacing without a 'BoB' - QTGMC + Progressive or TFF/BFF
2. Interframe 30fps
Reply
I'm not having much luck running the same scripts in AVIsynth.

Quote:Input is completely analysed,...
Couldn't find 'DePulse64' in the filter order, adding 'KillPulse32' at the end.
using 32bit AvisynthViewer: C:\Program Files\Hybrid\32bit\avsViewer.exe
Couldn't find 'DePulse64' in the filter order, adding 'KillPulse32' at the end.
using 32bit AvisynthViewer: C:\Program Files\Hybrid\32bit\avsViewer.exe
Couldn't find 'DePulse64' in the filter order, adding 'KillPulse32' at the end.
M:\IN\original cut.mov
Couldn't find 'DePulse64' in the filter order, adding 'KillPulse32' at the end.
using 32bit AvisynthViewer: C:\Program Files\Hybrid\32bit\avsViewer.exe
Avisynth preview error: -> Evaluate: Unhandled C++ exception! (M:\TEMP\tempPreviewAvisynthFile10_00_35_906.avs, line 63)
Couldn't find 'DePulse64' in the filter order, adding 'KillPulse32' at the end.

Any ideas how to fix this? I can't get a preview window to load.
Reply
Is it possible to process the SD interlaced PAL 25fps video through AVIsynth's DeSpot (better noise removal controls) and output the DeSpot version with identical interlacing?

I can then process this DeSpot file through Vapoursynth and interpolate/upscale to 29.97i as usual.
Reply
Since DeSpot in Avisynth supports interlaced content, Hybrid will load the source, apply the filter and return the output.
If you set your output to be interlaced, Hybrid will create interlaced output flagged like the input.
This should work fine if your input is TFF, BFF.
I expect this will cause issues if the input is mixed or telecined.

As a side note: it is possible to use Avisynth filters in Vapoursynth (assuming they are both 64bit).
So if it's just DeSpot you are missing, you could add it in a custom section behind the deinterlacing in the Vapoursynth clip. Smile
Here's an example:
core.avs.LoadPlugin("F:/Hybrid/64bit/Avisynth/avisynthPlugins/despot.dll")
# requires colorformat YUV420P8
clip = core.avs.DeSpot(clip, median=False,p1=24,p2=12,pwidth=6,pheight=5,ranked=True,sign=0,minpts=0,maxpts=0,p1percent=10,dilate=1,fitluma=True,blur=1,tsmooth=0,motpn=True,seg=2,color=False,mscene=0,mthres=16,mwidth=7,mheight=5,show=0,show_chroma=False,interlaced=False)

return clip
Note:
a. I added all parameters (this is not required)
b. instead of Avisynths 'true/false' 'True/False' needs to be used
c. The first parameter in your filter call needs to be the clip.
d. the '# requires colorformat YUV420P8' is needed to let Hybrid know that the used filter requires this color format.
e. this works only with progressive filtering, since I haven't come around to write support to let Hybrid know the used filter supports interlacing.

Cu Selur
Reply
Quote:Since DeSpot in Avisynth supports interlaced content, Hybrid will load the source, apply the filter and return the output.
If you set your output to be interlaced, Hybrid will create interlaced output flagged like the input.
This should work fine if your input is TFF, BFF.
I expect this will cause issues if the input is mixed or telecined.

Thank you. Smile

It's basic PAL 25i footage shot on video back in the early 1980s, hence the need to remove video dropouts.

So I need to set ProRes to Interlacing = Top, set De-Interlacing to NONE, is there anthing else I need to set for interlaced output?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)